When using inxi, perl starts moaning about locale

inxi:

$ inxi
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_GB",
        LC_ALL = (unset),
        LC_ADDRESS = "en_GB.UTF-8",
        LC_NAME = "en_GB.UTF-8",
        LC_MONETARY = "nl_NL.UTF-8",
        LC_PAPER = "en_GB.UTF-8",
        LC_IDENTIFICATION = "en_GB.UTF-8",
        LC_TELEPHONE = "en_GB.UTF-8",
        LC_MEASUREMENT = "nl_NL.UTF-8",
        LC_TIME = "en_GB.UTF-8",
        LC_NUMERIC = "en_GB.UTF-8",
        LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
CPU: Quad Core Intel Core i5-4690 (-MCP-) speed/min/max: 2389/800/3900 MHz Kernel: 5.2.11-3-CHAKRA x86_64
Up: 32m Mem: 996.7/7842.8 MiB (12.7%) HDD: 2.84 TiB (27.7% used) Procs: 168 Shell: bash 5.0.11 inxi: 3.0.10

Also, when using man, I get this:

$ man inxi
man: can't set the locale; make sure $LC_* and $LANG are correct

locale:

$ locale
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC=en_GB.UTF-8
LC_TIME=en_GB.UTF-8
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY=nl_NL.UTF-8
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER=en_GB.UTF-8
LC_NAME=en_GB.UTF-8
LC_ADDRESS=en_GB.UTF-8
LC_TELEPHONE=en_GB.UTF-8
LC_MEASUREMENT=nl_NL.UTF-8
LC_IDENTIFICATION=en_GB.UTF-8
LC_ALL=

Where to look?

List currently enabled locales:

$ locale -a
$ locale -a
C
en_GB.utf8
en_US.utf8
POSIX

Uncomment the locales you want (en_GB.UTF-8 and nl_NL.UTF-8, judging by your output from locale) in /etc/locale.gen, write the file to disk, and run this to generate the locales:

# locale-gen

# indicates the default prompt for the root user, as opposed to $ which is the default prompt for any other user.

The system default locale is set in /etc/locale.conf with the environment variable LANG, like so:

LANG="sv_SE.UTF-8"
LANGUAGE="en_US.UTF-8:sv_SE.UTF-8"
LC_ADDRESS="sv_SE.UTF-8"
LC_COLLATE="sv_SE.UTF-8"
LC_CTYPE="sv_SE.UTF-8"
LC_IDENTIFICATION="sv_SE.UTF-8"
LC_MEASUREMENT="sv_SE.UTF-8"
LC_MESSAGES="C"
LC_MONETARY="sv_SE.UTF-8"
LC_NAME="sv_SE.UTF-8"
LC_NUMERIC="sv_SE.UTF-8"
LC_PAPER="sv_SE.UTF-8"
LC_TELEPHONE="sv_SE.UTF-8"
LC_TIME="sv_SE.UTF-8"

Here is my ~/.config/plasma-localerc:

[Formats]
LANG=en_US.UTF-8
LC_COLLATE=sv_SE.UTF-8
LC_MEASUREMENT=sv_SE.UTF-8
LC_MONETARY=sv_SE.UTF-8
LC_NUMERIC=sv_SE.UTF-8
LC_TIME=sv_SE.UTF-8
useDetailed=true

[Translations]
LANGUAGE=en_US:en_GB:sv

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.