Upgrades for xorg, kernel and graphics drivers include important changes and might require manual intervention

xorg
kde-frameworks
manual-intervention
kde-applications
kde-plasma
mesa
linux
(Neofytos Kolokotronis) #32

Hello, sorry to hear you have issues logging in, it is always frustrating.

Here are some questions to help you troubleshoot:

  1. Did you follow the instructions in the initial thread on switching away from catalyst?
  2. Did you install the right drivers for your card?
  3. Can you switch to another tty using ctrl+alt+F3? If yes, what is the output of inxi -F (to see the details for your system) and sudo journalctl -p err (to check for possibly related errors)?
  4. Did you try booting into fallback mode and trying to manually run startx to check for any relevant output?
(aram heller) #33

Hi Tetris,

Thanks for the reply. As to the questions:

1 & 2) Sort of, but I wasn’t clear which video driver to install since I’m using VirtualBox (see below)

  1. While I can’t get into this VM, and can’t get to a different TTY, I can get into my testing VM, which upgraded successfully a few weeks back. The output for inxi on that one is:

    Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends e[1;34mSystem: e[0;37m e[1;34mHost:e[0;37m Testing e[1;34mKernel:e[0;37m 4.12.4-1-CHAKRA x86_64 e[1;34mbits:e[0;37m 64 e[1;34mDesktop:e[0;37m KDE Plasma 5.10.5e[0;37m e[1;34m e[0;37m e[1;34mDistro:e[0;37m Chakrae[0;37m e[1;34mMachine: e[0;37m e[1;34mDevice:e[0;37m oracle e[1;34mSystem:e[0;37m innotek e[1;34mproduct:e[0;37m VirtualBox e[1;34mv:e[0;37m 1.2 e[1;34mserial:e[0;37m N/Ae[0;37m e[1;34m e[0;37m e[1;34mMobo:e[0;37m Oracle e[1;34mmodel:e[0;37m VirtualBox e[1;34mv:e[0;37m 1.2 e[1;34mserial:e[0;37m N/Ae[0;37m e[1;34m e[0;37m e[1;34mBIOS:e[0;37m innotek e[1;34mv:e[0;37m VirtualBox e[1;34mdate:e[0;37m 12/01/2006e[0;37m e[1;34mCPU: e[0;37m e[1;34mDual coree[0;37m Intel Core i5-4570 (-MCP-) e[0;37me[1;34mcache:e[0;37m 6144 KBe[0;37m e[1;34m e[0;37m e[1;34mclock speeds:e[0;37m e[1;34mmax:e[0;37m 3192 MHz e[1;34m1:e[0;37m 3192 MHz e[1;34m2:e[0;37m 3192 MHze[0;37m e[1;34mGraphics: e[0;37m e[1;34mCard:e[0;37m InnoTek Systemberatung VirtualBox Graphics Adaptere[0;37m e[1;34m e[0;37m e[1;34mDisplay Server:e[0;37m N/A e[1;34mdrivers:e[0;37m modesetting (unloaded: vesa) e[1;34mtty size:e[0;37m 96x49e[0;37m e[1;34mAudio: e[0;37m e[1;34mCarde[0;37m Intel 82801AA AC'97 Audio Controller e[1;34mdriver:e[0;37m snd_intel8x0e[0;37m e[1;34m e[0;37m e[1;34mSound:e[0;37m Advanced Linux Sound Architecture e[1;34mv:e[0;37m k4.12.4-1-CHAKRAe[0;37m e[1;34mNetwork: e[0;37m e[1;34mCard:e[0;37m Intel 82540EM Gigabit Ethernet Controller e[1;34mdriver:e[0;37m e1000e[0;37m e[1;34m e[0;37m e[1;34mIF:e[0;37m enp0s3 e[1;34mstate:e[0;37m up e[1;34mspeed:e[0;37m 1000 Mbps e[1;34mduplex:e[0;37m full e[1;34mmac:e[0;37m 08:00:27:f3:11:a3e[0;37m e[1;34mDrives: e[0;37m e[1;34mHDD Total Size:e[0;37m 34.4GB (35.4% used)e[0;37m e[1;34m e[0;37m e[1;34mID-1:e[0;37m /dev/sda e[1;34mmodel:e[0;37m VBOX_HARDDISK e[1;34msize:e[0;37m 34.4GBe[0;37m e[1;34mPartition:e[0;37m e[1;34mID-1:e[0;37m / e[1;34msize:e[0;37m 23G e[1;34mused:e[0;37m 9.9G (46%) e[1;34mfs:e[0;37m ext4 e[1;34mdev:e[0;37m /dev/sda1e[0;37m e[1;34m e[0;37m e[1;34mID-2:e[0;37m /home e[1;34msize:e[0;37m 8.3G e[1;34mused:e[0;37m 1.5G (19%) e[1;34mfs:e[0;37m ext4 e[1;34mdev:e[0;37m /dev/sda2e[0;37m e[1;34mSensors: e[0;37m None detected - is lm-sensors installed and configured?e[0;37m e[1;34mInfo: e[0;37m e[1;34mProcesses:e[0;37m 156 e[1;34mUptime:e[0;37m 3 min e[1;34mMemory:e[0;37m 1527.2/15990.2MB e[1;34mInit:e[0;37m systemde[0;37m e[1;34m e[0;37m e[1;34mClient:e[0;37m Shell (zsh) e[1;34minxi:e[0;37m 2.3.38e[0;37m e[0;37m e[0m

  2. In fallback mode, I don’t see anything odd in the boot, and I still get to the log-in screen with a flashing cursor in the password field and am stuck from there.

Thanks,
mr park

(Neofytos Kolokotronis) #35

Oh my bad, I completely missed that this was also in virtuabox.

Are you using the same configuration for this virtual machine as the other one?
Are you sure you have enough space left on the virtual disk?
What happens with recovery mode (boots into CLI), do you get keyboard input there?

(aram heller) #36

As far as configuration goes (assuming you mean Virtual Box set up), yes I set them up pretty much the same these days.

I’m pretty sure there was still room on the disk. I had two partitions, for a total of 32GB. I think the home partition was around 10GB. But it’s possible that the root side filled up.

Recovery mode loads up to where it is asking for the root password. But even there it freezes.

After that didn’t work, I tried attaching it as a secondary HD to the good VM a few different ways. Testing launched but the drive didn’t mount. I’m starting to wonder if something happened to the drive.

As a fall back, I do have a snapshot from before the update, and thankfully a backup as well from right before the update. I’m wondering if it might be best to go back and try again. But I still will need to remove Catalyst, and am not sure what, if anything to put in it’s place for the video card.

-mr park

Plasma not loading after last update
(steven l kleiman) #37

A tale of two graphics cards, with a happy ending

My Dell XPS15-9530 laptop has two graphics cards: an integrated Intel HD
Graphics 4400/4600 and and a Nvidia GeForce GT 750M. And just as
Neofytos warned, I did “come across some conflicts regarding the mesa
package during this upgrade,” resulting in the failure of my Plasma
Desktop. In the hope that my experience might help someone else, here’s
my story. It has a a happy ending.

Being forewarned, I did as Neofytos advised, “before trying to perform
the upgrade,” I updated mesa separately by running:

$ sudo pacman -Sy mesa
$ sudo pacman -Syu

The upgrade went smoothly until the following message appeared:

libgl and nvidia-utils are in conflict. Remove libgl? [y/N] y

Yes, I answered “y” because in the useful tutorial,

How to switch between free and non-free video drivers,

https://community.chakralinux.org/t/how-to-switch-between-free-and-non-free-video-drivers/6396/4
we find this explanation:

There is nothing wrong. libgl is also provided by catalyst-utils or
nvidia-utils. You can replace libgl by nvidia-utils or catalyst-utils
without problem (just install the correct one for your graphics card.)

However, for me there was, indeed, something wrong! The rest of the
upgrade went smoothly, but after I rebooted, my Plasma Desktop failed to
work.

Luckily, an instance of Konsole was running, and although it couldn’t be
moved or resized, it allowed me to follow this advice given earlier in
the same tutorial:

  1. Steps to switch from NVIDIA to Nouveau.

Remove the NVIDIA driver:

If you have a newer NVIDIA graphics card:

`sudo pacman -Syu’ (already done, so not repeated)

sudo pacman -Rdd nvidia

sudo pacman -Rdd nvidia-utils

Install the Nouveau driver:

sudo pacman -Syu

sudo pacman -S xf86-video-nouveau

sudo modprobe nouveau (unnecessary, as nouveau was already there)

I rebooted, and my upgraded system has worked beautifully ever after.

(Luca Giambonini) #38

that’s quite strange, I have a GeForce GTX 760 and I’m using the nvidia drivers without any issue. Removing libgl is correct, because is provied by libglvnd.
Maybe you error was something else, I suppose a bad configuration of bumblebee, but without a log is difficult to say. If your are happy with the current driver keep it.

(steven l kleiman) #39

Well, I’m using the nouveau driver, not the nvidia driver nor bumblebee (as far as I know), and I’m happy enough with it (as I’m not a gamer). When I ran the live system off a thumb drive, I chose the nvidia driver, and it worked well. Then I installed the live system, but the installer installed the nouvea driver, without my knowing it, and it worked well enough until I ran the upgrade. Yes, libglvnd is installed.

I’d love to send you a log, but I don’t know where to find one or how to make one for the next upgrade. How about a pointer to a tutorial on what to do in this regard?

Luca, thanks for your reply. Steve

(Neofytos Kolokotronis) #40

Since you are running this in virtualbox, no special drivers like catalyst are needed. It is strange you had these installed to begin with.

(aram heller) #41

Yeah I was wondering a bit about that too. I was pretty careful about what I installed in this VM since I was trying to keep it as stable as possible. I was pretty much just doing web stuff/shell scripting and a bit of Inkscape/Gimp work, but nothing heavy.

Over the past few days I rolled back to the pre-update snapshot and tried a few different approaches to the update, but each time came up with different dependency issues. Finally, I decided to just create a new VM with the latest ISO and move data which I’m finishing up now.

(ericjs) #42

I just finally got around to this upgrade, it not having been a good time to possibly mess up my system. This is a nvidia / intel / bumblebee system. No major problems, but going into the Plasma settings panel for Display, I don’t get the full list of resolutions that I got before. In particular, resolutions that match the dimensions of my laptop screen are missing (I’ve been using 1920 x 1080) do not appear, and unless I keep to the max resolution which makes everything too tiny, I only have resolutions to choose from that leave black rectangles on either side. (And yes I know I can Scale, but I typically use this laptop with an external monitor where I want the scaling how it is by default, and setting the laptop screen resolution lower has been the best compromise.)

Anyway, I vaguely remember having run into this before and it having something to do with the Optimus stuff not being configured quite right, but I don’t remember the details, and am not 100% sure that this was really the reason)

optimus --status

says

Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.

Any ideas?

(cidig) #43

@ericjs: I have a similar setup and I had exactly the same problem.
It it mentioned here on the arch wiki.
I followed the instructions on adding a new resolution to /etc/X11/xorg.conf.d/10-monitor.conf. I added only one (2560x1440) and all the missing resolutions came back.

1 Like
(ericjs) #44

Thanks @cidig, I will try that. (I tried googling on the symptom but couldn’t find a wording that didn’t get me irrelevant stuff!)

(Knut Hildebrandt) #45

Hello Fred,

what do you mean by “… installed another Chakra instance, logged in to my original. Completed the upgrade …”? How the freshly installed system affect the old one?

I’m asking, since I have a similar setup and problem. There is an on-board Intel Graphics and an separate Nvidia. After the upgrade booting hangs at “Reached Target Graphical Interface” and the display starts flashing. Can’t access any other TTY when this happens, since the system has problems the read keystrokes.

(Fred Talmadge) #46

I installed Chakra as dual boot, using the option to shrink the existing partition. Then I tty into the original partition and completed the upgrade. You might be able to it with a bootable rescue disk as well.

(Knut Hildebrandt) #48

Thanks for the explanation. What I do not understand is, how you finished the upgrade from the second system. If you run pacman in the new environment it won’t affect the old installation, will it? Or did you make adjustments by copying and/or deleting files? If so, which?

I tried to upgrade two days ago what rendered my system unusable. The update of all packages went fine and without any error messages, except one regarding virtualbox. But that one I got at previous updates of virtualbox too and it did not affect the system at all.

But when I wanted to reboot the system I could not lock out properly. The lockout-screen kept crashing and thus I terminated Plasma entering

qdbus org.kde.ksmserver /KSMServer logout 0 2 2

While booting the system again, it got stuck at

Reached Target Graphical Interface

and the screen started flashing. I could not even access a TTY because not all keystrokes were accepted by the system and thus I could not enter my password.

Eventually I had to roll back by playing back an image I fortunately had made just before the upgrade. Now I wonder how to upgrade without running into the same problem again.

There are two more things to mention.

  1. I have an on-board Intel graphics chip and a separate Nvidia card which usually is switched off 'cause I do not use it. Just tested it, and it is off.

  2. investigating into the matter I found out that the old xf86-video-intel package is marked CCR while the new one belongs to CORE. Could this cause that the driver is not properly installed? Well, what lets me doubt this is the fact, that the protocol says that the package has been updated from the old to the new version. But have a look yourself.

(tom) #49

so far i can remember you can select in grub a entry that brings you to the multi-users.target and so you can login in a TTY and you can visit the journal or do something else

(Knut Hildebrandt) #50

Well, the problem seems to be solved. After playing back an image made before the update and updating the system again everything seems to work perfectly. No clue what went wrong the first time. Only thing I did differently was uninstalling xf86-video-intel and installing the new version since it had not been updated automatically. Anyway, the old version was marked “CCR” whereas the new one is from “core”. Maybe that is why it did not update and perhaps this is the reason why the graphical system did not work after the first update. If I had overlooked that xf86-video-intel had not been updated this might have caused the graphics problems.

(dinolib) #51

Unfortunately I found that on my intel+nvidia PC came back an annoying issue: nvidia cards is ON everytime.
I’m not able to turn off it in anyway. nvidia module is in use, so it is impossible to unload it by rmmode or modprobe -r.
Writing OFF in the /proc/acpi/bbswitch file doesn’t have effects. The only error is that nvidia goes time out when trying to turn off.

I can use both nvidia and intel cards, but nvidia is alway on.

(josx) #52

Hello community,

I tried to update/upgrade my system:

$ sudo pacman -Syu
:: Synchronizing package databases...
 lib32 is up to date
 core is up to date
 desktop is up to date
 gtk is up to date
 unstable is up to date
:: Starting full system upgrade...
:: Replace mesa-libgl with core/mesa? [Y/n] y
resolving dependencies...
looking for conflicting packages...
warning: removing 'mesa-libgl' from target list because it conflicts with 'mesa'
:: lib32-libglvnd and lib32-catalyst-libgl are in conflict (lib32-libgl). Remove lib32-catalyst-libgl? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst-utils: requires xorg-server<1.18.0

but I get some troubles, the update doesn´t work.

My g-card:

$ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:19.0 Ethernet controller: Intel Corporation 82577LM Gigabit Network Connection (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 06)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
02:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 35)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
(Luca Giambonini) #53

Please, try to follow the 3 commands listed here:

In case of errors please do not continue, and post them here.