Unable to update inkscape

When I try to update inkscape (either using octopi, sudo pacman -Syu or ccr inkscape) from inkscape version 0.92.4-1 (which I have installed and working) to current version inkscape 1.0-1 I cannot due to a dependencies error.

:: Synchronizing package databases…
lib32 is up to date 0,0 B 0,00 B/s 00:00 [---------------------------------------------] 0%
core is up to date 0,0 B 0,00 B/s 00:00 [---------------------------------------------] 0%
desktop is up to date 0,0 B 0,00 B/s 00:00 [---------------------------------------------] 0%
gtk is up to date 0,0 B 0,00 B/s 00:00 [---------------------------------------------] 0%
:: Starting full system upgrade…
resolving dependencies…
warning: cannot resolve “libcdr”, a dependency of “inkscape”
:: The following package cannot be upgraded due to unresolvable dependencies:
inkscape

:: Do you want to skip the above package for this upgrade? [y/N]

And, of course, this libcdr seems to not exist anywhere. Not even anything called cdr. Except cdrdao and cdrtools, but I’m quite sure they have nothing to do with inkscape.

Just in case, I’ve waited a couple days and I’ve tried ALL the different servers available on the mirrorlist, but no luck.

What’s happening?

Someone reported it on our GitLab: https://code.chakralinux.org/chakra/packages/gtk/-/issues/79
We may need to wait @FranzMari to resolve it.

2 Likes

Sorry, libcdr was still on [testing].
It works now

3 Likes