Trying to disable IPv6

vpn

(Hugo Beltran de Heredia Llamazares) #1

I’m trying to set up ProtonVPN using OpenVPN following their documentation. After having some troubles connecting due to the managing of IPv6 addresses I found that they recommend to disable IPv6 for manual VPN connections. As I’m not very confident about my “tweaking skils” I wanted to ask if there is any straight forward way to do it, because the Arch Wiki tends to obfuscate my senses with too many terms I am not familiar with.

In case there is, any suggestion of a better VPN choice is also welcome.

Thank you.


(tom) #2

https://wiki.archlinux.org/index.php/Disabling_IPv6


(Hugo Beltran de Heredia Llamazares) #3

Hey! Thanks for the quick reply, but that is the point I reached before writing the post. I sincerely don’t know how to either add a line to the kernel (I’ve never done that) or make a list of the interfaces I want to disable one by one (don’t know which are related to the VPN connection).

Thank you again!


(tom) #4

edit /etc/default/grub and add to this line

GRUB_CMDLINE_LINUX="<your desired kernel imput>"

then run update-grub


(Hugo Beltran de Heredia Llamazares) #5

Done, but this lets me a bit confuse now. It outputs the following:

Connecting...
[!] Error connecting to VPN.
[!] This is an error in enabling IPv6 on the machine. Please enable it manually.

So apparently I have to enable it undoing that grub edit. This is the output after that step:

Connecting...
[!] Error connecting to VPN.
[!] There are issues in managing IPv6 in the system. Please test the system for the root cause.
Not being able to manage IPv6 by protonvpn-cli might cause issues in leaking the system's IPv6 address.

How to proceed?


(tom) #6

you removed the kernel option and run update-grub?
maybe you must configure the client before or it is a bug?


(brli) #7

Hi,

AFAIK protonvpn supports connecting via openvpn protocol.

And, openvpn can be easily managed by Plasma’s networkmanager applet/kcm.

just search “openvpn KDE” on the internet and you should have plenty of tutorial helping you set openvpn up.

Hint

Namely

  1. grab your protonvpn <server>.ovpn file.
  2. open your networkmanager setting
  3. “Add”> “Import VPN configuration”
  4. check your protonVPN username and password from your dashboard
  5. enter corresponded fields

(Hugo Beltran de Heredia Llamazares) #8

For some reason I had to reboot every time I changed something to see the change in the behavior.


(tom) #9

try this:

sudo systemctl restart <service to restart>
sudo systemctl restart networkmanager

and have you read the other solution from @brli ?