Testing crashes [2020-03-31]

Since today testing update (31/03/2020), I’m not able to login into plasma anymore. I get a crash in login window (ksplashqml crash).
In order to complete the update I had to uninstall old qt4 related packages (files conflict otherwise). I reinstalled all the plasma-qt5-kf5 related packages without luck, still same error.

Ctrl+alt+f2 bring me to CLI interface and I was able to fix it:
I rolled back to stable and I’m logged regularly.
Please, check it. Maybe some qml related package needs to be recompiled.

Thank you.

1 Like

the same problem on my note book

[2020-03-31T12:45:03+0200] [ALPM] upgraded qt5-base (5.13.2-2 -> 5.14.1-3)
[2020-03-31T12:45:04+0200] [ALPM] upgraded qt5-declarative (5.13.2-2 -> 5.14.1-3)
[2020-03-31T12:45:04+0200] [ALPM] upgraded qt5-graphicaleffects (5.13.2-2 -> 5.14.1-3)
[2020-03-31T12:45:04+0200] [ALPM] upgraded qt5-location (5.13.2-2 -> 5.14.1-3)
[2020-03-31T12:45:04+0200] [ALPM] upgraded qt5-multimedia (5.13.2-2 -> 5.14.1-4)
[2020-03-31T12:45:04+0200] [ALPM] upgraded qt5-quickcontrols (5.13.2-2 -> 5.14.1-3)
[2020-03-31T12:45:04+0200] [ALPM] upgraded qt5-quickcontrols2 (5.13.2-2 -> 5.14.1-3)
[2020-03-31T12:45:04+0200] [ALPM] upgraded qt5-script (5.13.2-2 -> 5.14.1-3)
[2020-03-31T12:45:04+0200] [ALPM] upgraded qt5-sensors (5.13.2-2 -> 5.14.1-4)
[2020-03-31T12:45:04+0200] [ALPM] upgraded qt5-speech (5.13.2-2 -> 5.14.1-3)
[2020-03-31T12:45:04+0200] [ALPM] upgraded qt5-svg (5.13.2-2 -> 5.14.1-3)
[2020-03-31T12:45:05+0200] [ALPM] upgraded qt5-tools (5.13.2-2 -> 5.14.1-5)
[2020-03-31T12:45:05+0200] [ALPM] upgraded qt5-webchannel (5.13.2-2 -> 5.14.1-3)
[2020-03-31T12:45:08+0200] [ALPM] upgraded qt5-webengine (5.13.2-3 -> 5.14.1-5)
[2020-03-31T12:45:08+0200] [ALPM] installed brotli (1.0.7-1)
[2020-03-31T12:45:08+0200] [ALPM] installed woff2 (1.0.2-1)
[2020-03-31T12:45:09+0200] [ALPM] upgraded qt5-webkit (5.212.0alpha3-2 -> 5.212.0alpha4-3)
[2020-03-31T12:45:09+0200] [ALPM] upgraded qt5-x11extras (5.13.2-2 -> 5.14.1-4)

Yup, same.

And just because Disgust will otherwise moan about my post being too short again, Falkon keeps telling me there’s an SSL certificate error with this very site. Cert doesn’t match URL.

@dinolib Have you reported this on the bugtracker yet? I now see a huge fuckin update and I’m not running it until I’m sure my box will still work afterwards.

Edit, because bloody Disgust won’t even let me post anymore:
Plonk it on the BT pal, I just tried getting the devs’ attention to this on IRC and got me head bit off again.
Fuck that, I ain’t helping no more :fu:

I’ve done my very best to accomodate as many as possible when it comes to GitLab and Discourse. I’m sorry to hear that this, for some, isn’t enough.

In https://community.chakralinux.org/t/getting-testers-involved-at-an-earlier-stage/8276 I explained that collecting the information and writing the topics for this category is an activity that consumes a significant amount of time. I no longer have that time. An alternative was suggested, and the members of @testers were invited to the corresponding group in GitLab in February 2019. There was only positive feedback.

In How to become a tester a brief explanation on how to help out is described, reflecting the above change.

I also addressed the workflow used in https://code.chakralinux.org/groups/chakra/-/epics/5, where @testers were mentioned, inviting them to participate. This continued in https://code.chakralinux.org/chakra/melange/-/issues/133, in which I made the assumption that @testers agreed with this. Every time a merge request is created in those projects, members of the @testers group should receive a notification about the new item on their to-do list.

Since 2020-03-24 I’ve been working on https://code.chakralinux.org/chakra/packages/core/-/milestones/5. After that, I will work on https://code.chakralinux.org/chakra/packages/core/-/milestones/4. These are complex and, to me, often overwhelming tasks. I hope that I will be able to learn and document these tasks that they can be handled faster and more efficiently in the future, possibly giving me time to continue working on the website again.

I would rather not post the log of yesterday from IRC, but I’m sure that you’ll understand that after all the work done so far, and the work that remains, I find it very discouraging when someone shows up with what I perceive as a dismissive and ignorant attitude. Complaining about Discourse and GitLab being “shite” isn’t productive criticism. Throwing a tantrum like a petulant child is not okay. The assumption that I am “smart enough to understand that sort of stuff at first glance” is false. I read the documentation and look at how others work. I ask questions.

If you want to help out, it is more than welcome. I encourage you to join the IRC channel/Matrix room and hang around or ask questions about e.g. what package relates to what merge request.


since end of february is something wrong with the login @code.chakralinux.org because i couldn’t login anymore

i suppose a datebase error

the update today was smooth and the reboot without a problem. it seems there isn’t a danger anymore.

1 Like