System occasionally freezes


(Knut Hildebrandt) #1

Interesting thread. Just stumbled upon it because I’m desperately looking for a solution for various problems. I think my system started to get very unstable after the big update announced Mid-October. The graphics problem somehow could be solved quickly. What I never could solve was, that Skypeforlinux from that update on did not work anymore. It always crashes on login. Furthermore my system also hangs once in a while, mostly when the memory is used up and the system starts swapping. Already tried various changes to settings in this respect without any progress. See suggestions here: https://is.gd/wJrcdx

Apart from that I get loads of error messages regarding my camera. Sometime my system dos not start up nor shut down due to them. Did a little research into that and found this thread: https://askubuntu.com/questions/353533/webcam-not-working-in-13-04. It somehow suggests, that Skype might fail due to the problem with the camera. And that there is a problem with the camera proves

[knut@chakra-pc ~]$ dmesg | grep uvcvideo | less

[ 1123.394002] uvcvideo: Failed to query (129) UVC probe control : -71 (exp. 26).
[ 1123.394006] uvcvideo: Failed to initialize the device (-5).
[ 1124.037765] uvcvideo: Found UVC 1.00 device HD WebCam (1bcf:2c32)
[ 1124.046252] uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
[ 1124.050509] uvcvideo: Failed to query (129) UVC probe control : -71 (exp. 26).
[ 1124.050515] uvcvideo: Failed to initialize the device (-5).
[ 1124.683385] uvcvideo: Found UVC 1.00 device HD WebCam (1bcf:2c32)
[ 1124.692008] uvcvideo 1-1.1:1.0: Entity type for entity Extension 4 was not initialized!
[ 1124.692012] uvcvideo 1-1.1:1.0: Entity type for entity Extension 3 was not initialized!
[ 1124.692013] uvcvideo 1-1.1:1.0: Entity type for entity Processing 2 was not initialized!
[ 1124.692015] uvcvideo 1-1.1:1.0: Entity type for entity Camera 1 was not initialized!
[ 1125.792125] uvcvideo: Found UVC 1.00 device HD WebCam (1bcf:2c32)
[ 1125.800619] uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.

I only pasted a few of the hundreds of lines my log gets filled up with.

My question now is, what had changed under the hood that a stable system is rendered almost unusable? In the announcement for the update only manual intervention for mesa and graphics are mentioned (Upgrades for xorg, kernel and graphics drivers include important changes and might require manual intervention). Might the kernel be the culprit? BTW, my system is also Intel based.

Would be grateful about any hint that make my system return to normal.

Edit:
Okay, installed LTS kernel and at least the error messages with regard to uvcvideo are gone. Skypeforlinux does not work yet, but the freezes when swapping are gone too.

Only drawback, the graphics system seems to be unstable again. The window system crashed after the first boot into LTS and rendered the system almost irresponsible. After reboot everything seems to work fine. Will have an eye on that anyway. But honestly, I would prefer to get the new kernel working instead of getting stuck with the old stuff. Any ideas?


Chakra freezes every moment
(Neofytos Kolokotronis) #2

Hi Knut, it’s sad to see you are experiencing several issues.

Skype
I’ve also had troubles with Skype crashing but they were later resolved automagically. It is still not usable though as in my case I can’t hear audio from the other person. We should better start a bug report.

System hanging
I’ve had issues with system going extremely slow as I was running out of RAM as well. I’ve resolved them by switching swappiness to 10.

Graphics:
Tried with the new kernel in testing? Or After the latest xorg rebuild 1.19.5-2? Maybe they help.

Camera:

uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.

A quick search of these error returned several results, perhaps there is some workaround or further info there.

In any case, all these don’t seem directly related to this thread. For further troubleshooting can you please split this post into several threads per issue you are facing, including all the relevant information you posted here, to keep everything on topic? Thanks.


(Knut Hildebrandt) #3

Thanks for your reply. Well, I think my problems somehow are related to this thread. The main issue is the freezing. Furthermore @FranzMari recommends trying the LTS kernel. And he was right, the main issues like freezing and the uvcvideo problem are gone. Unfortunately with the LTS kernel a bunch of graphics problems arose. KWin crashes for instance randomly.

Skype
… We should better start a bug report.

I had started a bug report in the old issue tracker, that had been closed as unreproducible and wasremoved from it.

System hanging
… I’ve resolved them by switching swappiness to 10.

I’ve set swappiness to 10 years ago.

Well to cut a long story short, I think the culprit is the kernel. With the update from 4.8.6-1 to 4.12.4-1 (and later) kernels the problems arose and never disappeared again. Shall I open a new topic regarding the kernel?

Sorry for the new edit, but all I had written after this point turned out irrelevant. Just updated the kernel to 4.14.12 and all dependencies, including the nvidia driver, too. And my problems seem to be solved. I do not experience any freezes anymore when system starts swapping, the uvcvideo error disappeared and the webcam is recognized by the system correctly. Only the Skype problem is still there.

Thanks for your patience and the hints.
.


Latest status of the testing repository [08 Jan 2018 - 16 Jan 2018]
(Knut Hildebrandt) #4

I revive this topic even though the system does not like it. The reason is, even thought I stated differently in my last post, the problems continued. That is why I was experimenting with changes of various settings. Eventually the following measures helped to minimize the problem to a bearable extent.

  1. update to kernel 4.14.12

  2. add MODULES=“i915” in my /etc/mkinitcpio.conf

see this recommandation:

I actually had put the i915 into the MODULES for a graphics problem that arose with one of the recent updates and since this could be solved differently I took it out again, which let to a rise in the freezes.

  1. uninstall all nvidia related packages

Since I never use the nvidia card I did not reinstall these packages and thus do not know if this really was part of the solution. But I mention it as a possible line of investigation, just in case someone runs into similar problems.

And why did I write the freezes could only be minimized but are not gone? Well, my system still freezes ones in a while. And I somehow got the impression this has to do with Akonadi and the arrival of new mail. This sometimes, but not always, causes Akonadi and the MariaDB behind it to use a lot of memory and cpu time. Will investigate this more deeply in the KDE forum and bug tracker.


100 % CPU usage on Facebook or other websites with plugins
Clamscan leads to system freezes
Systemd-udevd spawns child processes and eats up memory
(Knut Hildebrandt) #5

Since I can’t edit my last post two additions:

  1. the kmail problem seems to be solved. Look at Clamscan leads to system freezes

  2. systemd-udevd also seems to contribute to the heavy swapping. More in Systemd-udevd spawns child processes and eats up memory


(system) closed #6

This topic was automatically closed 170 days after the last reply. New replies are no longer allowed.