Sound inaudible due to strong static noise

For about two months my audio system does not work correctly anymore. A friend supposed that this is caused by the new kernel 5.2.11-3 which might not support my Realtek ALC269VB sound chip correctly. He had issues too and solved them by setting Mic Boost to 0 in Alsamixer. Did so as well, but it did not help.

I first noticed the problem at some moment in October. But after a couple of re-boots it seemed to go away. I’m not sure if it occurred the first time after the kernel update or not. The latter I had made by the end of October. Since about a month after the update audio output does not work at all anymore. I only hear static noise. Once in while sound comes back for a short while, but the noise gets stronger over time until I can hear nothing but noise in the end.

Interestingly, when I start Tails on my machine I always can playback sound files correctly. Back in Chakra static noise again.

Any clue what this might be caused by and how I can fix it?

i would test a older kernel and if use till a new kernel solve the problem.

perhaps is this help full:

(1/1) Installiere pulseaudio                                  [#################################] 100%
 WARNING 
If you have per-user copies of configuration files in ~/.config/pulse/,
make sure you keep them in sync with changes to the packaged files in /etc/pulse/.
Otherwise, PulseAudio may refuse to start due to configuration errors.
Deleting ~/.config/pulse/ is another option to avoid these configuration errors.

Pulseaudio as well as alsa and all other sound stuff was last updated in June 2018. Only exception is qjackctl which got updates by the end of October and in December. But this should have nothing to do with this problem, right?

Also checked pulse config-files, deleted the ones used until now, but there was no change. Furthermore, there are no .pacnew files for pulse on my system.

Regarding the older kernels, I still got 4.18 and 4.19 on the system. Since Chakra does not support to have various kernels installed side by side, I made backups of initramfs and vmlinuz.linux and the module directories and thus can start with an older kernel. Unfortunately the problem remains. But I had noticed that somehow the module directories of all kernels were changed during a subsequent update, probably of virtual box. Apart from that the kernel has quite a few dependencies which were updated to the versions corresponding to 5.2.11-3. Thus I do not know if the older kernels work correctly.

Is there a way to install another kernel besides the actual one with all correct dependencies?

maybe not, because qjackctl is front end from jack and jack is audio related.
could you delete or rename the configuration file from qjackctl?

I can’t believe it. Uninstalled qjackctl and the sound problem was gone. But why is that? Neither jack nor qjackctl were running on my computer for years. I had both installed long ago to get ardour running. But since ardour works with alsa as well for a while I don’t use them anymore. But how can a program that is not running at all, make the sound system unusable?

Thanks for the hint. And Happy New Year.

a solved problem is probably a good start for the new year^^

i suppose ardour have a hierarchy to pick audio software and jack have a higher priority then alsa

That’s right. And it used alsa. Jackdbus was not started if I did not change this at startup.

Anyhow, the problem is back. Sound worked fine for half a day and then it started getting worse. No it’s back to inaudible and I only hear distortion when sound is playing :cry:

as work around i would try to remove jack: $sudo pacman -Rdd jack
a second option is build a newer version…

  1. download source file
  2. change to the directory where files are stored
  3. run makepkg -rsi

Well, I got the impression this is not a software problem, but my sound card is dying. By now, there is no sound at all in Chakra and when I started Tails I suddenly got the same distortion I had in Chakra before. Will test with another sound card and hope this is the solution.