Remapping Super key

Hi,

How do I remap the Super key on Hawking to open the application launcher on the default panel, instead of opening it on Latte?

That’s how it used to be before Hawking, and I’d like to return to that behavior.

TIA.

cccccccccccccccccccccccccccccccccccccc

just map the shortcut of the application launcher you wish to use to Alt+F1 (and it should call a conflicts on latte’s, you should be able to erase that shortcut from the dialog.)

I tried that, it doesn’t work. Now alt+F1 does open the app launcher, but Super key does nothing.

To be clear, I have removed the Latte dock from startup, as I do not want it.

1 Like

OK, I solved it. I had to disable Latte’s own setting of “Press meta to activate application launcher”. Once that was done, super key started launching the app launcher on the default panel.

Mark this as the solution then, please.

By the way, whose insane idea was it to change a working setup to that dock horror? ‘Modernising’ again, are we? :roll_eyes:

Spoke too soon. What I said earlier worked on my laptop, but doesn’t work on my desktop.

I agree with the poster above, that maybe you shouldn’t change things that we are so used to. Using the Super key for the application menu is almost second nature to me, and I think for most people. Before it was made default behavior in KDE, we used ksuperkey to accomplish that. And of course, it’s the key that brings up the start menu in Windows, and has been for decades.

TL/DR : Please let the super key bring up the application menu/launcher on the default panel. Or at least, give us an easy option to choose between that and the one on the latte dock.

1 Like