Reached target Graphical Interface hangs on iso

Trying to spin up a Hyper-V VM with Chakra, the live iso just flickers on Reached target Graphical Interface. Tried both with and without RemoteFX. Not sure what else to do. Any assistance?

1 Like

i would try to login in a tty and check journal and services.

Is it possible to do that when I’m trying to spin up the live iso for the first time? I’ve tried researching how to do that, but I’m not even sure what to look for. Unfortunately, you’re dealing with a semi-noob here, so your suggestion is like telling a 9 yr old to parallel park for the first time. I appreciate the help, but I need to know how to do that. I am willing to read and learn and figure it out, but I don’t even know which state to boot the live iso into to start attempting any of that. Any suggestions?

Can you please try it with the much younger RC iso? DL here:

Well, the only improvement from RC4 is that it doesn’t flicker as much. Chakra must not be made for running in a VM, eh?

I do not know how Hyper-V works. Btw I do used Chakra under Oracl’s Virtualbox many times without any problem.

Sorry, my reply was a bit too snarky, I didn’t mean anything by it. I would like to get this up and running, though. I just have no idea where to start. Tom said to login with tty and check journal and services, but I don’t know how to do that on an iso where I have no idea what the IP is, much less how to get to journal and services and what to do with whatever I would see.

So, I should clarify. I have secure boot turned off. Everything else is a regular setup for a VM, as far as I can tell.
Boot: DVD Drive with the ISO loaded to it.
Security: Secure Boot Disabled
Memory: 8192 MB
Processor: 4 Virtual processors
Hard Drive: [xxx].vhdx
Network Adapter: Default Switch
Going through and disabling various integration services to see if anything works. Not sure what else to do.

Well, created a new VM on Gen 1, and it works. Chakra supports UEFI, right? So why would a Gen2 on UEFI not work when a Gen1 on BIOS would? Something for smarter people than I to figure out.

Don’t worry :wink:

I think Tom mentioned to log in to tty6, by pressing ctrl + alt + F6 buttons. (F6 means the tty6, where F7 brings you back to the gui)
On tty6, you will be able to log in with your username and password. Than you can begin with reading journal etc.

*maybe Arch wiki can help too with Hyper-V:

on the live iso is your usrename ‘live’ and the password also ‘live’ but in this case i would do it as root :wink:

root login: username: root and password root


how many GPUs do you have enabled?

I got something similar, but with RC3 I was able to install chakra and then run full update… (but graphics driver related problems still continued).

I am having the same problem on a regular (ie, not VM) machine. I have an Nvidia-710 GPU. The Intel iGPU is disabled in BIOS. I see that the file isolinux.cfg has a line stating i915.modeset=1, could that be the issue? I am unable to change the line, apparently I do not have the permissions to do so.

The issue is exactly as the OP described. A flashing screen after “Reached target graphical interface”. I was able to install the same ISO (Hawking RC 4) using the same pendrive on another much older computer that only has an intel GPU, with no issues.

Having entered systemctl at the root prompt, the only service that shows failed is (unsurprisingly) SDDM.

The nVidia driver in that iso is not complete. You can try installing the old 2017 iso…

Hmm…Is there any way to rectify this myself? If not, is an update expected for the ISO soon?

No, afaik. Also, the RC iso’s will not be updated. If there will be a new iso in the future, than that will be a completely new one, not a successor of the current RC’s.

Till that, we are stuck with the old iso.

i suggest a bug report

…and if successful installed do sudo pacman -Syu

It’s already done. issue 89
AFAIK, there will be no RC5 from Hawking.

Developers, please do something to fix this. If Hawking’s release is still far off, please release and RC5 with the Nvidia drivers fixed. @AlmAck

It’s surprising that this issue has not been fixed yet despite being reported months ago, and disappointing that I’m not even getting a response here from anybody associated with the project. One would think that Nvidia drivers being broken is big enough of an issue, as most computers with an Nvidia GPU cannot install the OS.

By the way, I am having the same issue on my new laptop which has both an AMD and and Nvidia GPU. I am having the same issue with both Hawking and Goedel.

With regret, I decided to give up on Chakra (at least for now), and installed Kubuntu on both my systems, and it is working flawlessly. I hope to return to Chakra if and when these issues are sorted out. I strongly urge you to be faster in rectifying reported bugs, and to be more responsive here on the forums.