Pulseaudio high CPU usage

(tomaggio) #1

Hi There,
i encounter the problem that pulseaudio eat a lot of cpu after login.
Killing the process resolves the issue. The process will be respawned and then pulseaudio behaves as expected. Any suggestion to resolve the problem permanently?

(tom) #2

some debugging first? and perhaps start chakra-check-links

journalctl | grep pulse
#man pulseadio

--log-level=<LEVEL> If an argument is passed, set the log level to the specified 
value, otherwise increase the configured verbosity level by one. The log
 levels are numerical
from 0 to 4, corresponding to error, warn, notice, info, debug. Default log level is notice, i.e. all log messages
with lower log levels are printed: error, warn, notice.
-v
Increase the configured verbosity level by one (see --log-level above). Specify multiple times to increase log level multiple times.
--log-target={auto,syslog,stderr}
Specify the log target. If set to auto (which is the default), then logging is directed to syslog when --daemonize is passed, otherwise to
STDERR.

edit the start option in /usr/lib/systemd/user/pulseaudio.service

(tomaggio) #3

Hi Tom;
this the output from journalctl | grep pulse after editing /usr/lib/systemd/user/pulseaudio.service to
ExecStart=/usr/bin/pulseaudio --daemonize=no --log-level=4

:Apr 22 17:37:23 siddata ksmserver[1178]: ksmserver: Starting autostart service “/etc/xdg/autostart/pulseaudio.desktop” ("/usr/bin/start-pulseaudio-x11")
Apr 22 17:37:23 siddata rtkit-daemon[1256]: Successfully made thread 1253 of process 1253 (/usr/bin/pulseaudio) owned by ‘1000’ high priority at nice level -11.
Apr 22 17:37:50 siddata pulseaudio[1253]: E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service ‘org.bluez’: timed out

but I’m not sure if /usr/lib/systemd/user/pulseaudio.service is involved, when pulseaudio is started as a user.
Pulseaudio run with /usr/bin/pulseaudio --daemonize=no
so i assume its not involved
OUTPUT of chakra-check-links:
broken links

(tom) #4

a shot in to the dark because i haven’t any idea

  1. delete ~/.config/pulse
  2. reinstall pulseaudio with all depedencies
(tomaggio) #5

Fiddle around for 2 hours. First i followed your proposal and deleted ~/.config/pulse and reinstalled. After restart, the same thing, about 10% CPU. Then i tried /etc/pulse/client.conf to configure pulseaudio to start in debug mode, also “autospawn on” instead of off. But no luck with debug mode but the high CPU USAGE is gone.
Then i go back to autospawn off and since then The High CPU Usage is gone. No Idea why. Okay set this to SOLVED

(totte) #6

You’ll find simple instructions on how to do this here, please stick to the norm and avoid inventing own ways of marking topics as solved, thanks.

(system) closed #7

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.