Problemi nell'aggiornare Chakra all'ultima versione di kde e kernel


(Michael) #1

Ragazzi sto provando ad aggiornare Chakra all’ultima versione di kde e kernel. Ma andiamo con ordine. Come prima cosa ho provato l’ultima distro 2018 suggerita da AlmAck, ma non mi parte la grafica nè con uscita vga nè con uscita hdmi.
Allora ho reinstallato la distro 2017 ho modificato il file mirrorlist scegliendo i server in base al mirrorstatus: in particolare ho inserito quelli tedeschi, russo, francesi, svizzero e italiano. Lanciando il comando sudo pacman -Syu mi trova l’aggiornamento desiderato. I problemi iniziano ora: dopo aver risposto con S a tutte le domande mi esce un maxi aggiornamento di 1gb, che però richiede un ciclo di dipendenza:
attenzione: cryptsetup sarà installato prima della sua dipendenza systemd
attenzione: mesa sarà installato prima della sua dipendenza libglvnd
attenzione: qt5-translations sarà installato prima della sua dipendenza qt5-base (irrisolvibile)
attenzione: usbmuxb sarà installato prima della sua dipendenza libimobiledevice

Dopo aver risolto le dipendenze tranne quella irrisolvibile, inizia a scaricare gli aggiornamenti. Dopo oltre 40 minuti, sembra che il sistema venga aggiornato correttamente. Ma riavviando il sistema mi trovo davanti una serie di errori ed inoltre la starting version rimane sempre 231 anzicché essere aggiornata all’ultima versione e Chakra non si avvia più. A questo punto non so più cosa fare per risolvere il problema e aggiornare correttamente Chakra.

saluti


(Luca Giambonini) #2

mi piacerebbe avere qualche informazione in più, visto che siamo vicini al rilascio della nuova versione la cosa mi preoccupa un pochino.

Entra in modalità ripristino, da li prova a dare un pacman -Syu per verificare che sia tutto aggiornato.


(Michael) #3

Finalmente ci sono riuscito adesso va quasi tutto bene :sweat_smile:
Mi esce solo un errore in fase di caricamento del kernel e precisamente
[FAILED] Failed to start Load Kernel Modules.
See ‘systemctl status systemd-modules-load.service’ for details.
Come posso risolvere questo errore in avvio?

cordiali saluti


(Luca Giambonini) #4

bene! cosa hai fatto per sistemare il problema?

per il moduli controlla quali sono falliti con: systemctl --failed


(Michael) #5

Niente di particolare, semplicemente ho provato a rifare per l’ennesima volta l’installazione, e, per fortuna, mi è andata bene a parte l’errore sul kernel. Lanciando il comando mi viene fuori il seguente errore:

● systemd-modules-load.service loaded failed failed Load Kernel Modules

Cosa posso fare per risolvere il problema?

Per quanto riguarda la nuova iso non so darti altre info sul perché la grafica non partiva. So solo che sia in VGA che in HDMI all’atto del caricamento della grafica si imballava tutto.


(Michael) #6

Salve ragazzi,
sono riuscito a risolvere il problema degli errori sul kernel semplicemente reinstallando nell’ordine:

  • linux-firmware

  • linux-headers

  • linux

Riavviando il sistema il problema è stato risolto. Forse in fase di aggiornamento del kernel qualcosa è andato storto evidentemente.

Per quando riguarda la nuova distro, ho provato la RC1 e continuo ad avere gli stessi problemi, ovvero non carica la grafica si imballa tutto sia con uscita VGA che HDMI. La scheda video del PC è la seguente rilevata con il comando lspci:

VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]

Per il momento mi tengo stretto la distro 2017 perché, anche se non aggiornata, mi parte tutto correttamente.

Cordiali saluti


(Luca Giambonini) #7

Ciao Mike,
per favore apri un’altro topic cosi discutiamo della RC1.
Grazie!