Plasma 5.13.2, Applications 18.04.2 and Frameworks 5.47.0 by KDE now available to all Chakra users

kde-applications
curated
kde-plasma
kde-frameworks

(Neofytos Kolokotronis) #1

Also available in Italian, Spanish and Taiwanese Mandarin.

Hey all,

with your next system upgrade you will receive all the latest versions of KDE’s Plasma, Applications and Frameworks, in addition to several other package updates. We introduce Plasma 5.13 in its second bug-fix release, a brand new series that introduces many new features to our favorite desktop environment:

You will now find in our repositories a new package named plasma-browser-integration, which you should install to improve the integration of firefox and chrome-based browsers with your Plasma desktop. Make sure to install the add-on from your browsers’ store also, as described in the official announcement.

For more details and the full changelogs on KDE’s software releases, you can read the official announcements:

In addition to the above, more than 300 packages have been upgraded or rebuilt, the most noteworthy updates being:

[core]
cmake 3.11.4
gnupg 2.2.8
qt5 group 5.11.1
rust 1.27.0
vlc 3.0.3

[desktop]
konversation 1.7.5
mendeleydesktop 1.19.1
okteta 0.25.0
openshot 2.4.2
otter-browser 0.9.99.1
skrooge 2.14.0

[gtk]
eclipse 4.7.4
firefox-kde 61.0

It should be safe to answer yes to any replacement question by the package manager application. If in doubt or if you face another issue in relation to this update, please ask or report it below.

Most of our mirrors take 12-24 hours to synchronize with the central repositories on the origin server. Use the mirror status web page to see when your mirror of choice last synchronized.

Enjoy!


(Frank) #2

With this update I get to Warnings

The first depents on chakra-common

> WARNING
   The package chakra-common seems not to be installed,
   this can possibly break the installation. Just install it
   manually after this installation/update, run the following
   commands and restart KDE afterwards:
   sudo chakra-config-updater
   kbuildsycoca4

starting chakra-config-updater breaks with the error that chakra-config-updater isn’t existing but chakra-common is installed (and reinstalled).

I get this warning with the packages:
kwalletmanager
kompare
kcalc
kdepim-runtime

The second depents on cups.

(132/269) Aktualisiere cups                                                        [################################################] 100%
Cups daemon is now running under "cups" user+group.
Please make sure to enable the new user+group change in
/etc/cups/cups-files.conf or merge changes from
/etc/cups/cups-files.conf.default. After a service restart
make sure /etc/cups and all files within are owned by
cups group - run "chgrp -R cups /etc/cups".

I’m not sure what I have to change at the files cups-files.conf.default and cups-files.conf.
The only thing not commanded out is
SystemGroup lpadmin
Should this be setted to ‘cups’ ?
But there still no group or user ‘cups’ at the system.
Is there something to consider when creating the user/groups?

After a restart (without changings) cups is still running as “root” but printing break with “filter failed”


Latest status of the testing repository [10 July 2018 - Present]
(varanus) #3

I got the same warning, tried to run the suggested command and I got “command not found”.
So I rebooted and I got no error so far.

As I’m going to update another pc which i use for printing too, I’ll come back in case there are any errors.

Just a hint, in case you can print as root but not as normal user, you should make sure that you are in the cups group.


(Nuno Santos) #4

I can’t update. It says that there is nothing to do.


(Hans Tovetjärn) #5

Check your mirror, or provide more information, such as verbatim input and output, configuration files, and log files.


(tomaggio) #6

hey Frank got the same Problem und cant print anymore.
I#ve done this:

groupadd -g 209 cups
useradd -M -u 209 -g 209 -s /sbin/nologin cups
chgrp -R cups /etc/cups

Changed following files:
/etc/cups/cups-files.conf
/etc/cups/cups-files.conf.default

User cups
Group cups
SystemGroup lpadmin
systemctl restart org.cups.cupsd.service

Now it works; But i’m not 100% sure if that correct or breaks some security settings …
Is cups a replacement for lp? Confusing


(Frank) #7

Thank you tomaggio

I’ve done the same on sunday with

sudo useradd -U -r -s /user/bin/nologin cups

but I had to setup my printers new to stop the “filter failed” error.

I’m confused because cups still run as root.
The cups created ifiles n /etc/cups shows the rights
user: root
group: cups

I will try your setup on
/etc/cups/cups-files.conf
/etc/cups/cups-files.conf.default

with user and group to cups.

Edit:
Also with
user cups
group cups
in /etc/cups/cups-files.conf and /etc/cups/cups-files.conf.default
cupsd still run with root.
I do not know if that’s how it should be.


(Neofytos Kolokotronis) #8

Thanks everyone for the feedback and sorry for the troubles with cups. A fix for cups has been pushed by @AlmAck in the [testing] repo and will move to stable very soon.


(Luca Giambonini) #9

Moved to stable, the new cups should fix it, new file added:

 :: cups-2.2.8-1-x86_64.pkg.tar.xz from         [testing] -> [core]
 :: cups-filters-1.20.3-1-x86_64.pkg.tar.xz from        [testing] -> [core]
 :: cups-pdf-3.0.1-2-x86_64.pkg.tar.xz from     [testing] -> [core]
 :: foomatic-db-20180709-1-any.pkg.tar.xz from  [testing] -> [core]
 :: foomatic-db-nonfree-20180709-1-any.pkg.tar.xz from  [testing] -> [core]
 :: foomatic-db-nonfree-ppds-20180709-1-any.pkg.tar.xz from     [testing] -> [core]
 :: foomatic-db-ppds-20180709-1-any.pkg.tar.xz from     [testing] -> [core]
 :: libcups-2.2.8-1-x86_64.pkg.tar.xz from      [testing] -> [core]

(Nuno Santos) #10

I said before that, after update, everything was fine.

Well, it’s not. When I open systemsettings or desktopsettings, one of my cores gets 100% of usage. It slows down a bit the responsiveness and I always have to close the feature.

This never happened. The process using my CPU to it’s full usage is systemsettings, when I open it OR it is plasmashell if I right click from the desktop.

EDIT: I solved this, for now, by downgrading plasma-workspace package

sudo pacman -U plasma-workspace-5.12.5-2-x86_64.pkg.tar.xz

EDIT2: I also had to downgrade the systemsettings package

sudo pacman -U systemsettings-5.12.5-2-x86_64.pkg.tar.xz

I also get the message of error when updating the cups packages. It says that /var/cache/pacman/pkg/libcups-2.2.8-1-x86_64.pkg.tar.xz is corrupted.

 File /var/cache/pacman/pkg/libcups-2.2.8-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (checksum)).
Do you want to delete it? [Y/n] 

(Luca Giambonini) #11

Try to answer Y and the new package should be downloaded from our servers again.

About systemsettings… if you start it from the konsole with systemsettings5 do you see some messages?


(Nuno Santos) #12

About the corrupted package file, I disabled the Australian server which was the first in the list of servers and solved it. I’m trying this from a virtual machine installation so I’ll do the same tomorrow at the office.

About the question about systemsettings5 from the konsole it will have to wait until tomorrow.

EDIT: running systemsettings5 from the konsole gives me this

$ systemsettings5
QCoreApplication::arguments: Please instantiate the QApplication object first
WARNING: viewBackgroundColor is deprecated, use backgroundColor with colorSet: Theme.View instead
WARNING: viewBackgroundColor is deprecated, use backgroundColor with colorSet: Theme.View instead
KActivities: Database connection:  "kactivities_db_resources_140601025789568_readonly" 
    query_only:          QVariant(qlonglong, 1) 
    journal_mode:        QVariant(QString, "wal") 
    wal_autocheckpoint:  QVariant(qlonglong, 100) 
    synchronous:         QVariant(qlonglong, 0)
Nothing to load - the client id is empty
Nothing to load - the client id is empty
file:///usr/share/kpackage/genericqml/org.kde.systemsettings.sidebar/contents/ui/introPage.qml:90:27: Unable to assign [undefined] to QString
file:///usr/share/kpackage/genericqml/org.kde.systemsettings.sidebar/contents/ui/introPage.qml:90:27: Unable to assign [undefined] to QString

(tom) #13

do you know “rankmirrors”?

[tom@frija ~]$ LC_ALL=C rankmirrors -h
rankmirrors (pacman) v5.0.2

Ranks pacman mirrors by their connection and opening speed. Pacman mirror
files are located in /etc/pacman.d/. It can also rank one mirror if the URL is
provided.

Usage: rankmirrors [options] MIRRORFILE | URL

Options:
  --version      show program's version number and exit
  -h, --help     show this help message and exit
  -n NUM         number of servers to output, 0 for all
  -t, --times    only output mirrors and their response times
  -u, --url      test a specific URL
  -v, --verbose  be verbose in ouptut
  -r, --repo     specify a repository name instead of guessing

(Nuno Santos) #14

@brikler

Thank you. I’ll play a bit with rankmirrors.


(Luca Giambonini) #15

About systemsettings5: the output seems correct I can’t find and problem there. We are building the new framework, I hope that the new version can fix your problem.