Plasma 5.10.3 and Qt 5.9.1 available in Chakra

This announcement is also available in Italian and Spanish and Taiwanese Mandarin.

Hi everyone!

The latest Plasma release by KDE is now available to all Chakra users. Plasma 5.10.3 ships with several bug fixes and translation updates.

With this move, qt also gets updated to 5.9.1, the first bug fix release of the 5.9 series.

It should be safe to answer yes to any replacement question by Pacman. If in doubt or if you face another issue in relation to this update, please ask or report it below.

Most of our mirrors take 12-24h to synchronize, after which it should be safe to upgrade. To be sure, please use the mirror status page to check that your mirror synchronized with our main server after this announcement.

Ran into an error on my end…

[...]$: sudo pacman -Syu
error: failed to prepare transaction (could not satisfy dependencies)
:: lib32-expat: requires expat=2.1.1
:: lib32-libgcrypt: requires libgcrypt=1.7.5

But if I do pacman -Q lib32-expat it seem to indicate 2.1.1-1 is installed. Same for lib32-libgcrypt.

What is the output of pacman -Ss expat and pacman -Ss libgcrypt on your system?

I’ve run into a “nice” memory leak right after the update (also after reboot). plasmashell eats within about 10-15min 1GB of RAM. Oh boy, this is annoying.
Anyone else?

It seems the MediaFrame plasmoid is the culprit, every switch of an image adds some 2000 KB onto plasmashell

Thanks for the quick reply tetris4… I probably shouldn’t have sent that message so late on a Friday. That’s a laptop I keep at work and won’t be able to get to it until Monday. I’ll take a look Monday and report back. Thanks!

Yeah, past experience indicates that the first thing to check when something goes wrong after a Plasma upgrade is some misbehaving widget.

No rush. Fwiw, the issue here is that we have newer versions for these packages available in our repos, so depending on the output of those commands, I suspect a non-synced mirror used on your end.

OK, looks like I still get the errors this morning. Here is the output from pacman -Ss expat and pacman -Ss libgcrypt


I checked my mirrorlist file, and it appears the first uncommented in the list was an Australian one ($repro/x86_64)

I commented out everything besides the US mirrors and I am able to proceed with the updates now… must have been something strange with that Australian mirror…

1 Like

Glad to hear you resolved this. It must have been that the Australian mirror was late to sync. Usually choosing a mirror near you is a good option, or you could try a tool like rankmirrors.

This topic was automatically closed 170 days after the last reply. New replies are no longer allowed.