Pacman non riesce ad installare alcuni pacchetti

Questo problema è già stato affrontato in altri topic ma ugualmente non riesco a risolvere.
Ad es. quando provo ad installare digikam da terminale esce il seguente output:

errore: digikam: la firma di “Luca Giambonini gluca86@gmail.com” ha un’affidabilità sconosciuta
:: Il file /var/cache/pacman/pkg/digikam-1:6.3.0-2-x86_64.pkg.tar.xz è corrotto (il pacchetto non è valido oppure è corrotto (firma PGP)).
Andando a scrutare nel file chakra-signatures è risultata scaduta proprio la chiave di Luca Giambonini. Come posso risolvere in breve, premesso che sono un niubbo.

Grazie.

Risolto momentaneamente cambiando nel file /etc/pacman.conf l’opzione SigLevel= da “Required DatabaseNever” a “Never”. Però considerato che questo problema non è raro fra gli utenti di Chakra Linux sarebbe il caso di rivedere le regole del Package signing.

Risolto definitivamente con i seguenti comandi:
sudo pacman-key --init
sudo pacman-key --refresh-keys
sudo pacman-key --populate chakra
sudo pacman -Scc
sudo pacman -Syy

Ho aggiornato la scadenza della chiave :grin:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.