New Install and EFI problem: blue screen

uefi
(Jonajams) #1

Hi guys, I connect this topic to my previous: Catalyst-utils: requires xorg-server<1.18.0

I had a strange problem with my video card, so I decided to have a new install. Here my problems started…
I downloaded the newest chakra, made a live usb and installed. Everything ok, but on the reboot I had a blue screen with the ‘classic’ error about missing UEFI setting (Boot Configuration Data File is Missing), and every tutorial online tells to use a live win usb to solve it… So I made different version on my install, changing mount points or flags: nothing.
Hence now I stacked with my problem, cannot use my install and every solution is not-working.

Hope you can give me some help, it’s really really annoying!!

Catalyst-utils: requires xorg-server<1.18.0
(tom) #2

do you need grub? if not, i wont to suggest systemd-boot or efistub as bootloader

https://wiki.archlinux.org/index.php/Systemd-boot
or a simple example to setup efistub with / on /dev/sda2

sudo efibootmgr -c -d /dev/sda -p 1 -l \vmlinuz-linux -L "Chakra " -u "initrd=/initramfs-linux.img root=/dev/sda2 rw quiet

anyway check please if there a entry in the NVRAM

  1. start a live system
  2. open a konsole
  3. run efibootmgr to see and manage those entries
sudo efibootmgr
man efibootmgr
(Jonajams) #3

Ok i have to admit that i am not such an expert with chakra, so i was not able to do this

  • as my linux filesystem is on /dev/sdb2, i just copied your formula and changed this.
    it did not work out…
    now i am another time stucked…can you please tell me the step-by-step process…
    i would be sooo glad!!!
(tom) #4

what have you a partition layout?
from a live system check it with:

lsblk

as example my partition layout

[tom@frija ~]$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 111,8G  0 disk 
├─sda1   8:1    0    90M  0 part /boot
├─sda2   8:2    0  14,7G  0 part /
├─sda3   8:3    0  94,9G  0 part /home
└─sda4   8:4    0   2,2G  0 part [SWAP]
sudo efibootmgr -c -d /dev/sda -p 1 -l \vmlinuz-linux -L "Chakra " -u "initrd=/initramfs-linux.img root=/dev/sda2 rw quiet

perhaps … is the grub variant less complicated
check from from live media if exists on your installation

/boot/grub.cfg

than mount the mount the partitions and open a systemd-nspawn container

mount /dev/<your devices where root is> /mnt
mount /dev/<your devices where /boot is> /mnt/boot
grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub
(Jonajams) #5

ok this is weird, I do not have any mount point in my configuration!! the sdb is the part with chakra installed on

[live@localhost ~]$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0    7:0    0    48K  1 loop 
loop1    7:1    0 230.4M  1 loop 
loop2    7:2    0   1.7G  1 loop 
sda      8:0    0 931.5G  0 disk 
├─sda1   8:1    0   100M  0 part 
├─sda2   8:2    0    16M  0 part 
├─sda3   8:3    0 300.1G  0 part 
├─sda4   8:4    0 300.5G  0 part 
├─sda5   8:5    0 329.8G  0 part 
└─sda6   8:6    0     1G  0 part 
sdb      8:16   0 256.2G  0 disk 
├─sdb1   8:17   0   300M  0 part 
├─sdb2   8:18   0  47.8G  0 part 
├─sdb3   8:19   0  12.8G  0 part 
└─sdb4   8:20   0 195.3G  0 part 
sdc      8:32   1   7.5G  0 disk 
├─sdc1   8:33   1     2G  0 part /bootmnt
└─sdc2   8:34   1    31M  0 part 
sr0     11:0    1  1024M  0 rom  
[live@localhost ~]$ sudo efibootmgr -c -d /dev/sdb -p 1 -l \vmlinuz-linux -L "Chakra " -u "initrd=/initramfs-linux.img root=/dev/sdb2 rw quiet
> sudo efibootmgr -c -d /dev/sdb -p 1 -l \vmlinuz-linux -L "Chakra " -u "initrd=/initramfs-linux.img root=/dev/sdb2 rw quiet
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0006,2001,0005,0000,2002,2003
Boot0000* Linux
Boot0001* USB HDD: Freecom DATABAR
Boot0002* chakra
Boot0003* chakra1
Boot0004* chakra2
Boot0005* Windows Boot Manager
Boot000B* chakra3
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network
Boot0006* Chakra
(tom) #6

use code tags please because it is more easy to read :slight_smile:

[code]

[/code]

don’t be afraid it look normal at the view from the live system.

can you switch the boot order from sda and sdb?
it seems the grub was installed on the wrong hard drive i suppose on sdb.

back to evistub: you have in the NVRAM 5 entries for chakra and one for grub

Boot0000* Linux => entry for grub
Boot0002* chakra
Boot0003* chakra1
Boot0004* chakra2
Boot000B* chakra3
Boot0006* Chakra

…and no one entry does work for you?
so i would do a slight change:

sudo efibootmgr -c -d /dev/sda -p 1 -l \vmlinuz-linux -L "Chakra " -u "initrd=/initramfs-linux.img root=/dev/sdb2 rw quiet

you can delete unneeded entries, as example delet the third chakra entry

sudo efibootmgr -b 0003 -B
(Jonajams) #7
[live@localhost ~]$ sudo efibootmgr
BootCurrent: 0006
Timeout: 0 seconds
BootOrder: 000A,2001,0001,0000,2002,2003
Boot0000* Linux
Boot0001* Windows Boot Manager
Boot0002* chakra
Boot0003* chakra1
Boot0004* chakra2
Boot0005* chakra3
Boot0006* USB HDD: Freecom DATABAR
Boot0007* chakra1
Boot0008* chakra2
Boot0009* chakra3
Boot000A* Chakra 
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network

ok it did not work…i still have the blue screen with the error

(Jonajams) #8

Ok this post is exactely my same problem, and the solution proposed did not work for me…i am scared!

(Chroot Doot ✝) #9

If I can make a suggestion, while rEFInd is not technically a bootloader, but it is super easy to get running, fulfils everything that systemd-boot and grub do, and has the benefit of being super customable.

Unfortunately there isn’t a Chakra package for it, nor a CCR package (I might maintain one), however, manual installation is an option, as it shouldn’t mess with any other bootloaders since it’s relatively self contained (/boot/efi/EFI/refind), but I would still be cautious about attempting it.

For configuration, all you would have to do is add an entry pointing to /boot/vmlinuz-linux with an initrd subentry pointing to initramfs-linux.img.

I would try getting a Chakra-provided bootloader working before attempting this, as this is not supported by Chakra at the moment.

Best of luck. :v:

(tom) #10

…but there is one the AUR https://aur.archlinux.org/packages/?O=0&K=refind

@jonajams
have you “secure boot” disabled?
i found this to your problem:

(Jonajams) #11

I disable the security boot months ago, when it was on it was impossible to run the pc.

I found a solution (which I don’t like): I switched back to Legacy insted of UEFI and installed chakra, of course it works now.
I felt annoyed to spent 10 days trying to solve a problem which is supposed to be basic (all new pc have uefi as windows 10 runs on it).

(Chroot Doot ✝) #12

Well that makes it easier to maintain one for Chakra.

I have bad experiences with bootloaders, and what I’ve found is when one doesn’t work, it will never work. rEFInd has been flawless so far, so I will try to get a CCR package out for when I’m not busy (probably Saturday).

(Jonajams) #13

you know the funny thing, indeed: on my previous installation, I had legacy on and it did not work, so I had to switch to UEFI to run it…!! now, the contrary o.o

1 Like
(system) closed #14

This topic was automatically closed 85 days after the last reply. New replies are no longer allowed.