Linux kernel updates to address the Meltdown and Spectre vulnerabilities

linux-lts
linux

(Neofytos Kolokotronis) #1

This announcement is also available in Spanish and Taiwanese Mandarin.

Hi everyone,

this is a small but important upgrade of the Linux kernels in our repositories to address the recently discovered Meltdown and Spectre vulnerabilities affecting Intel’s CPUs.

As of now you’ll find available updates to linux 4.14.12 and linux-lts 4.4.110 and several rebuilds of the packages that depend on them.

We are keeping an eye on this and as new information becomes available we will try to provide the relevant fixes. Hopefully this makes you feel a bit more secure. :slight_smile:

If you are using Intel graphics and experiencing issues, please have in mind that OpenGL 2 is no longer supported for 3rd generation CPUs and you might be required to make some changes:

Some other notable updates include:

  • nvidia 387.34-1
  • php 7.1.13-1
  • intel-ucode 20180108-1

It should be safe to answer yes to any replacement question by Pacman. If in doubt or if you face another issue in relation to this update, please ask or report it below.

Most of our mirrors take 12-24 hours to synchronize with the central repositories on the origin server. Use the mirror status web page to see when your mirror of choice last synchronized.


Latest status of the testing repository [08 Jan 2018 - 16 Jan 2018]
我們的2018總結與2019展望
2018,我们有所作为;2019,我们翘首以待。
Here’s to our work done in 2018, and a great 2019!
Kernel upgrade fails (with a kernel panic upon reboot) after installing from the 2017.10 "Goedel" release and running `pacman -Syu`
(Neofytos Kolokotronis) closed #2

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.