Linux and systemd updates, with Plasma 5.13.5, Applications 18.08.1 and Frameworks 5.50 by KDE now available to all Chakra users

linux
curated
kde-plasma
systemd

(Neofytos Kolokotronis) #1

Also available in Italian, Spanish and Taiwanese Mandarin.

Hi everyone!

This time we have been a bit late, as many of our contributors were busy over the last couple of months, but we hope we can soon get back to normal delivery times. :blush:

Better late than never though, so we are happy to inform you that on your next system upgrade you will receive newer versions of KDE’s Plasma, Applications and Frameworks, in addition to updates to important packages such as the linux kernel and systemd. The latest Plasma 5.14 series should follow soon.

Please have in mind that we have removed the nvidia-304xx package from Chakra’s repositories because it is no longer compatible with new kernel releases. If you are using nvidia-304xx on your system, you should either install and use the linux-lts kernel and the corresponding nvidia-304xx-lts package, or switch to the free nouveau driver.

For more details and the full changelogs on KDE’s software releases, you can read the official announcements:

13-wee

Noteworthy package updates include:

[core]

  • curl 7.61.1
  • gcc 8.2.0
  • linux 4.18.12
  • linux-lts 4.4.152
  • nvidia 410.57
  • nvidia-390xx 390.87
  • openssh 7.8p1
  • systemd 239.0
  • vlc 3.0.4

[lib32]

  • wine 3.18

It should be safe to answer yes to any replacement question by the package manager application. If in doubt or if you face another issue in relation to this update, please ask or report it below.

Most of our mirrors take 12-24 hours to synchronize with the central repositories on the origin server. Use the mirror status web page to see when your mirror of choice last synchronized.

Enjoy!


Actualizaciones de Linux y systemd, con Plasma 5.13.5, Aplicaciones 18.08.1 y Frameworks 5.50 de KDE ahora disponibles para todos los usuarios de Chakra
(Johannes) #2

Great news! I hope everybody is doing fine.


(Cyril Brosch) #3

Great! Updating right now and keeping fingers crossed that the switch from nvidia to nouveau will work…

Will there be a new Chakra CD in the foreseeable future? I have a new notebook, but “Goedel” is 1 year old now and I don’t want to download and install 2GB in order to have 1,5GB of updates afterwards.


(tomaggio) #4

Hi there;
I’ve got a dependency Problem. linux- 4.8.12 is going to be installed but the Package nvidia wants 4.8.6.
Perhaps it’s only typo in the package. Thanks a lot.
Tomaggio


(Cyril Brosch) #5

‘nvidia’ is not compatible, take a look at the announcement.


(tomaggio) #6

The announcement says: 304 but i am running 396


(JC) #7

Hi all
After this update keyboard not working in my netbook, so I’cant login in SDDM


(tom) #8

@F4AW
and after a simple reboot?

@all
please check always the pacman.log for errors before reboot!


(Francesco Marinucci) #9

Package nvidia-390xx depends on the right linux version, while nvidia still depends on 4.8.6.
As soon as I finish building the new Plasma release, I’ll take care of that.

Try to login in single user mode and re-run the update: there has been a problem moving the updated libinput to stable and it wasn’t available for a while.

We’re working on it, @brli is building a test one right now . It should be available soon for testing.


(tomaggio) #10

Thanks a lot Francesco
:grinning:


(TheOliver) #11

I’m having the same problem, i.e., it seems to be a more general issue.


(Jeff Huang) #12

Well, for keyboard, go into runlevel 3 is enough, don’t need directly go into single user mode.


(James) #13

I have a problem with the package nvidia-settings, says depends of nvidia-utils 396.24 then it can’t update because it’s trying to install nvidia-utils 410.57-1


(tomaggio) #14

Thanks again Francesco for your work! My machine is updated without a flaw.


(Neofytos Kolokotronis) #15

Is this fixed by now? If not, what is the output of pacman -Sii nvidia-settings? Are you sure your mirror is synced?


(richard.llom) #16

Nice!
And when comes updated Mesa? There is already Mesa 18.2.3


(Agame) #17

Hello everyone ! I just tried the update today. I use the r8168 module for my network card, because the other compatible modules make the connection unstable.
But it seems the version in the repos is not compiled against the 4.18.12-1 kernel. When I pacman -Syu I get the following error :

r8168 : installing linux (4.18.12-1) breaks the dependency « linux=4.16.6 »

Is it possible to update the r8168 package so that it works with the new kernel ?
Have a nice day.


(brli) #18

Hi, sorry for the inconvenience.

This was an error on our side when moving packages from testing to stable.

It should be fixed right now.


(Facundo Gabriel Adorno) #19

Hi! Recently I have updated the system and works like a charm! Thanks for bring us new updates constantly!!


(Txeyen) #20

warning: cannot resolve “nvidia-304xx-utils=304.137”, a dependency of “nvidia-304xx-lts”
:: The following package cannot be upgraded due to unresolvable dependencies:
nvidia-304xx-lts