Libreoffice doesn't look like the rest of the desktop anymore

gtk
qt
libreoffice
(S.F.) #3

I get:

libreoffice-common /usr/lib/libreoffice/program/libvclplug_genlo.so
libreoffice-kde4 /usr/lib/libreoffice/program/libvclplug_kde4lo.so

(Rémy Epke) #4

Put terminal output in code-tags, now it’s only two lines but if it gets more those tags will keep it sane.
Also, the package you’re looking for is likely core/breeze-gtk.

1 Like
(brli) #5

What do you mean by “last upgrade”?
I mean, we don’t know how often you upgrade your system, and we can’t tell what you’ve really upgraded.
So, please read the about page first and ask for help in a more informative way.

Please use code tag provided as the symbol “</>”

IMHO, it should be core/breeze-kde4
As our LO is in fact using the KDE4 interface rather than the gtk one.

2 Likes
(Rémy Epke) #6

I was unaware of this, or of even the existence of core/breeze-kde4.
Guess that comes with the Chakra install (or at least did when my desky was reinstalled a year and half ago), where I’ve always had to install the GTK version manually.
Thanks for clearing that up.

(S.F.) #7

I was referring to the last time I upgraded the libreoffice packages, sorry, I thought it was clear. It was two days ago.

Thanks for your advice, brli and ReemZ. Unfortunately, both the packages you are referring to, both breeze-gtk and breeze-kde4, are already installed in my system.

(totte) #8

This is still vague. The #help category has a template for new topics which makes it easy for you to provide the relevant information, such as the pacman.log file in this case, which tells us exactly what was upgraded to which version and when. Please use the prepared template when asking questions, since it makes it easier for us to help you.

(brli) #9

So now, it is time to check your configurations.

Please share your /etc/profile.d/libreoffice.sh

https://wiki.archlinux.org/index.php/LibreOffice#Theme

(Neofytos Kolokotronis) #10

Speaking of configuration, did you check that Breeze is used everywhere under System Settings > Application Style > GNOME Application Style (GTK)?

(S.F.) #11

Thanks again for your replies

I did and it is.

Weird… that file does not exist in my system.

(brli) #12

Well…that is our fault, we didn’t include it…

Please try to run LO with following command (using Writer as example):

$ SAL_USE_VCLPLUGIN=kde4 lowriter

And see if things are going fine.

(S.F.) #13

I’m afraid the problem persists.

(brli) #14

Can you apply the theme again at “Look and feel” under System Settings?

(Francesco Marinucci) #15

LibreOffice doesn’t depend on GTK+, so its appearence shouldn’t depend on GTK+ “look ‘n’ feel” settings.
The Writer, Draw, Calc, etc. packages depend on libreoffice-kde4, which provides the Plasma integration and you shouldn’t need anything else.

Check that you have the right version of libreoffice-kde4 installed on your system.

(S.F.) #16

If the right version is libreoffice-kde4-5.3.6-1, then yes

(tom) #17

perhaps does libreoffice-gtk3 the trick?

[tom@frija ~]$ pacman -Ss libreoffice-gtk
testing/libreoffice-gtk3 5.4.1-1 (libreoffice)
    Plug-in for LibreOffice that enables GTK3 engine.
gtk/libreoffice-gtk3 5.3.6-1 (libreoffice)
    Plug-in for LibreOffice that enables GTK3 engine.
(S.F.) #18

Yes, it worked! Looks as usual again. Thank you very much!

1 Like
(Francesco Marinucci) #19

This is just a workaround, not a proper solution.

1 Like
(S.F.) #20

Sorry, I’m confused. How is that so?

(Francesco Marinucci) #21

Installing libreoffice-gtk LibreOffice is acting like a GTK application and it looks “fine” because of the GTK integration settings; in other words, it’s not directly integrated with Plasma’s appearence.
As I already said, the only package needed to have LibreOffice graphicaly integrated with Plasma is libreoffice-kde4. To really solve your issue we should understand why that doesn’t work properly.

1 Like
(tom) #22

i would delete LO settings and relogin