Libreoffice doesn't look like the rest of the desktop anymore

After performing the last upgrade, Libreoffice looks like a Windows 95 app. I remember I had this problem a while ago, which I solved by installing a few packages destined to make the gtk apps look pretty, but I don’t rememeber which packages those were and I don’t know what changed.
I’m wondering if anybody else has the same issue and whether anybody knows a fix.

Please share your result of the following command:

$ pacman -Ql | grep libvclplug

I get:

libreoffice-common /usr/lib/libreoffice/program/
libreoffice-kde4 /usr/lib/libreoffice/program/

Put terminal output in code-tags, now it’s only two lines but if it gets more those tags will keep it sane.
Also, the package you’re looking for is likely core/breeze-gtk.

1 Like

What do you mean by “last upgrade”?
I mean, we don’t know how often you upgrade your system, and we can’t tell what you’ve really upgraded.
So, please read the about page first and ask for help in a more informative way.

Please use code tag provided as the symbol “</>”

IMHO, it should be core/breeze-kde4
As our LO is in fact using the KDE4 interface rather than the gtk one.


I was unaware of this, or of even the existence of core/breeze-kde4.
Guess that comes with the Chakra install (or at least did when my desky was reinstalled a year and half ago), where I’ve always had to install the GTK version manually.
Thanks for clearing that up.

I was referring to the last time I upgraded the libreoffice packages, sorry, I thought it was clear. It was two days ago.

Thanks for your advice, brli and ReemZ. Unfortunately, both the packages you are referring to, both breeze-gtk and breeze-kde4, are already installed in my system.

This is still vague. The #help category has a template for new topics which makes it easy for you to provide the relevant information, such as the pacman.log file in this case, which tells us exactly what was upgraded to which version and when. Please use the prepared template when asking questions, since it makes it easier for us to help you.

So now, it is time to check your configurations.

Please share your /etc/profile.d/

Speaking of configuration, did you check that Breeze is used everywhere under System Settings > Application Style > GNOME Application Style (GTK)?

Thanks again for your replies

I did and it is.

Weird… that file does not exist in my system.

Well…that is our fault, we didn’t include it…

Please try to run LO with following command (using Writer as example):

$ SAL_USE_VCLPLUGIN=kde4 lowriter

And see if things are going fine.

I’m afraid the problem persists.

Can you apply the theme again at “Look and feel” under System Settings?

LibreOffice doesn’t depend on GTK+, so its appearence shouldn’t depend on GTK+ “look ‘n’ feel” settings.
The Writer, Draw, Calc, etc. packages depend on libreoffice-kde4, which provides the Plasma integration and you shouldn’t need anything else.

Check that you have the right version of libreoffice-kde4 installed on your system.

If the right version is libreoffice-kde4-5.3.6-1, then yes

perhaps does libreoffice-gtk3 the trick?

[tom@frija ~]$ pacman -Ss libreoffice-gtk
testing/libreoffice-gtk3 5.4.1-1 (libreoffice)
    Plug-in for LibreOffice that enables GTK3 engine.
gtk/libreoffice-gtk3 5.3.6-1 (libreoffice)
    Plug-in for LibreOffice that enables GTK3 engine.

Yes, it worked! Looks as usual again. Thank you very much!

1 Like

This is just a workaround, not a proper solution.

1 Like

Sorry, I’m confused. How is that so?