Latest status of the testing repository [23 Oct 2017 - 30 Nov 2017]


(Neofytos Kolokotronis) #1

Hi @testers,

From now on I will start a new thread when the packages have moved into the stable repositories and testing is emptied. Hopefully this will help everyone keep better track of the new packages introduced and any issues that come up.

I take this opportunity to ask our @team members to post here any important updates or changes they push into testing that might affect users. Examples of these could be related to:

  • Package groups
  • Popular or important packages
  • Libraries that break backwards compatibility

(Neofytos Kolokotronis) #2

Plasma 5.11.2 just landed. :slight_smile:


(Neofytos Kolokotronis) #3

Plasma 5.11.2 moved into stable.

This update is now available, please report any issues on the dedicated thread:


(Neofytos Kolokotronis) #4

Kernel updage now available, please report any issues on the dedicated thread:


(Neofytos Kolokotronis) #5

Plasma 5.11.3 just uploaded.


(Neofytos Kolokotronis) #6

New Firefox just landed:


(Neofytos Kolokotronis) #7

KDE Applications 17.08.03 and Frameworks 5.4.0, including systemd 235.38 and other core package updates are now in testing.

The plan is to wait for Plasma 5.11.4 to be released in a couple of days and then move it together with all these into stable.


(Neofytos Kolokotronis) #8

Just a warning. For whatever reason, after performing this upgrade I ended up with a black screen with a cursor and sddm not loading. To workaround it, I had to enable autologin via /etc/sddm.conf and then reboot. That worked, so I went ahead and disabled it again and rebooted and sddm now loaded fine. For whatever reason, this fixed the black screen issue for me.


No graphical interface after upgrading sddm from 0.15.0-1 to 0.16.0-1
(Neofytos Kolokotronis) #9

Plasma 5.11.4 just landed in testing.

If no issues occur, and since this is a final bug fix release and .3 never moved, everything will move into stable in 1-2 days.


(tom) #10

this upgrade has solved the sddm “black screen after boot”-issue it seems


No graphical interface after upgrading sddm from 0.15.0-1 to 0.16.0-1
(Neofytos Kolokotronis) #11

Interesting. In what way? Where you affected by this?


(tom) #12

i mean this problem because for me it is gone :slight_smile:

chakra-check-links doesn’t work for me anymore

[tom@frija ~]$ chakra-check-links 
Checking libraries and binaries
  0%|                                                                 | 0/9383 [00:00<?, ?it/s]
Traceback (most recent call last):
  File "/usr/bin/chakra-check-links", line 203, in <module>
    htmlreport = b.report()
  File "/usr/bin/chakra-check-links", line 173, in report
    missing_libs, broken_packages = self.check()
  File "/usr/bin/chakra-check-links", line 157, in check
    self.collect_needed(lib_or_bin)
  File "/usr/bin/chakra-check-links", line 146, in collect_needed
    self.lib2required_by[bytes2str(tag.needed)].append(sofile)
  File "/usr/lib/python3.6/site-packages/elftools/common/py3compat.py", line 22, in bytes2str
    def bytes2str(b): return b.decode('latin-1')
AttributeError: 'str' object has no attribute 'decode'

(Neofytos Kolokotronis) #13

Can you please report this on our bugtracker? I am closing this thread now as everything has moved into stable.


(Neofytos Kolokotronis) closed #14