Latest status of the testing repository [20 May 2018 - 14 June 2018]

mesa
systemd
linux

(Neofytos Kolokotronis) #1

Hey @testers,

An update of the kernel group of packages just landed in testing, including linux 4.16.6, systemd 238.76
and mesa 18.0.4.

Pllease report below any issues you come across related to this update.

The current plan is to start working on the sound group next.


Kernel upgrade fails (with a kernel panic upon reboot) after installing from the 2017.10 "Goedel" release and running `pacman -Syu`
Udev: fragile handling of uevent actions breaks with kernel 4.12+, can't connect to Android phone through Dophin
(tom) #2

the problem persists Latest testing status [2 May 2018 - 19 May 2018]
in to multi-users.target can i boot but not in to graphical.target it’s impossible.

-- Logs begin at Sun 2018-05-20 21:18:23 CEST, end at Sun 2018-05-20 21:19:14 CEST. --
Mai 20 21:18:23 donar systemd[1]: Failed to load default target: No such file or directory

(gopona) #3

Hi,
My latte-dock panel becomes pitch black with mesa 18.0.4, no more transparency. The dashboard app launcher also shows the same behavior. Downgrading to mesa 17.3.3-2 fixes the issue.
My graphic card:
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)


(Neofytos Kolokotronis) #4

As you have this issue with a custom kernel, it’s hard to say what the cause of it is. Perhaps something changed upstream.

I can replicate this with yakuake also, on a system running the same intel graphics card.


(tom) #5

@tetris4
it is our kernel not the ck kernel and the same behaviour on two notebook and rc6pp doesn’t work because the option enable_rc6= is removed


(Neofytos Kolokotronis) #6

To report another issue, I’m afraid the camera on my laptop stopped working after this. :confused:

Hmm, so this is caused by a change in how we compile the kernel?


(Hans Tovetjärn) #7

A post was split to a new topic: Udev: fragile handling of uevent actions breaks with kernel 4.12+, can’t connect to Android phone through Dophin


(tom) #8

definitely not because the same problem with linux-ck


(tom) #9

gst-vaapi, bomi and mpv need to be rebuild

Broken package    |Broken file                   |Missing .so files          |
|                  |/usr/bin/bomi                 |libva-x11.so.1             |
|                  |/usr/bin/bomi                 |libva-glx.so.1             |
|                  |/bin/bomi                     |libva-x11.so.1             |
|bomi              |/usr/bin/bomi                 |libva.so.1                 |
|                  |/bin/bomi                     |libbluray.so.1             |
|                  |/bin/bomi                     |libva-glx.so.1             |
|                  |/bin/bomi                     |libva.so.1                 |
|                  |/usr/bin/bomi                 |libbluray.so.1             |
|grub              |/bin/grub-mount               |libfuse.so.2               |
|                  |/usr/bin/grub-mount           |libfuse.so.2               |
|                  |/usr/lib/gstreamer-1.0/       |libmpcdec.so.5             |
|                  |libgstmusepack.so             |                           |
|gst-plugins-bad   |/usr/lib/gstreamer-1.0/       |libkate.so.1               |
|                  |libgstkate.so                 |                           |
|                  |/usr/lib/gstreamer-1.0/       |libdc1394.so.22            |
|                  |libgstdc1394.so               |                           |
|                  |/usr/lib/libgstvaapi-         |libva.so.1                 |
|                  |1.6.so.1.0.0                  |                           |
|                  |/usr/lib/libgstvaapi-drm-     |libva-drm.so.1             |
|                  |1.6.so.1.0.0                  |                           |
|                  |/usr/lib/libgstvaapi-wayland- |libva.so.1                 |
|                  |1.6.so.1.0.0                  |                           |
|                  |/usr/lib/libgstvaapi-glx-     |libva-x11.so.1             |
|                  |1.6.so.1.0.0                  |                           |
|gst-vaapi         |/usr/lib/libgstvaapi-x11-     |libva-x11.so.1             |
|                  |1.6.so.1.0.0                  |                           |
|                  |/usr/lib/libgstvaapi-glx-     |libva.so.1                 |
|                  |1.6.so.1.0.0                  |                           |
|                  |/usr/lib/libgstvaapi-x11-     |libva.so.1                 |
|                  |1.6.so.1.0.0                  |                           |
|                  |/usr/lib/libgstvaapi-drm-     |libva.so.1                 |
|                  |1.6.so.1.0.0                  |                           |
|                  |/usr/lib/libgstvaapi-wayland- |libva-wayland.so.1         |
|                  |1.6.so.1.0.0                  |                           |
|                  |/usr/lib/ImageMagick-6.9.9/   |libwmflite-0.2.so.7        |
|imagemagick       |modules-Q16HDRI/coders/wmf.so |                           |
|                  |/usr/lib/ImageMagick-6.9.9/   |libIlmImf-Imf_2_0.so.20    |
|                  |modules-Q16HDRI/coders/exr.so |                           |
|iproute2          |/usr/lib/tc/q_atm.so          |libatm.so.1                |
|kde-runtime       |/usr/lib/kde4/exrthumbnail.so |libIlmImf-Imf_2_0.so.20    |
|                  |/usr/lib/qt5/plugins/plasma/  |                           |
|                  |dataengine/                   |libKF5KrossCore.so.5       |
|kdeplasma-addons  |plasma_engine_comic.so        |                           |
|                  |/usr/lib/qt5/plugins/         |libKF5KrossCore.so.5       |
|                  |plasma_comic_krossprovider.so |                           |
|                  |/usr/lib/qt5/plugins/kf5/     |                           |
|kfilemetadata     |kfilemetadata/                |libepub.so.0               |
|                  |kfilemetadata_epubextractor.so|                           |
|ldns              |/usr/bin/ldns-dpa             |libpcap.so.1               |
|                  |/bin/ldns-dpa                 |libpcap.so.1               |
|libffado          |/bin/ffado-dbus-server        |libdbus-c++-1.so.0         |
|                  |/usr/bin/ffado-dbus-server    |libdbus-c++-1.so.0         |
|libreoffice-calc  |/usr/lib/libreoffice/program/ |libetonyek-0.1.so.1        |
|                  |libwpftcalclo.so              |                           |
|                  |/usr/lib/libreoffice/program/ |libzmf-0.0.so.0            |
|libreoffice-common|libwpftdrawlo.so              |                           |
|                  |/usr/lib/libreoffice/program/ |libjawt.so                 |
|                  |libofficebean.so              |                           |
|libreoffice-writer|/usr/lib/libreoffice/program/ |libetonyek-0.1.so.1        |
|                  |libwpftwriterlo.so            |                           |
|lm_sensors        |/sbin/sensord                 |librrd.so.8                |
|                  |/usr/sbin/sensord             |librrd.so.8                |
|                  |/usr/lib/libmpv.so.1.25.0     |libva.so.1                 |
|                  |/bin/mpv                      |libva.so.1                 |
|                  |/usr/bin/mpv                  |libva.so.1                 |
|                  |/bin/mpv                      |libbluray.so.1             |
|                  |/usr/lib/libmpv.so.1.25.0     |libbluray.so.1             |
|                  |/usr/bin/mpv                  |libva-drm.so.1             |
|                  |/usr/lib/libmpv.so.1.25.0     |libva-wayland.so.1         |
|mpv               |/bin/mpv                      |libva-wayland.so.1         |
|                  |/usr/lib/libmpv.so.1.25.0     |libva-drm.so.1             |
|                  |/bin/mpv                      |libva-drm.so.1             |
|                  |/usr/lib/libmpv.so.1.25.0     |libva-x11.so.1             |
|                  |/usr/bin/mpv                  |libva-x11.so.1             |
|                  |/bin/mpv                      |libva-x11.so.1             |
|                  |/usr/bin/mpv                  |libva-wayland.so.1         |
|                  |/usr/bin/mpv                  |libbluray.so.1             |
|                  |/usr/lib/qt5/plugins/okular/  |                           |
|                  |generators/                   |libepub.so.0               |
|okular            |okularGenerator_epub.so       |                           |
|                  |/usr/lib/qt5/plugins/okular/  |                           |
|                  |generators/                   |libqmobipocket.so.2        |
|                  |okularGenerator_mobi.so       |                           |
|                  |/usr/lib/qt5/plugins/plasma-  |libgps.so.22               |
|                  |geolocation-gps.so            |                           |
|                  |/usr/lib/qt5/plugins/plasma-  |libKF5NetworkManagerQt.so.6|
|plasma-workspace  |geolocation-ip.so             |                           |
|                  |/usr/lib/qt5/plugins/plasma/  |                           |
|                  |dataengine/                   |libKF5NetworkManagerQt.so.6|
|                  |plasma_engine_geolocation.so  |                           |
|python2           |/usr/lib/python2.7/lib-       |libtk8.6.so                |
|                  |dynload/_tkinter.so           |                           |
|                  |/usr/lib/python3.6/lib-       |                           |
|python3           |dynload/_tkinter.cpython-36m- |libtk8.6.so                |
|                  |x86_64-linux-gnu.so           |                           |
|                  |/usr/lib/qt/plugins/          |libodbc.so.2               |
|                  |sqldrivers/libqsqlodbc.so     |                           |
|qt                |/usr/lib/qt/plugins/          |libsybdb.so.5              |
|                  |sqldrivers/libqsqltds.so      |                           |
|                  |/usr/lib/qt/plugins/          |libpq.so.5                 |
|                  |sqldrivers/libqsqlpsql.so     |                           |
|                  |/usr/lib/qt5/plugins/         |libodbc.so.2               |
|                  |sqldrivers/libqsqlodbc.so     |                           |
|qt5-base          |/usr/lib/qt5/plugins/         |libsybdb.so.5              |
|                  |sqldrivers/libqsqltds.so      |                           |
|                  |/usr/lib/qt5/plugins/         |libpq.so.5                 |
|                  |sqldrivers/libqsqlpsql.so     |                           |
|                  |/usr/lib/qt5/plugins/         |                           |
|                  |texttospeech/                 |libflite_cmulex.so.1       |
|                  |libqttexttospeech_flite.so    |                           |
|                  |/usr/lib/qt5/plugins/         |                           |
|                  |texttospeech/                 |libflite_usenglish.so.1    |
|                  |libqttexttospeech_flite.so    |                           |
|                  |/usr/lib/qt5/plugins/         |                           |
|qt5-speech        |texttospeech/                 |libflite.so.1              |
|                  |libqttexttospeech_flite.so    |                           |
|                  |/usr/lib/qt5/plugins/         |                           |
|                  |texttospeech/                 |libspeechd.so.2            |
|                  |libqtexttospeech_speechd.so   |                           |
|                  |/usr/lib/qt5/plugins/         |                           |
|                  |texttospeech/                 |libflite_cmu_us_kal16.so.1 |
|                  |libqttexttospeech_flite.so    |                           |
|qt5-webengine     |/usr/lib/                     |libre2.so.0                |
|                  |libQt5WebEngineCore.so.5.10.1 |                           |

(Neofytos Kolokotronis) #10

New xorg and driver upgrades just landed in testing.

In my case, this fixes both the transparency and camera issues, @gopona is it the same for you?

However the libva upgrade breaks several packages, as @brikler mentions:

  • avidemux-cli
  • bomi
  • ffmpeg2.8
  • freshplayerplugin
  • gst-vaapi
  • kodi
  • mplayer-vaap
  • mpv
  • mythtv

@brikler is your issue by any chance related to the udev issue posted above?


(gopona) #11

@tetris4, I no longer have the transparency issues on the latte-dock panel and the dashboard after upgrade.


(tom) #12

do you mean the moved post? if, it then i think not.

edit
systemd 238.76 doesn’t change anything but i couldn’t build systemd
the build breaks here

==> Starting prepare()...
fatal: No such remote: upstream
Updating upstream
remote: Counting objects: 8324, done.
remote: Compressing objects: 100% (1891/1891), done.
remote: Total 8324 (delta 6822), reused 7675 (delta 6247)
Receiving objects: 100% (8324/8324), 1.64 MiB | 8.52 MiB/s, done.
Resolving deltas: 100% (6822/6822), completed with 1564 local objects.
From ../systemd
 * [new branch]          master     -> upstream/master
Note: checking out 'f398c546c6fc43121131f41acec56b5a851bd35e'.

You are in 'detached HEAD' state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by performing another checkout.

If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -b with the checkout command again. Example:

  git checkout -b <new-branch-name>

HEAD is now at f398c546c... systemd-udevd: limit children-max by available memory (#8668)
patching file rules/50-udev-default.rules.in
patching file sysusers.d/basic.conf.in
==> Starting pkgver()...
HEAD is now at f398c546c... systemd-udevd: limit children-max by available memory (#8668)
==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version: pkgver
pkgver2
M       rules/50-udev-default.rules.in
M       src/nspawn/nspawn.c
M       sysusers.d/basic.conf.in
238.76
==> Removing installed dependencies...

(Rémy Epke) #13

Didn’t read through the whole thread, but it’s the only one coming up when searching for libre2.so as that’s in the error message I get when trying to launch Falkon:

$ falkon
falkon: error while loading shared libraries: lirbe2.so.0: cannot open shared object file: No such file or directory

In stable, Falkon works. Difference is the version of qt5-webengine: 5.10.1-1 in stable, 5.10.1-2 in testing.

edit: qt5-webengine 5.11.0-2 solved that little problem, Falkon works again.


(Neofytos Kolokotronis) #14

It turns out that the kernel group that moved into the testing repo overlapped with the sound group being prepared in parallel in our staging repository. So we decided to move this group upgrade to testing as well to fix the issues caused in the meantime and make sure the upgrade is done properly.

Please let us know if indeed your issues are resolved or if something else is still broken.

Some important packages have received updates:

  • qt5 5.11.0
  • ffmpeg 4.0
  • pulseaudio 11.1

(kepszlok) #15

With -Syu…

smplayer: installing mpv (0.28.2-1) breaks dependency ‘mplayer’


(Luca Giambonini) #16

This is the error message you get in the terminal? do you have smplayer installed?


(kepszlok) #17

Yes, i have smplayer installed in this Chakra installation.

Of corse, i did not get this error on my other installation withouth smplayer.


(tom) #18

kernel 4.17 solves this issue, it seems but it need a terrible long time to mount /

[tom@frija ~]$ uname -r
4.17.0-1-ARCH

(Neofytos Kolokotronis) #19

Everything has now moved into stable: