Kwin fails to initialize, black screen with cursor

2 of my 3 Chakra installations works fine with latest testing. But one of them has some problem with EGL since the plasma update.

journalctl:
jan 05 16:58:19 kepsz-pc kwin_x11[633]: kwin_core: choose config failed
jan 05 16:58:19 kepsz-pc kwin_x11[633]: kwin_core: Creating egl surface failed
jan 05 16:58:19 kepsz-pc kdeinit5[593]: kscreen.kded: Saving current config to file
jan 05 16:58:19 kepsz-pc kdeinit5[593]: kscreen.kded: Config saved on: "/home/kepsz/.local/share/kscreen/dd0b57b77c1f11ab7d9fd7f0d11cb48e"
jan 05 16:58:19 kepsz-pc kdeinit5[593]: kscreen.kded: KScreen::Output( 69 “HDMI-A-0” connected enabled QPoint(0,0) QSize(1920, 1080) “72” )
jan 05 16:58:19 kepsz-pc kwin_x11[633]: kwin_core: Failed to initialize compositing, compositing disabled

And then i get only a black screen with a working mouse pointer.

This issue may not related with this Plasma update, because of my recent problems with plasma. This happend on my desktop with my second Chakra, where my first Chakra works fine, so it’s not machine related.
Deleting kwinrc config did nothing.

Sadly, i will not be at home till sunday to investigate this issue further.

Hmm. The EGL option was removed over a year ago because it caused issues. Is there a particular reason you are using it?

btw, is ‘History’ under the application launcher menu missing for anyone else after this update?

If you can switch to another tty (e.g. Ctrl+Alt+F3) you can check with

$ cat ~/.config/kwinrc | grep Backend

Try switching it to Backend=OpenGL or Backend=XRender and see if it helps.

Otherwise enter this installation via systemd-nspawn or boot a live ISO and check this file.

I did not touched this EGL thing. This is my older Chakra, maybe something in the past changed it. I don’t even know where to set EGL to GLX.

TTY works, but adding Backend option did not do anything. But in my working Chakra, there are no Backend=… line at all in kwinrc.
So i think it’s deffined in some other file.

Did you try with both OpenGL and Xrender and it’s the same error? I am not sure where else this is defined.

A quick search revealed several related threads, for example:

Can you check the outputs as suggested there, to check for more info?

journalctl -p err -b 

and

glxinfo | grep OpenGL

PS: I am moving this into it’s own thread.

Hi,
I got similar problems after yesterday’s updates. Plasma doesn’t run, all windows are borderless and bottom/side panels don’t work.
On start or whenever I execute “plasmashell” I got message window (translated):
Plasma cannot be executed because it cannot use OpenGL 2. Please check your setting of your drivers.

Point is that I use XRandr.

glxinfo
Error: couldn’t find RGB GLX visual or fbconfig

journalctl -p err -b

led 08 14:39:46 nb-msi plasmashell[1545]: Open GL context could not be created

I can start System Setting and switch to XRandr but it does not help.
Also XRandr is set correctly in ~/.config/kwinrc

Thanks for help,

B.

EDIT: Some more info:

lspci -k | grep -iA3 vga
08:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV730/M96-XT [Mobility Radeon HD 4670]
Subsystem: Micro-Star International Co., Ltd. RV730/M96-XT [Mobility Radeon HD 4670]
Kernel driver in use: radeon
Kernel modules: radeon

[ 24.537] (II) RADEON(0): Acceleration enabled
[ 24.537] (==) RADEON(0): DPMS enabled
[ 24.537] (==) RADEON(0): Silken mouse enabled
[ 24.538] (II) RADEON(0): Set up textured video
[ 24.538] (II) RADEON(0): [XvMC] Associated with Radeon Textured Video.
[ 24.538] (II) RADEON(0): [XvMC] Extension initialized.
[ 24.538] (II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[ 24.539] (–) RandR disabled
[ 24.546] (EE) AIGLX error: dlopen of /usr/lib/xorg/modules/dri/r600_dri.so failed (libLLVM-4.0.so: cannot open shared object file: No such file or directory)
[ 24.546] (EE) AIGLX: reverting to software rendering
[ 24.547] (EE) AIGLX error: dlopen of /usr/lib/xorg/modules/dri/swrast_dri.so failed (libLLVM-4.0.so: cannot open shared object file: No such file or directory)
[ 24.547] (EE) GLX: could not load software renderer
[ 24.547] (II) GLX: no usable GL providers found for screen 0

@Blaazen did you install llvm-libs? it is part of the dependency of mesa, which includes the /usr/lib/xorg/modules/dri/ part IIRC.

I was wrong. In my desktop, none of the two chakra installation works. Somehow i did missed the last kde update with the first one…

I’m using AMD RX460. I was not able to get glxinfo, because with tty, it can not connect to the display.

Journalctl did not get any related error msg. And the output of journalctl -p err -b was the same before the update and after the update.

Maybe we experiencing some kwin regression?

Yes, I have it. Also the /usr/lib/xorg/modules/dri/r600_dri.so
But the llvm verison in repo is 5.0 while log says about 4.0.

Thanks, B.

EDIT:
I resolved it. Plasma now works. Solution was to move back to llvm-libs 4.0.
As a side effect I had to uninstall llvm, clang, qtcreator and qbs.

B.

EDIT2 (I cannot add a new post because I am new here):

Now it all (mesa + lvm-libs5 + qtceator etc.) works well again. Thank you very much!

Summary

Should be fixed in testing https://code.chakralinux.org/packages/core/issues/41

If you want you can try to enable [testing] and update (includes also the new kernel and new intel drivers)

mesa MOVED! to stable

My problems are also gone after this update! :slight_smile:

hey, you mean the mesa update to 17.3.1 or something else?
I’m asking cause it seems that mesa update breaks several apps:


Yes, the mesa and xf86-video-amdpgu got the update today for me.

mesa try to open a not existing file but this file is in /usr/lib and this is wired because .so files always in /usr/lib perhaps exist a patch to point in the right directory

xorg-server 1.19.5-2 was urgently pushed into stable a few hours ago, rebuilt against the new mesa. It should resolve all the issues related to this.

@kepszlok can you mark the thread as solved please? You click the three dots icon “…” under the post that offers the solution, then select the tick box :ballot_box_with_check:.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.