Keyboard Input broken in Plasma

Since today I have a really strange problem under plasma with keyboard input:

  • on every (number, letter, arrow keys and return) key it is pasting my clipboard contents.
  • if I push Ctrl in Yakuake it says “You are trying to paste non-printable characters (/xd).”
  • arrow keys are strange, if I press left cursor goes left and then immediately right again, same for the other 3 directions.
  • and more other strange things…
    So in other words totally fu**** up.

However this doesn’t happen in SDDM (login screen), nor at the boot manager. So this is definitely not a hardware defect. But it happens for all users on the system, so not a user settings either…

I already tried changing the keyboard layout under system settings, but to no avail…

Appreciate any help…

Can you share a bit more on any changes you made today that might have caused this?

Really nothing. I’m talking about Dell Latitude E6400 Notebook. I had it lying around (with a dead battery) for maybe a month or a little more.

After a little usage I found out that the symptoms are coming and going, so it does point more to a hardware defect.

Under windows I can use the keyboard fine, but the touchpad and buttons don’t work in windows dialogs and on the taskbar, but it does work in notepad. So really strange…

Ok, it was hardware defect after all and I was able to fix it by this:

Sorry for the fuzz, but really such a strange behavior…

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.