Keyboard back to qwerty after upgrade to Plasma 5.11.1, Applications 17.08.2 and Frameworks 5.39

internationalization
kde-applications
kde-frameworks
kde-plasma

(Jean-Baptiste Louvet) #1

After this update, I rebooted my computer and got locked at the login screen without being able to enter a correct password. I eventually figured out that my keyboard went back to qwerty (usually it’s bépo), and could log normally. I noticed then that all my system was in english (usually it’s in french), so I thought that the update overwrote my configuration one way or another. When I tried to configure the Input Method and the Regional Settings in the system configuration tool, nothing could be changed and a message was displayed saying “Cannot connect to Fcitx by DBus, is Fcitx running?”

I found these lines in my journalctl, I think it’s related:

oct. 24 10:20:31 jbl-pc kdeinit5[641]: org.kde.kcoreaddons: Expected JSON property “X-KDE-OnlyShowOnQtPlatforms” to be a string list. Treating it as a list with a single entry: "xcb;"
oct. 24 10:20:31 jbl-pc kdeinit5[641]: detected kglobalaccel restarting, re-registering all shortcut keys
oct. 24 10:20:32 jbl-pc kdeinit5[641]: Trying to convert empty KLocalizedString to QString.
oct. 24 10:20:32 jbl-pc kdeinit5[641]: Trying to convert empty KLocalizedString to QString.
oct. 24 10:20:32 jbl-pc kdeinit5[641]: Trying to convert empty KLocalizedString to QString.
oct. 24 10:20:32 jbl-pc kdeinit5[641]: org.kde.kcm_keyboard: Failed to run “/bin/setxkbmap -model pc101 -option -option caps:swapescape” return code: 251

For the moment, I just quickfixed the problem by opening a terminal and entering setxkbmap fr bepo but it’s not really a solution…

Does anybody experience the same problem since last update or have any suggestion to solve this? Thanks!


Plasma 5.11.1, Applications 17.08.2 and Frameworks 5.39 by KDE now available in Chakra
(tomaggio) #2

Hi i have the same problem: fcitx is not running and i’ve lost my language and keyboard settings.
fcitx isn’t running.
locale.conf is now

LANG=en_US.UTF-8
LC_MESSAGES=en_US.UTF-8

before it was

LANG=de_DE.UTF-8
LC_MESSAGES=de_DE.UTF-8

i changed it to “de” but after a reboot it is back to en :frowning:
vconsole.conf is changed:
before upgrade

FONT=
FONT_MAP=
KEYMAP=de

after the upgrade

FONT=
FONT_MAP=
KEYMAP=de
KEYMAP="us"
KEYMAP=“us”

Cause is: the package "upgraded chakra-init-live (2016.02-4 -> 2017.09-2)"
it had been activated:

[ALPM-SCRIPTLET] Created symlink /etc/systemd/system/multi-user.target.wants/live.service → /usr/lib/systemd/system/live.service

so /etc/vconsole.conf and /etc/locale.conf will be changed.
i removed the package and i hope that’s ok.
Also possible

systemctl disable live.service

i put /usr/bin/fcitx-autostart
in systemsettings Autostart
and now i’ve been back to normal :slight_smile:
Hope it helps someone

Tomaggio


(Francesco Marinucci) #3

I can confirm the fcitx issue, although my regional and keyboard layout settings didn’t get lost.


(Massimiliano) #5

I get lost regional and keyboard layout settings too.
I temperory fix this running command “fcitx”, but when system restart the problem will return.


(tom) #6

@mrcrowley
can you reset your settings?

@tomaggio
you don’t need “chakra-init-live” because its a artefact from the installations process.

[tom@frija ~]$ pacman -Ss chakra-init-live
core/chakra-init-live 2017.09-2
    Live-session systemd startup scripts

and it seems locale.conf doesn’t be needed any more because there is no owner?

[tom@frija ~]$ LC_ALL=C pacman -Qo  /etc/locale.conf
error: No package owns /etc/locale.conf

(Massimiliano) #7

@tom not possible reset regional settings before run command “fcitx”. After run the command is possible to reset settings, but as I told before, after system restart I get the problem again.


(tom) #8

you shouldn’t need fcitx for this task.

plasma is storing these settings in ~/.config/plasma-localerc

[Formats]
LANG=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LC_MONETARY=de_DE.UTF-8
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
useDetailed=true

[Translations]
LANGUAGE=de

and plasma-locale-settings.sh export this every login:

# Generated script, do not edit
# Exports language-format specific env vars from startkde.
# This script has been generated from kcmshell5 formats.
# It will automatically be overwritten from there.
export LANG=de_DE.UTF-8
export LC_NUMERIC=de_DE.UTF-8
export LC_TIME=de_DE.UTF-8
export LC_MONETARY=de_DE.UTF-8
export LC_MEASUREMENT=de_DE.UTF-8
export LANGUAGE=de

(tomaggio) #9

Hi Tom; locale.conf will be read and is responsible for language in console. without i’m in lang=C.
locale.conf sets the systemwide locale.
Where can i define the language for the system without locale.conf?
Manpage says
The /etc/locale.conf file configures system-wide locale settings. It is read at early boot by systemd(1).
so it should be a dependency of systemd!?


(tom) #10

@tomaggio
i thought locale for the GUI.

you can edit /etc/locale.conf to your needs and regenerate the locale

sudo  locale -a

https://wiki.archlinux.org/index.php/Locale.conf#Generating_locales

i don’t kow but perhaps does some one know whats happen with /etc/locale.conf?


(Massimiliano) #11

Blockquote
you shouldn’t need fcitx for this task.
plasma is storing these settings in ~/.config/plasma-localerc

I don’ t know, but running fcitx command I get back my italian keyboard layout.
No errors in plasma-localerc.
I get lost settings also about numbers.


(Massimiliano) #12

I update to plasma 5.11.2 but still got the problem with keyboard layout.
No news about it ?


(Jean-Baptiste Louvet) #13

I also still have this problem, even after updating to 5.11.2. I didn’t find any way to solve it for the moment.


(tomaggio) #14

hi jboot
I have had the same problem solved it as i mentioned in my post:


(Jean-Baptiste Louvet) #15

Oh, I read your post to fast… It solved one half of the problem: the sddm screen is now in french, and my bépo keyboard configuration is back after login. But sddm is still in qwerty (it switches to bépo only after login).


(tom) #16

@jboot and @tomaggio
is it the same result with sddm 0.15?


(tomaggio) #17

@tom i haven’t a problem with my keyboard in sddm. It’s in qwertz. @jbott What’s the content of your /etc/locale.conf?
I think , but i’m not sure that /etc/vconsole.conf is responsible for the settings (keyboard, language) in sddm.
The keymap should be
KEYMAP=fr-bepo or another variant for you.


(Massimiliano) #18

I try to modify vconsole.conf and set KEYMAP=it (my case), but after restart I got the same Us keyboard.
In fact I have again KEYMAP=us in vconsole.conf
Then there is something that modified vconsole.conf at each start.


(Jean-Baptiste Louvet) #19

Yes.

LANG=fr_FR.UTF-8
LC_MESSAGES=fr_FR.UTF-8

The content of my /etc/vconsole.conf was quite strange:

FONT=
FONT_MAP=
KEYMAP=fr
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP="us"
KEYMAP=“us”

I changed it to

FONT=
FONT_MAP=
KEYMAP=fr-bepo

then rebooted but sddm is still in qwerty. The content of /etc/vconsole.conf remained with fr-bepo after the reboot. I just noticed that now, my tty consoles are in bépo.


(tom) #20

vconsole.conf shouldn’t like yours and i think it is a bug.


(Massimiliano) #21

My vconsole.conf is the same of mr Louvet.

But how many times to solve this bug …