Kernel upgrade fails (with a kernel panic upon reboot) after installing from the 2017.10 "Goedel" release and running `pacman -Syu`

The problem has happened me with two different laptops, one using UEFI, one which does not. (HP 250 and Lenovo ThinkPad T430)

I can install latest iso quite smoothly.

However, after I run a sudo pacman -Syu I realized programs were not up to date. I saw repositories were too old. I did

cd /etc/pacman
sudo mv mirrorlist.pacnew mirrorlist
sudo pacman -Syu

Now I got a real actualization. Great.

Everything works. Great.

As far as I don’t turn off the computer. Because, if I do, I get a kernel panic at boot, no init found, and I have to reinstall the ISO again. Something like Not syncing: No working init found. Try passing init= option to kernel.

And yes, of course, after the actualization I did, as asked, a

sudo grub-install /dev/sda --no-floppy
sudo grub-mkconfig -o /boot/grub/grub.cfg

What should I do?

I’m the only one this is happening to?

Nobody has installed Chakra from scratch lately? No new users at all?

You can view the progress for the next release here.

It happens that mirrors are added or removed for various reasons. Without knowing which mirror you were using, it is difficult to tell why you had issues updating. I suggest attaching the files described here to your post, as well as /etc/pacman.d/mirrorlist.

You can view the status of the official mirrors here.

There have been no mention of need for #manual-intervention in #news after the 2017.10 “Goedel” release, unless I’m missing something. A quick search for “kernel panic” returned this result, have you tried that?

Ok, so, it seems this problem seems to be known since months ago. Great. A least a big advice should be put next to the ISO download telling people not to download it and wait for a non broken one…

I’ll try it, once I get what they mean by making the chroot, because when I tried it I’ve got problems with the paths to the programs and the libs.

Thanks for the help.

I think I’ll have to look for another more stable KDE based distribution. Any suggestion?

I haven’t had this issue myself, and it isn’t clear to me which specific upgrade is the cause of this. If it does affect a majority users a notice should indeed be posted with an explanation and instructions for solving the issue.

You can learn more about chroot here. Please share the input and output if you are having issues, and we can help you troubleshoot.

Thanks to an ubuntu forum I’ve been able to arrange it.

I’ve booted with a USB stick with the old ISO. chroot of course didn’t find the paths. So I followed this:

sudo mkdir /HDInstall

sudo mount /dev/sda1 /HDInstall

for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /HDInstall$i; done

sudo chroot /HDInstall

sudo grub-mkconfig
sudo mkinitcpio -v -p linux

Now everything works.

I repeat. This has happened to me in two different computers. One using UEFI, one that doesn’t use it. It happens to other people. I think it should be addressed. Who knows how many new users have tried chakra for the first time, seen it doesn’t work, and left forever?

I’m having some trouble understanding this issue, but this is what I’ve got so far:

Your error message:

Not syncing: No working init found.

From Kernel panic after upgrading after a fresh install: Unable to mount root fs on unknown-block(0,0)

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

From Kernel panic after update

Kernel panic - not syncing: No working init found. Try passing init= option to kernel. See Linux Documentation/admin-guide/init.rst for guidance.

There is a bug report here, titled “Failed kernel updgrade after install via Goedel 2017.10 iso.”. The comments are really difficult to read, so I skipped that, but the first comment suggests that this happened in January. Starting in January, these topics in #news has the #linux tag:

This topic may be related, but it’s rather long and I found no mentions of “kernel panic” there:

I’ll turn on notifications for that bug report and see where it leads.

Since your issue has been resolved, please mark the topic as solved by following these instructions. The issue already appears to have a solution as suggested here, so please post any further information as replies to the bug report, to keep it all in one place:

Closed as duplicate of Kernel panic after update. A report has been made here, please submit any further information to that in order to keep it all in one place.

Another, more detailed workaround can be found here.