Is it normal to use 100% of CPU for opening a xml file?

(ruben) #1

Hello everyone, just curious today,
I am trying to open a 1.2 MB .xml file, it is a save file from a steam game. While trying to opening it, I noticed a bit of a general slow down (not too much) and the file is “stuck” in loading.
What is interesting, is the fact that my 6 cores CPU (FX6300) is only providing one CPU for the task and is stuck to 100% :

It also alternates between CPU3, CPU5 or CPU2 being fully occupied.
Is it an issue related to Kate, or to my CPU ? I mean, it’s only supposed to load lines of text…Its been 15 minutes now…

(Neofytos Kolokotronis) #2

Hi ruben,

This looks like an upstream bug. Doing a quick search on KDE’s bugtracker, I see there are a couple of related reports. It’s worth checking them out and leaving your feedback there:

(ruben) #3

Yeah, probably.
Meanwhile Vim opened the same file instantly. Kate has also a line lenght limit which is weird for a text editor.

(Neofytos Kolokotronis) #4

Not sure if you are aware, but you can change that limit from kate’s settings.

(ruben) #5

Yes I set it to 0 and that’s when it couldn’t open the file anymore. Of course with 1024 letters limit it opened very fast lol
Anyone has a good alternative to Kate or Vim ? Turns out Vim opens the file but then struggle when I run some words search…

(gopona) #6

Have you tried something like this on vim ?
set synmaxcol=250
It can improve the performance on vim


(ericjs) #7

I’ve had this problem with Kate too, will large xml files with no line breaks.

Notepadqq is a great QT-based editor in a similar style (originally inspired by populare Notepad++ from Windows) which handles long lines much better. I’ve just updated it on CCR:

(ruben) #8

Jesus, it is exactly what I needed !!
Amazing. Works perfectly, 100 times better than Kate and Vim.
:+1: :+1:

(Neofytos Kolokotronis) #9

Remember to vote for the apps you use from CCR, from time to time we consider the most popular of them for importing to Chakra’s official repositories!

(system) #10

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.