Installing mpich-3.2

System information, pacman configuration, and pacman log

System information

Linux sysmetryx-linux 4.8.6-1-CHAKRA #1 SMP PREEMPT Sun Nov 6 14:17:46 GMT 2016 x86_64 GNU/Linux

/etc/pacman.conf

Replace this line with the contents of the file /etc/pacman.conf

/etc/pacman.d/mirrorlist

# mirrorlist generated by rankmirrors during chakra installation
# the original file was saved to /etc/pacman.d/mirrorlist.pacsave

Server = http://www-ftp.lip6.fr/pub/linux/distributions/chakra/$repo/x86_64
Server = http://archlinux.puzzle.ch/kdemod/$repo/x86_64
Server = http://elgrande74.net/chakra/packages/$repo/x86_64

/var/log/pacman.log

2017-02-20 23:47] [PACMAN] Running 'pacman -r /home/luca/Chakra/git/chakra-iso_master/iso_build/chakra -Syy --needed --noconfirm --config=/home/luca/Chakra/git/chakra-iso_master/config/pacman.conf device-mapper filesystem lvm2 pcmciautils ut$
[2017-02-20 23:47] [PACMAN] synchronizing package lists
[2017-02-20 23:47] [ALPM] transaction started
[2017-02-20 23:47] [ALPM] installed linux-api-headers (4.8.6-1)
[2017-02-20 23:47] [ALPM] installed tzdata (2016j-1)
[2017-02-20 23:47] [ALPM] installed iana-etc (2.30-2)
[2017-02-20 23:47] [ALPM] installed filesystem (2016.11-1)
[2017-02-20 23:47] [ALPM-SCRIPTLET] impossibile chiamare execv (File o directory non esistente)
[2017-02-20 23:47] [ALPM] installed glibc (2.24-1)
[2017-02-20 23:47] [ALPM] installed attr (2.4.47-1)
[2017-02-20 23:47] [ALPM] installed acl (2.2.52-1)
[2017-02-20 23:47] [ALPM] installed ncurses (6.0+20170204-1)
[2017-02-20 23:47] [ALPM] installed readline (7.0.001-1)
[2017-02-20 23:47] [ALPM] installed bash (4.4.005-1)
[2017-02-20 23:47] [ALPM] installed libdbus (1.10.12-1)
[2017-02-20 23:47] [ALPM] installed expat (2.1.1-1)
[2017-02-20 23:47] [ALPM] installed dbus (1.10.12-1)
[2017-02-20 23:47] [ALPM] installed iptables (1.4.21-1)
[2017-02-20 23:47] [ALPM] installed zlib (1.2.8-2)
[2017-02-20 23:47] [ALPM] installed cracklib (2.9.6-2)
[2017-02-20 23:47] [ALPM] installed shadow (4.2.1-1)
[2017-02-20 23:47] [ALPM] installed gcc-libs (5.2.0-9)
[2017-02-20 23:47] [ALPM] installed gmp (6.1.2-1)
[2017-02-20 23:47] [ALPM] installed libcap (2.25-1)
[2017-02-20 23:47] [ALPM] installed coreutils (8.25-1)
[2017-02-20 23:47] [ALPM] installed util-linux (2.29-1)
[2017-02-20 23:47] [ALPM] installed e2fsprogs (1.42.13-1)
[2017-02-20 23:47] [ALPM] installed gdbm (1.11-1)
[2017-02-20 23:47] [ALPM] installed db (5.3.28-1)

Hello, I am trying to install the mpich library on my machine. I noticed it wasn’t available in the CCR, so I tried downloading the snapshot on AUR. The makepkg -S works fine, as I managed to create the .src
However, when I try to sudo pacman -U mpich-3.2-1.src.tar.gz , I get two errors saying that the package is corrupted and that metadata are missing…

I also tried to build from the source, as proposed on the official website, with no success.

If anyone have any knowledge about that, that would be great !

Yeah that’s not an installable package - that’d be the gzipped source tarball. Why are you using makepkg -S? See man makepkg for information on how to use it. You probably want to use -s, possibly -si. Refer to the manpage to learn about the two.

Hi and welcome to Chakra.

Make sure to check out our guide on importing Arch or AUR packages to CCR also.

Hi, thank you for the quick answer, I will try to look forward into that. I had no idea it worked differently from what I’m used to.

If the issue has been resolved, please mark your topic as solved by clicking the checkbox icon :white_check_mark: under the reply that provided the solution.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.