Installation failed: Boost.Python-Error in job "bootloader"

I tried installing the newest iso of chakra linux. In the live usb demo I was unable to connect to wifi, because it failed to resolve the network adress, put that’s another thing.
So, I wanted to install it in dual-boot. I had initial three partitions which I earlier installed another linux in, and I created a fourth one for /boot/efi. So I had the partitions for /, swap, /home and /boot/efi.
I installed the distribution, everything went fine, until it was finished, when it showed the following error message …

I installed it in german, so I’ll translate the first few lines (the remaining lines are on english):
Installation failed
Boost.Python Error in job “bootloader”

Can someone help me? I’m really new to linux and I have no idea what happened.

Thank you

Welcome to our forum @Rosary!

Am unfortunately not very familiar with installing on UEFI, but I will try my best and hopefully somebody else can chip in.

I guess you chose manual partitioning for this attempt. Afaik, Calamares can automatically handle the partitioning for this type of installation, did you try installing using this way?

Also, what happens when you reboot? Does GRUB show up? Did you have GRUB installed from before? If yes, we can probably attempt to fix it.

I had GRUB installed before, but it deleted itself. I had another distribution before.
Yes, I used manual partitioning, because I’m not sure about the assistance (and I had the partitions before, I wanted to format them) - I want to make sure to have dual boot. (just a little bit paranoia).
When I reboot, the windows loader starts. My windows loader is on its own partion (it was like that when I got the laptop).
But the entire Chakra OS didn’t install, as I thought. But I’m not sure, I don’t really know much about linux.

Judging from the output in the error box, it looks like Chakra was installed, but it failed to install the bootloader on the system. So if you boot using a Live ISO, you can probably find the Chakra related files on the corresponding partition.

You could try using the Live ISO to manually install GRUB, the ArchWiki could help but it may be too complicated.

Alternatively, I would recommend going with the automated option, to try and see if it resolves the problem. It should help if this is due to wrong configuration in terms of partition setup and setting the right flags.

1 Like

Thank you for your help, I’ll talk again if I had the time to try it out. Tomorrow I’m a bit busy, so it could take a while. Hope it helps.

i would try a different way and use the UEFI menu for OS selection.
i suppose your system is installed so it need only a litte to do :slight_smile:

please post your partition layout and check /boot for generated initramfs you can do this task from the live media.

I’ll try to reinstall chakra with the automated system as you say. It is okay, if I format and delete the partitions where I had installed it before? I don’t want any “dead” partitions on my hard drive.

Do you think that this would be okay, @brikler ?

Anyways, here is a picture of my partitioning:

/dev/sda9 is (or should be) /boot/efi, /dev/sda6 is /, /dev/sda7 is swap, /dev/sda8 is /home.

And how do I check /boot for generetade initramfs? I don’t know how to …

[quote=“Rosary, post:7, topic:6312”]
And how do I check /boot for generetade initramfs? I don’t know how to …
[/quote]you can use dolphin for this purpose.
open dolphin and klick the partiton or from your windoof. windows can handle fat32

the installer force you to create a /boot/efi but you don’t need it because this folder will be created by the installer in /boot and 260 MB for sda2 as /boot partition? 100 MB are enough^^

i would use 100 MB for /boot on sda1.
only on big partition for / (/ and /home) and set the swap on the end
you can check the minimum size by cat /sys/power/image_size

please check your sda2 if there are the initramfs is created, you can use dolphin on your live media


ich würde erst mal schaun wie viel swap ich bräuchte. das geht mit dem befehl: cat /sys/power/image_size

und dann sda9, sda8, sda6, sda7 ein partition machen abzüglich dem ergebnis von /image_size

außerdem würde ich BTRFS als dateisystem wählen… BTRFS hat ein paar praktische eigenschaften

Eine einzige Partition? Bisher dachte ich, für die Installation müsste ich es aufteilen in mehrere? (Also hier eine einzige Partition und eine für’s swap?)


Because of language confusion -
"Only one partition? Until now I thought I need to devide the space into multiple ones? (So here one partion and one for swap?)

My main emotion is confusion.

das einzige was du “mußt” ist eine fat16 oder fat32 bootpartition erstellen, UEFI verlangt das. einen swap brauchst du “eigentlich” auch nicht, aber es kann fälle geben wo er recht nützlich ist. something to read about https://forum.chakralinux.org/viewtopic.php?id=15369

natürlich könntest es so aufteilen wie dus bereits tatest, aber mit der zeit wirds mühsam weil der paket speicher mit jedem update wächst…der wächst schnell und die programme brauchen auch platz, da ist die partition schnell voll, dies kannst du eine schöne zeit lang mit einer einzigen partition umgehen.


you need only a fat /boot partition and one for / everything else isn’t necessary.
i don’t recommend a extra /home partition because the space on the hard drive can be used efficient… the package cache will grow and programs need space too…

keep your head up we will manage this :wink:

Your layout maybe like this:

/dev/sda6 mounted as /
/dev/sda8 mounted as /home
/dev/sda9 mounted as /boot
/dev/sda7 mounted as swap

noted that Chakra would try to use /boot as EFI partition, not /boot/efi, it would then install needed files into /boot/efi itself, you should only take cares that /dev/sda9 is formatted as FAT32

PS please try to use English in general forum, as some of the helper out here may not understand your native one. You can always start a question at language-specific sub forum anyway.

Okay, I’ll try this.

Yes, I know that I should use english, but they wrote some things in german to me so I replied in german, but I translated to english so others could understand what I wrote. I’m sorry.
(I’m german but I fluently speak english so I mostly use english; I learned many things in english like especially).

Hope this works :slight_smile:

if not you can try calamares 3.1.
unfortunately it isn’t in the repository and you must build the package but fortunately it is very easy task :slight_smile:

  1. create a file with the name PKGBUILD andcopy this in the code block to PKGBUILD
    https://chakralinux.org/code/desktop.git/plain/calamares/PKGBUILD

[code]pkgname=calamares
pkgver=3.1
pkgrel=3
_releaseName=“Goedel”
_releaseYear=“2017"
pkgdesc='Distribution-independent installer framework’
arch=(‘x86_64’)
url='https://github.com/calamares/calamares
license=(‘LGPL’)
depends=(‘boost’ ‘qt5-svg’ ‘kconfig’ ‘ki18n’ ‘kcoreaddons’ ‘solid’ ‘yaml-cpp’
‘parted’ ‘kpmcore>=3.0’ ‘libatasmart’ ‘udisks2’ ‘polkit-qt5’ ‘boost-libs’
‘rsync’ ‘python3’ ‘keyboardctl’ ‘qt5-webkit’ ‘kparts’ ‘mkinitcpio-openswap’)
makedepends=(‘extra-cmake-modules’ ‘git’ ‘qt5-tools’ ‘translate-toolkit’ ‘qt5-tools’)
#source+=(”$pkgname-$pkgver.tar.gz::https://github.com/calamares/calamares/releases/download/v$pkgver/calamares-$pkgver.tar.gz"
_gitsha=“6cb4291b4d142462f8cc0e61fc4f10880cd25546"
source+=(”$pkgname-$pkgver.tar.gz::https://github.com/calamares/calamares/archive/${_gitsha}.zip"
“calamares-chakra::git://git.chakralinux.org/calamares.git#branch=modules”)
md5sums=(‘c6be3cb3f5e2fad8f06f2e18373c7822’
‘SKIP’)

prepare() {
#cp -a ${srcdir}/calamares-chakra/* ${srcdir}/calamares-${pkgver}
cp -a ${srcdir}/calamares-chakra/* ${srcdir}/calamares-${_gitsha}
rm -rf ${srcdir}/calamares-chakra
#cd ${srcdir}/calamares-${pkgver}
cd ${srcdir}/calamares-${_gitsha}

# apply the current version Name and Year
sed -i -e "s/UnknownName/${_releaseName}/" "src/branding/chakra/branding.desc"
sed -i -e "s/UnknownYear/${_releaseYear}/" "src/branding/chakra/branding.desc"

}

build() {
#cd ${srcdir}/calamares-${pkgver}
cd ${srcdir}/calamares-${_gitsha}
mkdir -p build

cd build

cmake .. \
-DCMAKE_BUILD_TYPE=Debug \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DWITH_CRASHREPORTER=ON \
-DSKIP_MODULES="webview interactiveterminal netinstall"
make

}

package() {
#cd ${srcdir}/calamares-${pkgver}/build
cd ${srcdir}/calamares-${_gitsha}/build
make DESTDIR="${pkgdir}" install

install -Dm644 "../conf/settings.conf" "$pkgdir/usr/share/calamares/settings.conf"
install -Dm644 "../conf/welcome.conf" "$pkgdir/usr/share/calamares/welcome.conf"
install -Dm644 "../conf/displaymanagers.conf" "$pkgdir/usr/share/calamares/modules/displaymanagers.conf"
install -Dm644 "../conf/locale.conf" "$pkgdir/usr/share/calamares/modules/locale.conf"
install -Dm644 "../conf/users.conf" "$pkgdir/usr/share/calamares/modules/users.conf"
install -Dm644 "../conf/unpackfs.conf" "$pkgdir/usr/share/calamares/modules/unpackfs.conf"
install -Dm644 "../conf/packages.conf" "$pkgdir/usr/share/calamares/modules/packages.conf"
install -Dm644 "../conf/grubcfg.conf" "$pkgdir/usr/share/calamares/modules/grubcfg.conf"
#install -Dm644 "../conf/partition.conf" "$pkgdir/usr/share/calamares/modules/partition.conf"
install -Dm644 "../conf/services.conf" "$pkgdir/usr/share/calamares/modules/services.conf"
install -Dm644 "../conf/umount.conf" "$pkgdir/usr/share/calamares/modules/umount.conf"
install -Dm644 "../conf/initcpio.conf" "$pkgdir/usr/share/calamares/modules/initcpio.conf"

install -Dm755 "../data/launch-calamares.sh" "${pkgdir}/usr/bin/launch-calamares.sh"
install -Dm644 "../data/calamares.desktop" "$pkgdir/usr/share/applications/calamares.desktop"
install -Dm644 "../data/installer.svg" "${pkgdir}/usr/share/pixmaps/installer.svg"

rm -r "$pkgdir/usr/lib/calamares/modules/dummyprocess/"
rm -r "$pkgdir/usr/lib/calamares/modules/dummypython/"
rm "$pkgdir/usr/share/calamares/modules/dummypython.conf"

}[/code]
2) as next step run updpkg in the konsole this will download the source and verify

  1. in the folder with the PKGBUILD run in the konsole “makepkg -rsi”

makepkg will download needed build dependencies, create the packages, and install it for you.

attention! if you don’t save the packages it will be go to the data nirvana…

Besides, if you read python code, you can try to execute the command this calamares module do from konsole (translate it into console command first) and see what/where grub really failed. But that is a bit advanced tbh.

good idea but she doesn’t need grub because she can select the OS with the UEFI menu if she set a boot entry with efibootmgr in the NVRAM.

i would set a # before line 309, 220 and 283 in /usr/lib/calamares/bootloader/main.py if is not possible to avoid grub.
the benefit is windows can’t overwrite the grub mbr entry.

from the live media run

edit 2
in the moment the web side does some nonsens
must be replaced by the root partition

without ‘’

edit
there should stand dev not “developer”.
why change the web side dev to “developer”?

source1 https://wiki.archlinux.de/title/EFISTUB
source2 https://wiki.archlinux.org/index.php/Unified_Extensible_Firmware_Interface#efibootmgr

At first, I tried the solution to mount /dev/sda9 as /boot. It didn’t work (yes, I installed chakra anew with the partitions booted like this, just to make this clear).
@brikler The second solution with calamares 3.1 … I don’t understand. How should I create a file? Where? I really know nothing about how linux works. I’m really new. And I only know how to use windows, everything I know is self-taught (aka I sat in front of the computer and just used it, and read a few things. The only thing I was taught is what the kernel and a browser is).
I’m also sorry that I didn’t reply for a short time. Summer vacation started and I had some busy days, I don’t know what happened … also I’m not home from first to eighth july.

it’s a pity :frowning:
so i recommend you to a other more beginner friendly distribution like linuxmint because there is very friendly german community linuxmintusers.de
i see no chance to install chakra without manual intervention.

Hmm, I think I’ll try Linux Mint KDE instead. It looks really good, and also, I had already wi-fi problems with Chakra and after doing this I think I would have to many problems fixing them.

But thanks to you all for being there for me :slight_smile: @brli You rock, guys :smiley:

note for problems in future:
/usr/share/calamares/setting.conf

[code]sequence:

  • show:
    • welcome
    • locale
    • keyboard
    • partition
    • users
    • summary
  • exec:
    • partition
    • mount
    • unpackfs
    • machineid
    • fstab
    • locale
    • keyboard
    • localecfg
    • luksbootkeyfile
    • luksopenswaphookcfg
    • initcpiocfg
    • initcpio
    • users
    • displaymanager
    • _usercfg
    • _driver_cleanup
    • _nonfree_drivers
    • _locale_cleanup

- _pre_packages

  • _pacmancfg
  • packages
  • networkcfg
  • hwclock
  • services
  • grubcfg
  • bootloader

- _bootldr

- _systemd-boot_entries

  • umount
  • show:
    • finished[/code]

the bootloader can be installed from out side because the system is in a workable state and need only a bootloader

I have the same problem.

I can’t access to /usr/lib/calamares/bootloader/main.py

/usr/ does not exist…

Please fix this.

Also I cannot access to /dev/sda filesystem from archOS, via “arch-chroot.” proc does not exist. So I tried mount -t proc proc proc/ and that does not exist. So I tried manually typed chroot /mnt /bin/bash, and bin/bash does not exist. So I am assuming that chakra installation has failed to install all of the packages.