How to enable fcitx

cjk
fcitx

(Bobby Rong) #1

Make sure you have installed at least one of the input method engines if you want to type CJK characters with fcitx.

Now define the environment variables to register input method modules and enable support for xim programs:

# nano ~/.xprofile
GTK_IM_MODULE=fcitx
QT_IM_MODULE=fcitx
XMODIFIERS=@im=fcitx

Reboot your system to make these environment changes effective.


(brli) #2

better not touch global configuration ie. files in /etc/

you can use ~/.xprofile or ~/.bash_profile instead, both works on KDE environment.