Grouped windows are not displayed using the "Present Windows" desktop effect when clicked in the icons-only task manager after upgrading to Plasma 5.14.4

opengl
kde-plasma

(Nuno Santos) #21

Enabling compositor on startup gives the effect shown second in the video.


(totte) #22

Yeah, the “Present Windows” desktop effect requires the compositor to be running. Whichever backend you use, you can toggle the compositor on and off with Shift+Alt+F12, I think.


(Nuno Santos) #23

But if I simply change the Backend Renderer am I enabling the compositor?


(totte) #24

I don’t know, but to see whether it is currently enabled or not, try running:

$ qdbus org.kde.KWin /Compositor org.kde.kwin.Compositing.active

To enable it, run:

$ qdbus org.kde.KWin /Compositor org.kde.kwin.Compositing.resume

To disable it, run:

$ qdbus org.kde.KWin /Compositor org.kde.kwin.Compositing.suspend

(Nuno Santos) #25

Thanks!

Always learning with you guys.

I used the commands you just told me to and went to the settings to enable OpenGL 3.1 and back to 2.0. Just by doing that (selecting a backend renderer) it enables compositor.


(system) closed #26

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.