Firefox shortcut is broken

[20:37] <ReemZ> guess, problem after today's update, Firefox won't start anymore. can't search forum or bugtracker to see if it's already been reported, because for that I'd need...you've guessed it, Firefox.
[20:37] <ReemZ> KDEInit could not launch '@MOZ_APP_NAME@':
[20:37] <ReemZ> Could not open library 'libkdeinit5_@MOZ_APP_NAME@'.
[20:37] <ReemZ> Cannot load library libkdeinit5_@MOZ_APP_NAME@: (libkdeinit5_@MOZ_APP_NAME@: cannot open shared object file: No such file or directory)
[20:38] <ReemZ> this happens both when using the key combination I had assigned to Firefox through right-clicking the menu button and selecting Edit Applications and when trying to start Firefox from the menu itself
[20:39] <ReemZ> it used to say just Firefox and now says Firefox Web Browser, no idea if that's related
[20:40] <ReemZ> in aforementioned Edit Applications I see under Command it now says @MOZ_APP_NAME@ %u, where I believe it used to say firefox %u. I'll change this and see if this solves the problem.
[20:40] <ReemZ> also, the icon is gone from the menu.
[20:42] <ReemZ> ok changed, now it does start from the menu again, but still, the shortcut I'd made doesn't work, even after re-entering it.
[20:49] <ReemZ> solved that too by emptying the shortcut field entirely before reassigning it...bloody hell what a mess!
[21:19] <ReemZ> had a look again at code.chakralinux.org btw, I found it difficult enough to find my old bugreport, and I have absolutely no idea how to create a new one for this issue
[21:19] <ReemZ> why the fuck is reporting stuff so bloody difficult these days?

Have fun.

1 Like

I also have this problem, after upgrading to 67.0.3 :thinking:

I do get the same “pop-up” window, but the Firefox launches just fine.
We’re investigating this, thank you for reporting.

Update Should be fixed with 67.0.4, thanksto @brli

Concerning the bug reporting, I honestly do not see how it can be so difficult: you just go here, select “New issue” and pick the right template from the list (in this case “Broken package”), the you just need to fill out the required informations.

1 Like

See, that link isn’t in the IRC channel topic, only the root is. This link should really be made way more clearly visible…

Anyway, update received, problem solved.

version 67.0.4-1 fixes the problem :slightly_smiling_face::+1:t4:

1 Like

That’s because the page I linked here is “repo-specific” for packages in [gtk], it’s not a generic one.
I could add this kind of link for every repository on the discussion added by @totte in the Help category.

I changed the IRC channel topic from:

This channel is bridged to #chakra:matrix.org | Our website: https://www.chakralinux.org | Get help here: https://community.chakralinux.org | Frequently asked (and answered) questions: FAQ - Chakra's Community | Report issues here: https://code.chakralinux.org | Status of services: https://status.chakralinux.org/

to:

This channel is bridged to #chakra:matrix.org | Our website: https://www.chakralinux.org | Get help here: https://community.chakralinux.org | Frequently asked (and answered) questions: FAQ - Chakra's Community | Report issues here: https://code.chakralinux.org/groups/chakra/-/issues | Status of services: https://status.chakralinux.org/

Feedback as to how the reporting can be improved is welcome here (and was already discussed at length here. There are also a number of related FAQ entries, e.g.



2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.