Failure building radeon-profile-git

ccr

(richard.llom) #1

Hi,
radeon-profile-git from ccr fails to build for me (see error message below). Can someone advice?
Thanks.

...
==> Retrieving sources...
  -> Cloning radeon-profile git repo...
Cloning into bare repository '/tmp/ccrbuild-1000/radeon-profile-git/radeon-profile-git/radeon-profile'...
remote: Enumerating objects: 23, done.
remote: Counting objects: 100% (23/23), done.
remote: Compressing objects: 100% (19/19), done.
remote: Total 3627 (delta 10), reused 9 (delta 4), pack-reused 3604
Receiving objects: 100% (3627/3627), 1.79 MiB | 1.30 MiB/s, done.
Resolving deltas: 100% (2649/2649), done.
==> Validating source files with sha256sums...
    radeon-profile ... Skipped
==> Extracting sources...
  -> Creating working copy of radeon-profile git repo...
Cloning into 'radeon-profile'...
done.
==> Starting pkgver()...
==> Updated version: radeon-profile 20181028.r0.g33af9d3-1
==> Starting build()...
Project MESSAGE: Building for releaseProject MESSAGE: Warning: unknown QT: chartsUpdating '/tmp/ccrbuild-1000/radeon-profile-git/radeon-profile-git/src/radeon-profile/radeon-profile/translations/strings.it.qm'...
    Generated 298 translation(s) (292 finished and 6 unfinished)
    Ignored 29 untranslated source text(s)
Updating '/tmp/ccrbuild-1000/radeon-profile-git/radeon-profile-git/src/radeon-profile/radeon-profile/translations/strings.pl.qm'...
    Generated 261 translation(s) (257 finished and 4 unfinished)
    Ignored 5 untranslated source text(s)
Updating '/tmp/ccrbuild-1000/radeon-profile-git/radeon-profile-git/src/radeon-profile/radeon-profile/translations/strings.hr.qm'...
    Generated 373 translation(s) (373 finished and 0 unfinished)
Info: creating stash file /tmp/ccrbuild-1000/radeon-profile-git/radeon-profile-git/src/radeon-profile/radeon-profile/.qmake.stash
Project MESSAGE: Building for release
Project ERROR: Unknown module(s) in QT: charts
==> ERROR: A failure occurred in build().
    Aborting...
The build failed.
Hardware information
System:    Host: cray Kernel: 4.18.12-1-CHAKRA x86_64 bits: 64 Desktop: KDE Plasma 5.13.5 Distro: Chakra 
Machine:   Type: Desktop Mobo: ASUSTeK model: A88XM-PLUS v: Rev X.0x serial: <filter> UEFI: American Megatrends 
           v: 3003 date: 03/04/2017 
CPU:       Topology: Quad Core model: AMD A10-7850K Radeon R7 12 Compute Cores 4C+8G bits: 64 type: MCP 
           L2 cache: 2048 KiB 
           Speed: 3716 MHz min/max: 1700/4200 MHz Core speeds (MHz): 1: 3716 2: 3752 3: 3298 4: 2475 
Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] Fiji [Radeon R9 FURY / NANO Series] driver: amdgpu 
           v: kernel 
           Display: x11 server: X.Org 1.20.0 driver: amdgpu tty: N/A 
           OpenGL: renderer: AMD Radeon R9 Fury Series (FIJI DRM 3.26.0 4.18.12-1-CHAKRA LLVM 6.0.0) 
           v: 4.5 Mesa 18.1.1 

(Neofytos Kolokotronis) #2

It looks to me like some patch might be needed against Qt. Did you check Arch/AUR for what they are doing?


(richard.llom) #3

I checked AUR and they have qt5-charts set as a dependency.

With qt5-charts installed the build is successful.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.