Error al instalar paquetes con ccr


(Cazador) #1

Hola compañeros, hace un tiempo vengo teniendo el mismo problema al instalar programas desde ccr, baja los paquetes dependientes pero al momento de instalarse da error porque los archivos ya existen en el sistema. Me paso recientemente con vivaldi y con visual estudio

Alguno tuvo un problema similar? idea de solucion?

Gracias

Saludos
Cazador


(truko22 🇻🇪) #2

Los Repositorios de la Comunidad Chakra CCR, son mantenido por la comunidad y algunas veces están huérfanos, mal empaquetados, otros errorcillos y el mas común están desactualizados y por lo tanto no superan los controles de integridad para las fuentes.

Puedes verificar el paquete en https://ccr.chakralinux.org/

Pero en especifico que problema te sale 0.o?


(Tux83) #3

Hola Martin, el CCR del vivaldi originalmente lo habia creado yo pero despues lo dejé de mantener porque se volvió inestable, y sinceramente…, Firefox es muy superior.

Respecto a los CCR, podes editar el código justo antes de instalarlo, cuando lo ejecutas en la consola te pregunta si deseas ver o editar el PKGBUILD antes de instalarlo. Si hay algún problema con una dependencia podes quitarla desde ahi.

Necesitamos mas información para poderte ayudar mejor.

Saludos.


(Cazador) #4

Hola Amigos!
Sobre vivaldi, solo lo instalo a efectos de chequear los sitios web que desarrollo, actualmente utilizo firefox y chromium siendo firefox mi navegador principal

Sobre el error al instalar paquetes desde ccr, se ingresar para editarlos pero no como modificar la linea para que sobreescriba los archivos si existen en el sistema. Adjunto una captura de pantalla del interior del pkgbuild y otro del error



(Hans Tovetjärn) #5
$ pacman -Qo /usr/share/applications/visual-studio-code.desktop

Copie y pegue texto, es más fácil de leer que las imágenes de texto. Si no desea que se ejecuten las tres líneas del PKGBUILD, agregue un símbolo # a cada línea. Puede suceder que reciba estos mensajes de error cuando use pacman para instalar nuevos paquetes o actualizar su sistema:

error: no se pudo preparar la operación
error: no se pudo realizar la operación (archivos en conflicto)
libname: /ruta/al/archivo existe en el sistema de archivos
Ocurrieron errores, por lo que no se actualizaron los paquetes

pacman ha detectado un conflicto de archivos y, por diseño, no sobrescribirá los archivos por usted. Esta es una característica de diseño y no un defecto. Es responsabilidad del usuario y no del administrador de paquetes mantener su sistema. El problema suele ser fácil de resolver. Compruebe si otro paquete posee el archivo:

$ pacman -Qo /ruta/al/archivo

Si el archivo es propiedad de otro paquete, repórtelo en nuestro rastreador de problemas.

Si el archivo no pertenece a otro paquete, cambie el nombre o elimine el archivo que ya existe en el sistema de archivos y ejecute pacman -Syu nuevamente.

Como siempre, asegúrese de leer y seguir #es:news antes de intentar cualquier actualización.


(Cazador) #6

Muchas gracias por el dato! lo había buscado en el manual de pacman y no lo había encontrado.
Perdón por las capturas, de ahora en adelante copiare y pegare el texto

Doy por solucionado el post

Gracias

Saludos

Martin


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.