Display turns off after 10 minutes idle


(ruben) #1

Hello there again,
Weird problem today. When I am playing a video on my DVI display it works fine, but when I turn on my TV screen on HDMI and continue to watch the same video, both screens turn off after exactly 10 minutes (and sound too). Never happened before…
Went to the Power Management in System Settings but “Screen energy saving” was not selected, still I tried to select it and set it to turn off after 360 minutes, but it didn’t help.
Also when I come back to the computer I wake the screen up and realize the movie is still playing in the background…
Any idea what it can be ?

inxi -Fzxc0

Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] Hawaii PRO [Radeon R9 290] driver: radeon v: kernel 
           bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.0 driver: modesetting unloaded: vesa resolution: 1920x1080~60Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing. 

(ruben) #2

It stopped happening for a few days now. No idea what caused it, nor what fixed it. :thinking:


(Neofytos Kolokotronis) #3

Sometimes a reboot helps, if you rarely do that. Glad to see it resolved, even automagically. :smiley:


(ruben) #4

Hello there,
Well the problem is back again, this time even when only using my “normal” display (DVI port). It is not linked to any software, it happens while not touching anything, it can be a VLC video, or a YouTube video on Firefox, it doesn’t matter. Rebooting didn’t help. The weird thing is, sometimes it happen, sometime it doesn’t. I don’t know what triggers it. Like 2 hours ago I watched a 40mn episode on Stremio and everything was fine. Directly after, without shut down or restart, I just tried to watch news on YouTube, and the screen turns off if don’t touch anything. The sound continue, as the session doesn’t log out.
I tried :
gsettings set org.gnome.desktop.screensaver idle-activation-enabled false
And waited. After exactly 10mn, screen turned off.
[edit] forgot to say, I’m aware this is a ubuntu command, but I don’t know the KDE/Chakra one
It is really annoying ! Help ?


(tom) #5

can you set a default screen? maybe could this help.


(brli) #6

AFAIK, the control of power is managed by systemd, or more specifically, systemd-logind

you should find all the configuration variables and their default values under /etc/systemd/logind.conf

checkout the manual and Archwiki about this section, and you should be able to play around with it.