Clipboad / Pasting doesn't work anymore in LO

libreoffice
(richard.llom) #1

Hey,
I cannot paste anymore text from outside LO into any LO document. Happens on two installations here.

How to reproduce:

  1. create new document or open existing
  2. write text
  3. mark text and copy it
  4. paste it -> works
  5. go outside LO (firefox, okular, kate, etc…) and copy text there
  6. paste in LO -> doesn’t work: text from 4. is pasted instead.

This makes LO hardly usable!

Need urgent help…

(kepszlok) #2

So in 4., you pasted your own text from 2.
In 5., you pasted some other text to kate or the same text from 4?

Either way, i was not able to reproduce what you described. No matter what i tried, the proper text was pasted into LO.

(Frank) #3

hi richard

libreoffices vcl-plugin kde5 is really still buggy (and I think it becomes more and more buggy)
for your bug see here:
https://bugs.documentfoundation.org/show_bug.cgi?id=122689

to make it more interesting.
you can copy from kate to libreoffice, as long as you do not make a copy in libreoffice.
from this point you would have to restart Libreoffice to be able to copy from kate again.
that’s why testers say it would work.

for a first workaround use the vcl-pugin gt3k.
start it from konsole with:

SAL_USE_VCLPLUGIN=gtk3 libreoffice

There should be a setting in the expert setting of LO for this. But I haven’t found it.

(richard.llom) #4

hi frankes, thanks a lot for the findings!

looks like it will be fixed in 6.3. …:neutral_face:
I also looked in the setting, but couldn’t find anything related, guess the workaround has to do for now…

@kepszlok theres is no pasting in 5., pasting is in 6. where the bug occurs.

(brli) #5

Consider that you really eager a KDE integration at least on the file dialog thing, you can use gtk3_kde5

IIRC there is a complete list under /etc/profile.d/libreoffice.sh.

(Frank) #6

sorry, but this file isn’t existing at my computer.
but copy and paste is working.

(Francesco Marinucci) #7

One can simply remove the libreoffice-kde5 package and install the libreoffice-gtk3 one, no need to start from terminal or editing launch files.