Chakra 2019.01 “Hawking” RC3 released

Ok, should be the final one if no major stopper will no problem arise.

What’s new since RC2 ?

  • moved the kickoff menu back to the latte dock. In addition the menu style has changed
  • new logout screen for heritage, fix the blur/black background and introduced more shutdown options (image below)
  • added Live user icon (image below)
  • update calamares to 3.2.3
  • kf5/plasma/apps updated to latest version


  • fix missing default user folder in /home when installed
  • fix font rendering
  • fix boot speed and calamares launch

Known Issues

  • none

Download & Test
The release candidate does not have the final release name, but is named by the commit tag and date.
Click here to download it. See How to create a live media for instructions on how to create a bootable flash drive.
The sha512sum is:

3a4ca090131db39ec9e5096ae04999cbb23d9e6e209df03f2f019d3bc2fa5f2df0a77c52c17973c6f2fbe6803ca3e74bbc8aac971c8980e433b8abbc447405d4 chakra-2019.01.15-ddf5ae10-x86_64.iso


I’m still hoping for the mesa-demos and the vulkan driver packages to be include in the iso. :slight_smile:

there is a leftover file in the pacman cache

[root@frija /]# ls /var/cache/pacman/pkg/

does we need this ttf on the iso because ttf-noto are the default fonts?

local/ttf-lklug 1.0-1
    Unicode sinhala font
local/ttf-opensans 20140120-2
    Open Sans is a humanist sans serif typeface designed by Steve Matteson, Type
    Director of Ascender Corp.
local/ttf-raleway 3.0-2
    A sans-serif typeface

hm… good point, I don’t remember if ttf-opensans was used as fallback, I will check.


raleway is our font, used by heritage and some programs(plasmoids) in Chakra.

i doesn’t notice a difference without this font

[tom@donar ~]$ pacman -Qi chakra-heritage-themes
Name            : chakra-heritage-themes
Version         : 2019.01-4
Description     : Chakra Plasma 5 Look & Feel theme files
Architecture    : x86_64
URL             :
Licenses        : LGPL
Groups          : None
Provides        : None
Depends On      : plasma-framework  chakra-wallpapers-giau
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 18.38 MiB
Packager        : almack <>
Build Date      : Tue Jan 15 23:03:47 2019
Install Date    : Wed Jan 16 08:39:53 2019
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : SHA-256 Sum

a propos, is there a connection between a zebra and the passo di giau?^^

nothing, just something different then the shape of a human torso :grin:

Let’s see if it works on my new EZBook 3 Pro! :grin:



I am not quite sure where to post feedback about Hawking RC3, so I am starting a new topic for the same. Please merge or move this thread if this is inappropriate. I tried to post on the “news” post announcing RC3, but I did not see an option to reply to that thread, although there were six replies there.

The immediate issue I would like to bring up is that startup is extremely slow - to be specific, after the desktop wallpaper is loaded and visible, it takes a while (30 seconds) for the panel and dock to appear. I suspect that the loading of the new dock widget is what is causing the delay. Later today, I shall try removing it from autostart and confirm it. I wonder if anybody else has noticed this issue?

I should also mention that I changed the desktop theme and window decoration to “Diamond”, which has transparency and blur effects. But I have been using “Diamond” for a couple of years now, and this issue has not come up before. Other than that, I cannot think of anything which could possibly be causing a delay at the aforementioned stage.

I shall give details of my hardware if necessary. (I don’t think it is relevant, as I have been running Chakra without issues on the same machine for a couple of years.)

Apart from that, I feel like the entire OS is running a bit slower than previous releases. Programs are taking longer to start, and so on.

I want to make a suggestion that in machines where Nvidia drivers are automatically installed, like mine, nvidia-tools should also be installed automatically. I had to download it from the repos myself.

Good luck with the release!

1 Like

thanks Sam for the feedback.
Did you tested on a real HW or on virtualbox? on LIVE or after installation?
Is very strange your behaviour, on my PC and on VB is almost instant, when I see the desktop background the plasma is fully loaded.
Please check again that you are using the chakra-2019.01.15-ddf5ae10-x86_64.iso (RC3) because from the RC2 lot of speed improvement are implemented.

I had absolutely no problem with the installation on the ezbook, everything got recognized and worked out-of-the-box.
The installation process went smooth and fast.

I am using the Wayland session as a daily driver, because the screen resolution is handled in a better way (with Xorg everything is too small and the scaling doesn’t work really well), and I have to admit it improved a lot in the past months.



I’m sorry for the late response. I was away from home, and did not have access to the testing machine.

However, after updating pacman again, I find that I do not have that specific problem anymore - of the delay in loading plasma at startup. Whatever the cause was, seems to have been resolved. So please ignore that part of my report, unless others have the same issue.

To answer Luca’s questions, it was a real (not virtualbox, not live session) install on the hard drive.

@FranzMari : May I ask how you use Wayland on Chakra? How does one switch from xorg? Is there a tutorial available? I am also having some scaling issues on my 4k screen.

I would like to reiterate my earlier suggestion that nvidia-tools should be installed by default with nvidia-drivers.

When is “Hawking” expected to be released?

Good luck with that.

Install plasma-wayland-session , logout and choose Plasma (Wayland) session in SDDM.

Plasma on Xorg seems better for now…:joy: I just tried Plasma on Wayland last weekend and still found some small issues…

LibreOffice: The frame disappeared.

Fcitx: unable to align.

This happens in part because of LibreOffice (the kde5 integration isn’t still stable), in part because of gtk3 (3.24 branch should fix this, I hope to be able to update that soon).

Meanwhile LibreOffice 6.2 in [testing] was built with Qt5 support, so it provides a quite ugly but usable window frame under Wayland.

1 Like

Installed yesterday on my HP G72 laptop.

No issues so far, install process is clean and concise. No crash, lag or bug for now.

One single drawback (very personal) : Latte-Dock could be smaller.


gtk3 3.24.5 is now in [testing]

you know what? is not that easy to do, but I will check that again, I have to find the good match between size and “screen proportion size” settings


I know it is not simple to find a layout that renders properly on every screen configurations.

It’s not a real issue by the way as it is very easy to increase/decrease the dock’s size for users.

@AlmAck would it be possible to add this behaviour to latte-dock?

1 Like



This topic was automatically closed after 42 days. New replies are no longer allowed.

RC4 has been released. Continue here.