Catalyst-utils: requires xorg-server<1.18.0

xorg
catalyst

(Jonajams) #1

I have a problem since a couple of weeks, trying to update my software: catalyst does not work as it requires xorg in a downgraded version.
Here I found a solution https://aur.archlinux.org/packages/catalyst-utils/
bu I don’t trust a lot the comment, as it was posted many months ago.

Could you give me some advice? I am not sure about downgrading things…


New Install and EFI problem: blue screen
(kepszlok) #2

AMD dropped the support of Catalyst some time ago. Because of this, Chakra also dropped Catalyst packages. You have to switch your graphics driver to the free alternative. Until then, you will not be able to normally upgrade your system.

See the official announcement here: how to switch


(Jonajams) #4

thank you. the only problem: I have a Nvidia video card, how is it possible I’m using catalyst?!

Ok, I made a mistake and now I need support!!
I tried to install nvidia but it failed. so I tried with Mesa, the new version, as in a topic is said to install mesa to perform the upgrade. Hence, It worked but now i cannot access the pc. During the starting up, I see the mouse icon but it suddenly disapperes for a black screen, and if i run jounalctl it said and error I already had with nvidia drivers /something with loading kernel data.

Please help, now I don-t know what to do…
I might do a chroot from live but dont know what to do…


(kepszlok) #5

nVidia card? Hmmm. At first, you should remove catalyst-utils and any catalyst packages, if there are others.

Chroot from live media is viable, but i think you can simply get a terminal by pressing ctrl + alt + F6 when you gets the black screen.

When was the last time since you did a full system upgrade? I think it was quite a while. So i woud do this steps:

*to remove any catalyst related stuff:
sudo pacman -Rdd catalyst catalyst-libgl catalyst-utils lib32-catalyst-libgl lib32-catalyst-utils
sudo pacman -Syu
reboot

*to get back nvidia:
sudo pacman -Rdd mesa-libgl
sudo pacman -R xf86-video-nouveau

sudo pacman -S nvidia
sudo pacman -S nvidia-utils
reboot

And also, there are some other help here: switch from nvidia to mesa


(Jonajams) #6

ok, thank you for your reply. I followed your procedure and I had the opportunity to totally update chakra.
but now I have another problem :frowning:, cause on the screen I have an error message (plasma2 cannot work due instability etc, or something similar). I have the connection and from the terminal I can see everything is update. but still i have this annoying problem…any suggestion? I really don’t know what to do!


(kepszlok) #7

Can you give us the exact error message? I did never seen such error message.


(tom) #8

you can try to investigate the error:


(Jonajams) #9

Ok i cannot take a picture neither, now just see the mouse icon and the black screen behind! And if i run systemctl failed its said 0 unit.


(kepszlok) #10

Hmm, maybe a kde reset?

switch to terminal with ctrl + alt + f6, then

mv ~/.kde ~/.kde.old
reboot


(tom) #11

had you run systemctl on a TTY? :wink:


(Jonajams) #12

this is the error i have.


(kepszlok) #13

I think, you have to run this command:

sudo nvidia-xconfig
reboot

because there are no OpenGl2 capable driver loaded. Propably your xorg config file needs to be updated, what nvidia-xconfig will do.


(Jonajams) #14

no luck :frowning:


(kepszlok) #15

Wow. No xorg-server?

Then:

sudo pacman -S xorg-server xorg-server-common xorg-server-utils
reboot

After the reboot:
sudo nvidia-xconfig
reboot


(Jonajams) #16

And now i have another weird error

after doing xconfig i have this (it’s blinking if you want to know…)


(kepszlok) #17

Sadly, i’m out of ideas.

We are at the point, where you shoud reinstall your system. I dunno what the heck is this error…


(brli) #18

There is a wiki entry describes how to switch between graphical drivers, did you follow that part?

Anyway, assume you did. We never suggest user to generate a xorg.conf via nvidia-xconfig.

So, please first remove any custom xorg.conf and make sure you’re having a working graphic stack, which should include xorg-server, mesa, and libglvnd in minimum.

Then, there we could start trouble shooting.


(kepszlok) #19

So he have to delete the xorg.conf file and then reboot?

Btw, that wiki page did needs an update. To start, i will remove the now obsolote Catalyst parts.


(brli) #20

We are migrating to the #tutorials part IIRC. So, you can copy the content and sort it up here.


(kepszlok) #21

Hmm. I like to write some tutorials there, but i did not know how to create cool fromatted text with brackets. This new community site are still a bit strange to me. I’m guess i’m just getting old :slight_smile: