Can't update packages to their latest versions, the mirror I use hasn't synchronized with the origin server

Hardware information
[john@spectre ~]$ hwinfo --short
                       Intel(R) Core(TM) m7-6Y75 CPU @ 1.20GHz, 1500 MHz
                       Intel(R) Core(TM) m7-6Y75 CPU @ 1.20GHz, 1500 MHz
                       Intel(R) Core(TM) m7-6Y75 CPU @ 1.20GHz, 1500 MHz
                       Intel(R) Core(TM) m7-6Y75 CPU @ 1.20GHz, 1500 MHz
  /dev/input/event9    AT Translated Set 2 keyboard
                       Synaptics HIDUSB TouchPad V07
graphics card:
                       Intel VGA compatible controller
                       Intel Audio device
                       Intel SATA controller
  wlo1                 Intel WLAN controller
  enp0s20f0u3c2        HP lt4114 LTE 4G Module
network interface:
  lo                   Loopback network interface
  enp0s20f0u3c2        Ethernet network interface
  wlo1                 Ethernet network interface
  /dev/sda             SanDisk SD8SNAT-
  /dev/sda1            Partition
  /dev/sda2            Partition
  /dev/sda3            Partition
  /dev/sda4            Partition
  /dev/sda5            Partition
  /dev/sda6            Partition
usb controller:
                       Intel USB Controller
                       Intel Host bridge
                       Intel PCI bridge
                       Intel ISA bridge
                       Intel PCI bridge
                       Linux 4.13.11-1-CHAKRA xhci-hcd xHCI Host Controller
                       Linux 4.13.11-1-CHAKRA xhci-hcd xHCI Host Controller
                       Main Memory
                       Bluetooth Device
                       DMA controller
                       Keyboard controller
                       Intel Signal processing controller
                       Intel Signal processing controller
                       Intel Signal processing controller
                       Intel SMBus
                       Intel Multimedia controller
                       Intel Signal processing controller
                       Intel Memory controller
                       Realtek Unclassified device
                       Intel Unclassified device
                       Intel Signal processing controller
                       Intel Multimedia controller
  /dev/input/event6    Intel RealSense 3D Camera R200
                       Elan Microelectronics Touchscreen

pacman.conf (2.3 KB)
pacman.log (144.0 KB)

Image above shows current status. Would like to update to current kde per latest announcement from initial install from live media, but pacman -Syu isn’t doing it. From searching update, pacman -syu, system upgrade, force update, and FAQ, haven’t found the solution. I figure it’s something rather stupid, which is why I’m not seeing a solution. Can someone please assist?

  1. second, don’t use ccr -Syu because it is more or less outdated
  2. third read the pacman message below "starting full system upgrade…^^
there is nothing to do
  1. perhaps was your mirror not synced and i would change the mirror
1 Like

This definitely looks like an outdated mirror issue. Please share the contents of the mirrorlist file, so we can tell which mirror is outdated and help you switch to another one:

1 Like

Thanks for the replies and info. Here are the contents of mirrorlist:

# mirrorlist generated by rankmirrors during chakra installation
# the original file was saved to /etc/pacman.d/mirrorlist.pacsave

Server =$repo/x86_64
Server =$repo/x86_64
Server =$repo/x86_64

EDIT: looks like there is an issue with one of the US mirrors I was using. U.S. mirrors out of sync
I’ve just commented it out and re-run pacman -Syu and the update appears to be progressing, but is this an appropriate long-term solution?

Happy to see you resolved your issue. And yes, if you are mirror is down, then switching to another mirror is the proper solution. :+1:

You can always check for the status of our mirrors on the mirrorstatus page.

Thanks, that did solve the issue. Now I rebooted and have a more serious issue: kernel panic with no init found. It seems to be solved by this reply but can someone explain the process in more detail? Kernel panic after update
My main question is where to mount the partitions and where to chroot. If I should start a new thread or add to that one, please let me know.

this will solve your problem:

the installation was from our goedel 2017.10 iso, right?
make a bug report, please

1 Like

Perfect, that solved it. You’re correct about the installation media.
On the bug report,pretend I’m dense for a minute-did you want that about the initial pacman not checking the next mirror issue or the kernel panic due to init failure issue?
Thanks again for all the help.

is about the failing first kernel upgrade with the goedel 2017.10 iso.
the next boot failed because pacman doesn’t trigger mkinitcpio

Got it. Report filed. Thanks again.

1 Like

please post the link to the bug report

Sorry, here it is:
Apologies if it’s not in the right spot, and happy to provide more info if needed.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.

The last release of Chakra to date was made on 2017-09-08.

On 2017-09-24, the Dacentec mirror was removed from our mirror list due to remaining unsynchronized for an extended period of time, despite a reply from their customer support indicating that their mirror administrator(s) would be notified of, and resolve the issue.

This means that new installations may have the unsynchronized Dacentec mirror at the top of their /etc/pacman.d/mirrorlist:

Server =$repo/x86_64

If you do, remove it from your list and use a different mirror, followed by running pacman -Syu to synchronize and upgrade your system.

View the mirror status page to learn the current status of all known mirrors.

Further reading:

1 Like