Can't install HP LaserJet Pro MFP 130FW - it will scan but not print

System information, pacman configuration, and pacman log

System information

Linux thebox 4.14.12-1-CHAKRA #1 SMP PREEMPT Sat Jan 6 00:03:07 CET 2018 x86_64 GNU/Linux

Hardware information

Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
System:    Host: thebox Kernel: 4.14.12-1-CHAKRA x86_64
           bits: 64
           Desktop: KDE Plasma 5.11.5 Distro: Chakra
Machine:   Device: laptop System: System76 product: Oryx Pro v: orxp1 serial: N/A
           Mobo: System76 model: Oryx Pro v: orxp1 serial: N/A
           UEFI: American Megatrends v: 1.05.13RSA1 date: 02/02/2016
Battery    BAT0: charge: 15.1 Wh 22.9% condition: 65.8/59.2 Wh (111%)
           
CPU:       Quad core Intel Core i7-6700HQ (-MT-MCP-)
           cache: 6144 KB
           clock speeds: max: 3500 MHz 1: 2600 MHz
           2: 2600 MHz 3: 2600 MHz 4: 2600 MHz 5: 2600 MHz
           6: 2600 MHz 7: 2600 MHz 8: 2600 MHz
Graphics:  Card: NVIDIA GM204M [GeForce GTX 970M]
           Display Server: N/A
           drivers: nvidia (unloaded: modesetting,vesa)
           tty size: 61x23
Audio:     Card-1 NVIDIA GM204 High Def. Audio Controller
           driver: snd_hda_intel
           Card-2 Intel Sunrise Point-H HD Audio
           driver: snd_hda_intel
           Sound: ALSA v: k4.14.12-1-CHAKRA
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169
           IF: enp2s0f1 state: down mac: <filter>
           Card-2: Intel Wireless 8260 driver: iwlwifi
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 2000.4GB (4.4% used)
           ID-1: /dev/sda model: Samsung_SSD_850 size: 500.1GB
           
           ID-2: /dev/sdc model: HGST_HTS721010A9 size: 1000.2GB
           
           ID-3: /dev/sdb model: Samsung_SSD_850 size: 500.1GB
           
Partition: ID-1: / size: 427G used: 17G (5%)
           fs: ext4 dev: /dev/sda2
           ID-2: /home size: 459G used: 376M (1%)
           fs: ext4 dev: /dev/sdb1
           ID-3: swap-1 size: 34.36GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 33.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 201 Uptime: 20 min Memory: 1993.7/15997.7MB
           Init: systemd Client: Shell (bash) inxi: 2.3.56

/etc/pacman.conf

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
HoldPkg     = pacman glibc pacman-helpme
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options (CheckSpace enabled by default for safety; color enabled by default 'cause it's fancy)
#UseSyslog
Color
#TotalDownload
CheckSpace
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel = Never
LocalFileSigLevel = Never
#RemoteFileSigLevel = Required


#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

#[testing]
#Include = /etc/pacman.d/mirrorlist

[lib32]
Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[desktop]
Include = /etc/pacman.d/mirrorlist

[gtk]
Include = /etc/pacman.d/mirrorlist

#[unstable]
#Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

/etc/pacman.d/mirrorlist

# mirrorlist generated by rankmirrors during chakra installation
# the original file was saved to /etc/pacman.d/mirrorlist.pacsave

Server = http://mirror.rit.edu/chakra/$repo/x86_64
Server = http://mirror.dacentec.com/chakra/$repo/x86_64
Server = http://www-ftp.lip6.fr/pub/linux/distributions/chakra/$repo/x86_64

/var/log/pacman.log

Replace this line with the contents of the file /var/log/pacman.log

Describe your issue and what you’ve tried so far here, including complete log files, terminal input and output, error messages, and versions of any specific software involved. Information is crucial to being able to solve any problem.

I am unable to get an HP LaserJet Pro MFP 130fw installed. I have tried the following:

  • Reviewed forum posts
    – installed as many missing files as possible based on previous posts by users
  • Installed hplip from Chakra repository
  • Installed hplip-plugin through hp-plugin (required for this printer)
  • lsusb output shows the system knows it is there
    – Bus 001 Device 006: ID 03f0:622a Hewlett-Packard
  • hp-check reveals the following comments
    – warning: chakra distro is not found in AUTH_TYPES
    warning: 0- version is not supported. Using 0-0 versions dependencies to verify and install…
    – HPLIP-Version: HPLIP 3.17.10
    HPLIP-Home: /usr/share/hplip
    warning: HPLIP-Installation: Auto installation is not supported for 0 distro version
    – Only red-flagged dependency I could not resolve
    — error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - MISSING ‘python3-notify2 needs to be installed’

I am able to scan but it will not print and applications do not know it is there. I am only connected via usb and do not require wireless.

This is the one thing that will keep me from being able to use Chakra GNU/Linux. Please assist if you are aware of steps to take.

Thank you,

falcon40

Your device is supported by hplip, so there shouldn’t be any issues.

Post the full output of hp-check -t.

Output hp-check -t

hp-check -t
Saving output in log file: /home/jon/hp-check.log

HP Linux Imaging and Printing System (ver. 3.17.10)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode  
before compiling the HPLIP supplied tarball (.tar.gz or .run)
to determine if the proper dependencies are installed to     
successfully compile HPLIP.                                  
2. Run-time check mode (-r or --run): Use this mode to       
determine if a distro supplied package (.deb, .rpm, etc) or  
an already built HPLIP supplied tarball has the proper       
dependencies installed to successfully run.                  
3. Both compile- and run-time check mode (-b or --both)      
(Default): This mode will check both of the above cases (both
compile- and run-time dependencies).                         

Check types:                                                 
a. EXTERNALDEP - External Dependencies                       
b. GENERALDEP - General Dependencies (required both at       
compile and run time)                                        
c. COMPILEDEP - Compile time Dependencies                    
d. [All are run-time checks]                                 
PYEXT SCANCONF QUEUES PERMISSION                             

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

warning: chakra distro is not found in AUTH_TYPES
warning: 0- version is not supported. Using 0-0 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.14.12-1-CHAKRA #1 SMP PREEMPT Sat Jan 6 00:03:07 CET 2018 GNU/Linux
 Host: thebox
 Proc: 4.14.12-1-CHAKRA #1 SMP PREEMPT Sat Jan 6 00:03:07 CET 2018 GNU/Linux
 Distribution: 0 
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.17.10
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 0 distro   version 

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.17.10

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.17.10
html=/usr/share/doc/hplip-3.17.10
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=yes
internal-tag=3.17.10
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no


Current contents of '/var/lib/hp/hplip.state' file:
[plugin]
installed = 1
eula = 1
version = 3.17.10



Current contents of '~/.hplip/hplip.conf' file:
[installation]
date_time = 01/25/18 17:07:58
version = 3.17.10


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

-------------------------
| External Dependencies |
-------------------------

 cups                 CUPS - Common Unix Printing System                           REQUIRED        1.1             2.2.1           OK         'CUPS Scheduler is running'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.21            OK         -
 xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.25          OK         -
 dbus                 DBus - Message bus system                                    REQUIRED        -               1.10.12         OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.113           OK         -
 network              network -wget                                                OPTIONAL        -               1.19.2          OK         -
 avahi-utils          avahi-utils                                                  OPTIONAL        -               0.6.31          OK         -

------------------------
| General Dependencies |
------------------------

 libjpeg              libjpeg - JPEG library                                       REQUIRED        -               -               OK         -
 cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               2.2.1           OK         -
 cups-image           CUPS image - CUPS image development files                    REQUIRED        -               2.2.1           OK         -
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.25'         OK         -
 libusb               libusb - USB library                                         REQUIRED        -               1.0             OK         -
 sane                 SANE - Scanning library                                      REQUIRED        -               1.0.25          OK         -
 sane-devel           SANE - Scanning library development files                    REQUIRED        -               1.0.25          OK         -
 libnetsnmp-devel     libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.7.2           OK         -
 libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.0.2           OK         -
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.6.2           OK         -
 error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               MISSING    'python3-notify2 needs to be installed'
 python3-pyqt4-dbus   PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             4.12.1          OK         -
 python3-pyqt4        PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             4.12.1          OK         -
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.4           OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.2.1           OK         -
 python3-devel        Python devel - Python development files                      REQUIRED        2.2             3.6.2           OK         -
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               1.1.7           OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.4.0           OK         -

--------------
| COMPILEDEP |
--------------

 libtool              libtool - Library building support services                  REQUIRED        -               2.4.6           OK         -
 gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               6.3.1           OK         -
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.2.1           OK         -

---------------------
| Python Extentions |
---------------------

 cupsext              CUPS-Extension                                               REQUIRED        -               3.17.10         OK         -
 hpmudext             IO-Extension                                                 REQUIRED        -               3.17.10         OK         -

----------------------
| Scan Configuration |
----------------------

 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.17.10         OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.17.10         OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `v4l:/dev/video0' is a Noname BisonCam, NB Pro: BisonCam, NB  virtual device
device `hpaio:/usb/HP_LaserJet_MFP_M129-M134?serial=VNB3D12128' is a Hewlett-Packard HP_LaserJet_MFP_M129-M134 all-in-one


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI                Model                   
  ------------------------  ------------------------
  hp:/usb/HP_LaserJet_MFP_  HP LaserJet MFP         
  M129-M134?serial=VNB3D12  M129-M134               
  128                                               

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
lpstat
------
Type: Unknown
Device URI: No destinations added.


--------------
| PERMISSION |
--------------

USB             None                           Required        -        -        OK       Node:'/dev/bus/usb/001/007' Perm:'  root  lp rw- rw- rw- rw- r--'
 
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
None

Missing Optional Dependencies
-----------------------------
None


Total Errors: 1
Total Warnings: 0


Done.

First time posting code. Hope I did it correctly. Thank you for the quick response.–falcon40

Your printer is discovered as a scanning device:

but is not setup to work as a printer:

We can troubleshoot that, starting from the basics.

Have you used the HP Device Manager to setup your printer? It should come installed with the hplip package.

I have not tried that on this installation attempt. I have tried in the past, however, with no success. I will try again now. I did not think that was the key since I have not had to do that with other debian-based and arch-based distributions. I will report results soon. Thank you.–falcon40

Edit: I used the HP Device Manager to setup the printer. The dialog boxes say the printer is installed but the printer states that the “driver is invalid.” This is what happened on previous installation attempts. On other distributions this is what happens when I do not have the proprietary driver (hplip-plugin) installed. I am still unable to print.

Edit: I tried reinstalling hplip-plugin. It reinstalled but I still get a “drver is invalid” statement when trying to print. I would prefer to use Chakra GNU/Linux but I cannot if I am unable to resolve this issue as I need the printer functionality. Several questions come to mind:

  1. What is different/missing in Chakra that makes this so challenging.
  2. I am unable to use the hplip-plugin from CCR because the versions are different resulting in a failed install. Should I try to downgrade the hplip version? I do not know how to do this.
    Theses questions are more rhetorical in nature to possibly spark ideas. I have the questions but do not have the answers.–falcon40

Edit: To get the printer installed in other distributions I just ensure hplip is installed and add hplip-plugin either from the AUR repository (if Arch-based) or with the hp-plugin command from the command line if there is a mismatch in versions between hplip and hplip-plugin or on a non-Arch distribution. I can print immediately after that is accomplished. Something is different in Chakra GNU/Linux–just unaware of what it is. Willing to take extra steps if I know what they are.–falcon40

Flagged the package as out of date, however, could take a while to get updated, and I don’t know how to (if I even can) contribute to updating the package.

In the meantime, save this:

# maintainer : whoami <pace_a_te@libero.it>
# contirbutor: PyroPeter <googlemail.com@abi1789>
 
pkgname=hplip-plugin
pkgver=3.17.10
pkgrel=1
pkgdesc="Binary plugin for HPs hplip printer driver library"
arch=('x86_64')
url="http://hplipopensource.com/"
license=('unknown: proprietary')
makedepends=('python2' 'pygobject' 'dbus-python')
depends=('hplip='$pkgver)
source=(
	"http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-$pkgver-plugin.run"
)
md5sums=('ab5ff33c500d76202619cba2d744fa2c')
 
build(){
    cd $srcdir
    # Untargziping the makeself selfextracting archive
    sh hplip-$pkgver-plugin.run --tar xvf
}
 
package() {
 
    # Create folders
    install -d $pkgdir/usr/lib/udev/rules.d
    install -d $pkgdir/usr/share/hplip/data/firmware
    install -d $pkgdir/usr/share/hplip/fax/plugins
    install -d $pkgdir/usr/share/hplip/prnt/plugins
    install -d $pkgdir/usr/share/hplip/scan/plugins
    install -d $pkgdir/usr/share/licenses/hplip-plugin
    install -d $pkgdir/var/lib/hp
 
    # Copy files
    cd $srcdir
    #install -m644 86-hpmud-hp_laserjet_*.rules $pkgdir/usr/lib/udev/rules.d/
    install -m644 plugin.spec                  $pkgdir/usr/share/hplip/
    install -m644 hp_laserjet_*.fw.gz          $pkgdir/usr/share/hplip/data/firmware/
    install -m755 fax_marvell-x86_64.so      $pkgdir/usr/share/hplip/fax/plugins/
    install -m755 hbpl1-x86_64.so            $pkgdir/usr/share/hplip/prnt/plugins/
    install -m755 lj-x86_64.so               $pkgdir/usr/share/hplip/prnt/plugins/
    install -m755 bb_*-x86_64.so             $pkgdir/usr/share/hplip/scan/plugins/
    install -m644 license.txt                  $pkgdir/usr/share/licenses/hplip-plugin/
 
       cat << EOF > hplip.state
[plugin]
installed = 1
eula = 1
version = $pkgver
EOF
 
 
 
   install -m644 hplip.state                $pkgdir/var/lib/hp
 
    # Create symlinks
    for f in $(find $pkgdir/usr/share/hplip -type f -name "*.so"); do
        cd $pkgdir/usr/share/hplip
        cd $(dirname $f)
        link_name="$(basename $f | cut -d- -f1).so"
        ln -s $(basename $f) $link_name
    done
}

as a file named PKGBUILD, run makepkg in the directory you saved this file, then install the resulting tarball with pacman -U <resulting_tarball>.

How did you install hp-plugin outside of the CCR package?

EDIT:
Forgot to update md5 in PKGBUILD file, whoops

Okay. I will try this. What is the extension/suffix for the file “PKGBUILD”?

To get the latest hplip-plugin from HP you just use the command “hp-plugin” from the command line and it will pull the appropriate file from their servers.

  • hp-plugin results in a graphical process where you authenticate before finalization
  • sudo hp-plugin results in a command-line process
  • works on other distros

Thank you for your kind assistance, ChrootDoot. If I am unsuccessful I will install another distribution and check back regularly to see if the situation has been resolved. I do think this is an area that may be reducing user numbers if others have the same issue. This is not an issue in other distributions. I understand I can try buying a different printer but that is not a reasonable solution for me at the moment.

Thanks again,

falcon40

Edit: Interesting thing happened when trying to run “makepkg PKGBUILD”. I get the following error message:

makepkg PKGBUILD
==> Making package: hplip-plugin 3.17.10-1 (Thu Jan 25 23:43:24 EST 2018)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Missing dependencies:
  -> pygobject
==> ERROR: Could not resolve all dependencies.

==> ERROR: An unknown error has occurred. Exiting...

My system says that pygobject is installed.

whereis pygobject
pygobject: /usr/share/pygobject

This is likely the issue. I will have to go elsewhere for now. Please let me know if you think this is a bug and whether I should submit it. Thank you, again.–falcon40

Sorry, I forgot with makepkg you could run makepkg -s, which installs any missing dependencies. What you probably need is to install python2-gobject, but just run makepkg -s it will handle that for you.

Also, makepkg can be run without specifying PKGBUILD as a parameter, and in fact, it will only look for the file PKGBUILD, unless you use the parameter -p:

makepkg -p otherFileName

Also also, I forgot to update the md5sum in the text I pasted you. It’s now corrected, but you’ll need to resave it or you will receive an error when you run makepkg.

Other than that, keep posting if you are still having issues.

Chroot Doot–I did as you suggested and installed the package. Unfortunately the same result occurred after running the HP Device Manager, rebooting and restarting the printer twice. The printer installed but will not print. Wish it was not so as I really like Chakra GNU/Linux but I need the printer functionality. No worries as it seems as I may be an anomaly due to some hardware combination. I will try again when I have a break between work requirements. Thanks again.–falcon40

Does this printer have a wireless function? It might be worth setting it up as a wireless printer to check if it works.

This printer does have a wireless function. I will try this when I get Chakra GNU/Linux back on hardware. However, please note that the printer works fine via USB with other distributions. Thank you.–falcon40

This topic was automatically closed 85 days after the last reply. New replies are no longer allowed.