Cannot upgrade the system

Hey guys, it has been months i cannot update my system. I guess it is a problem with mirrors but cannot find a solution…I hereby attach the result of LC_ALL=C sudo pacman -Sy**u

Hardware information
[domenico@domenico-pc ~]$ LC_ALL=C sudo pacman -Syu
:: Synchronizing package databases...
 lib32 is up to date
 core is up to date
 desktop is up to date
 gtk is up to date
:: Starting full system upgrade...
warning: pacmanlogviewer: local (1.4.1-2) is newer than desktop (1.4.1-1)
warning: sddm-kcm: local (1:5.17.1-1) is newer than core (5.17.3-1)
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: libreoffice-it will be installed before its libreoffice-common dependency

Packages (45) babl-0.1.74-1  ca-certificates-mozilla-3.50-1  curl-7.68.0-1  ed-1.16-1  expat-2.2.9-1  firefox-74.0.1-1  fribidi-1.0.7-1  gegl-0.4.20-1  gimp-2.10.16-1  git-2.25.0-1  hwids-20190818-1
              kodi-18.6-1  kpmcore-4.1.0-1  libnsl-1.2.0-1  libreoffice-base-6.4.0-1  libreoffice-calc-6.4.0-1  libreoffice-common-6.4.0-1  libreoffice-draw-6.4.0-1  libreoffice-gtk3-6.4.0-1
              libreoffice-impress-6.4.0-1  libreoffice-it-6.4.0-1  libreoffice-kde5-6.4.0-1  libreoffice-math-6.4.0-1  libreoffice-postgresql-connector-6.4.0-1  libreoffice-sdk-6.4.0-1
              libreoffice-sdk-doc-6.4.0-1  libreoffice-writer-6.4.0-1  libusb-1.0.23-1  luajit-2.0.5-1  mdadm-4.1-1  mesa-19.1.8-1  nano-4.9.2-1  nspr-4.25-1  nss-3.50-1  openjpeg2-2.3.1-1
              os-prober-1.77-1  partitionmanager-1:4.1.0-1  pciutils-3.6.2-1  python2-2.7.17-1  sdl2-2.0.10-1  slang-2.3.2-1  sqlite-3.31.1-1  sudo-1.8.31-1  ttf-liberation-2.1.0-1  usbutils-012-1

Total Download Size:     62.20 MiB
Total Installed Size:  1729.49 MiB
Net Upgrade Size:       369.01 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 sqlite-3.31.1-1-x86_64                                                                     1423.1 KiB  1009 KiB/s 00:01 [########################################################################] 100%
 sdl2-2.0.10-1-x86_64                                                                        610.3 KiB   279 KiB/s 00:02 [########################################################################] 100%
 python2-2.7.17-1-x86_64                                                                      11.3 MiB  1331 KiB/s 00:09 [########################################################################] 100%
 mdadm-4.1-1-x86_64                                                                          345.7 KiB  1235 KiB/s 00:00 [########################################################################] 100%
 firefox-74.0.1-1-x86_64                                                                      48.6 MiB  1008 KiB/s 00:49 [########################################################################] 100%
(45/45) checking keys in keyring                                                                                         [########################################################################] 100%
(45/45) checking package integrity                                                                                       [########################################################################] 100%
error: sqlite: signature from "Chaka Build Server (Automated Chakra Build System) <staff@chakralinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/sqlite-3.31.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: sdl2: signature from "Chaka Build Server (Automated Chakra Build System) <staff@chakralinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/sdl2-2.0.10-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: python2: signature from "Chaka Build Server (Automated Chakra Build System) <staff@chakralinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/python2-2.7.17-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: firefox: signature from "Chaka Build Server (Automated Chakra Build System) <staff@chakralinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/firefox-74.0.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: mdadm: signature from "Chaka Build Server (Automated Chakra Build System) <staff@chakralinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/mdadm-4.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

this is my mirrolist file:
Server = http://www-ftp.lip6.fr/pub/linux/distributions/chakra/$repo/x86_64
Server = http://ftp.ciril.fr/pub/linux/chakra/$repo/x86_64
Server = https://mirror.alpix.eu/chakra/$repo/x86_64

this mirror is working:

Server = http://ftp.halifax.rwth-aachen.de/chakra/$repo/x86_64

if you want a complete new mirrorlist:

sudo pacman -U http://ftp.halifax.rwth-aachen.de/chakra/core/x86_64/pacman-mirrorlist-20191025-1-x86_64.pkg.tar.xz

for your out of order mirrors i suggest a bug report

thank you fro the reply. actually, i have here the same problem of -Syu

[domenico@domenico-pc pacman.d]$ sudo pacman -U http://ftp.halifax.rwth-aachen.de/chakra/core/x86_64/pacman-mirrorlist-20191025-1-x86_64.pkg.tar.xz
pacman-mirrorlist-20191025-1-x86_64 2,8 KiB 1573 B/s 00:02 [########################################################################] 100%
pacman-mirrorlist-20191025-1-x86_64.sig 566,0 B 0,00 B/s 00:00 [########################################################################] 100%
caricamento dei pacchetti in corso…
errore: ‘/var/cache/pacman/pkg/pacman-mirrorlist-20191025-1-x86_64.pkg.tar.xz’: il pacchetto non è valido oppure è corrotto (firma PGP)

Please add LC_ALL=C before any command you wish to share here. This will sets the output to english.

i think there will a new problem rise because there are new keys in the chakra-keyring

  1. pacman-key -h
    1.1 sudo pacman-key --refresh-keys -u
  2. pacman -Syu

the current mirrorlist

# Chakra repository mirrorlist

# The first not commented (no # at the beginning of the line) mirror is
# used. Mirrors are used in order, starting from the top. Add a # at 
# the start of a line to disable a mirror.  

# Australia
Server = http://mirror.aarnet.edu.au/pub/chakra/$repo/x86_64

# Brazil 
Server = http://chakra.c3sl.ufpr.br/$repo/x86_64

# China 
Server = http://mirrors.ustc.edu.cn/chakra/$repo/x86_64
Server = http://mirrors.tuna.tsinghua.edu.cn/chakra/$repo/x86_64

# Colombia 
Server = http://mirror.edatel.net.co/chakra/$repo/x86_64

# France 
Server = http://www-ftp.lip6.fr/pub/linux/distributions/chakra/$repo/x86_64
Server = http://elgrande74.net/chakra/packages/$repo/x86_64
Server = https://mirrors.deogracia.xyz/chakra/packages/$repo/x86_64

# Germany 
Server = http://ftp.halifax.rwth-aachen.de/chakra/$repo/x86_64
Server = http://mirror.selfnet.de/chakra/$repo/x86_64
Server = https://mirror.alpix.eu/chakra/$repo/x86_64
#Server = https://rsync.chakralinux.org/packages/$repo/x86_64

# Greece 
Server = http://ftp.cc.uoc.gr/mirrors/linux/chakra/$repo/x86_64

# Italy 
Server = http://chakra.mirror.garr.it/mirrors/chakra/$repo/x86_64

# Russia 
Server = http://mirror.yandex.ru/mirrors/chakra/$repo/x86_64

# Sweden
Server = http://ftp.acc.umu.se/mirror/chakralinux.org/packages/$repo/x86_64

# Switzerland 
Server = https://mirror.puzzle.ch/chakralinux/$repo/x86_64

# Taiwan 
Server = http://free.nchc.org.tw/chakra/packages/$repo/x86_64
Server = http://ftp.yzu.edu.tw/Linux/chakra/$repo/x86_64
Server = http://mirror.ossplanet.net/chakra/packages/$repo/x86_64
Server = http://ftp.ubuntu-tw.org/mirror/chakra/packages/$repo/x86_64
Server = http://ftp.tku.edu.tw/Linux/Chakra/packages/$repo/x86_64

# United States
Server = http://mirror.rit.edu/chakra/$repo/x86_64
Server = http://www.gtlib.gatech.edu/pub/chakra/packages/$repo/x86_64