Cannot explore second hdd on my laptop

(Jonajams) #1

hey guys, I’m experiencing this weird problem: I have two hdd on my laptop, one with chakra/windows on, the other with files on. Since a couple of days, when I click on my second hdd, i’m requested the password to explore it (as usual) but nothing more happens, hence I cannot explore this hdd. Do you have any suggestion? it’s such a unique problem i’m neither able to search for a solution online…

(kepszlok) #2

Just an alternative solution:

Mount it automaticaly at boot time using the fstab file. Then your password will not needed anymore for opening that hdd.

If you unsure of this, then please post the output of this command here:
sudo fdisk -l

(Jonajams) #3

uhm I’m not sure you got my point: I can mount the hdd, but I cannot explore it, so I cannot open those files I need on that…
as you can be below, I can only access to sdb so far…

Disk /dev/sda: 931,5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 2EC11DA3-537A-458D-B788-93F9DE332178

Dispositivo      Start       Fine   Settori   Size Tipo
/dev/sda1         2048     206847    204800   100M EFI System
/dev/sda2       206848     239615     32768    16M Microsoft reserved
/dev/sda3       239616  629667674 629428059 300,1G Microsoft basic data
/dev/sda4    629667840 1259769103 630101264 300,5G Microsoft basic data
/dev/sda5   1259769856 1951415548 691645693 329,8G Microsoft basic data
/dev/sda6   1951426560 1953523711   2097152     1G Windows recovery environment


Disk /dev/sdb: 256,2 GiB, 275064201216 bytes, 537234768 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x859941fe

Dispositivo Avvio     Start      Fine   Settori   Size Id Tipo
/dev/sdb1              4096 100847615 100843520  48,1G 83 Linux
/dev/sdb2   *     100847616 510445567 409597952 195,3G  7 HPFS/NTFS/exFAT
/dev/sdb3         510447014 537229664  26782651  12,8G 82 Linux swap / Solaris
(totte) #4

Please prepend LC_ALL=C to commands run to post in English. What are the permissions of the files? What have you tried so far? Which partition is it that you can’t browse? What, specifically, does “cannot explore this hdd” mean? Are you talking about using Dolphin or another graphical file browser, or Konsole? How was the hard drive set up? Do you have ntfs-3g installed?

(Jonajams) #5

i’m using dolphin and I cannot see what is inside my ntfs disks, hence those mounted under /dev/sdba.
I have ntfs-3g installed

here I found an error
domenico@domenico-pc ~]$ sudo mount /dev/sda3
mount: /dev/sda3: can’t find in /etc/fstab.

(totte) #6

Please answer this, too.

Which one is that?

Why are you trying to mount that partition? Post your /etc/fstab.

(Jonajams) #7

I copied, through windows, some files on the hdd I could not open on chakra. I restarted, and now I can explore these hdd without problems. so weird o.O

(Fireshadow 3) #8

I see you said “Restarted”. If I got it right, you are trying to access the Windows partitions from Chakra through Dolphin. But on some computers, especially laptops, if you shutdown Windows it goes in a sort of “Ibernation” mode, not allowing external access to his hard disk. Instead, you can bypass this security by restarting Windows, instead of shutting it off. I know this problem, I deal with it daily.

(totte) #9

Try disabling the “fast startup” for Windows.

(Jonajams) #10

how to do it?
cause I need some software which run only on windows…

(totte) #11

Search the web. You still haven’t answered my previous questions.

(Jonajams) #12

this is my fstab, which is the original one:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=6b1b0e79-7278-479c-881c-ce5c2975bbe5 /              ext4    defaults,noatime,discard 0 1
UUID=2c038ad6-acbe-4056-9fa0-e299bc38d4ac swap           swap    defaults,noatime,discard 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

I don’t know about permission, did not change nothing since the install.
About the mount, it was /dev/sda3, on that message I did a mistake.

(totte) #13

Install of what? See man ls, then run ls in the directory you mount the device to. Try running mount /dev/sdb2 /somewhere/of/your/choice - edit as necessary, I’m guessing that it is sdb2 you want to mount but it’s not entirely clear from what you’ve written so far - and see what happens. I think that if Windows (I don’t know which version of it that this applies to) is hibernated, you should get a non-zero exit code and descriptive message of why it fails.

(Jonajams) #14

my installation from formatting the first hdd (which is an ssd)

about hibernation, I have win 10 in dual boot, and using an sdd I don’t have the hibernation active

about the error, I couldn’t mount neither sdb2 nor sda 3/4/5 (all of them are ntfs).
As I said, after restarting windows chakra works properly

(totte) #15

What, specifically, did you install? Chakra? Windows 10?

How, specifically, do you know that hibernation isn’t enabled?

This is not an error message. Post the actual error message, not your vague interpretation of an event.

Glad it worked out in the end. I strongly suggest that you read this topic again, given your tendency to ignore questions and being cagey about providing information about your system.

Since what little information there is in this topic points towards this being an issue with the “fast startup” feature of Windows 10, let’s leave it at that.

(Jonajams) #16

hens, I’m glad for your help, but you can image I’m not an advanced user of chakra hence if I say I did not change any permission on my hdds, it means I left everything as brand-new.
By the way, I firstly wrote the error (I cannot open ntfs hdds on dolphin), that I have a dual boot (of course chakra, it’s the community here!), and hibernation cause it’s into option when I want to turn off windows (…).

Finally, thank you for the support. I check the fast startup on windows and try to solve it.

(system) closed #17

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.