Cannot connect to wifi anymore

hi guys, since a couple of days I’me experiencing a really bad issue, as I cannot connet to wifi: I turn on the laptop and I inserct my password; then I see the network wizard on the right side (where you can see all the connection) turning total black (so all the connection disappeared) and then I can see all the connection but the one I want to connect. After few seconds this one is there anothere time, but if I click “connect” I have the same problem (disappearing and reappearing).
I tried to connect through ethernet and works fine, and now I’m on windows and wifi works normally.
What is the problem that I have?! I really don’t know how to fix it!

Does it started to misbehave after an update?

I think so, after last update i did. Can’t say which one was…

You can check what’s got updated in the file here: /var/log/pacman.log

networkmanager got updated to 5.56 from 5.55 now, maybe that’s the source of the problem.

Are you using a driver provided on CCR or built locally?

I have something similar happening here, but I believe it only occurs after I boot into windows on my system (Dell XPS L502x).

Try rebooting a couple of times into Chakra without booting into windows, see if it is fixed.

As long as I don’t boot back into windows, WiFi works fine.

if nm-applet doesn’t work for you, you can get a connection when it works again


I use the driver provided. Didn’t remember to install any external driver

Yes, i did this update. How to solve this problem?

any message using dmesg before and after the wifi disappear?

No, no messages. Any ideas? (sorry for my laaaate response)

Update : i installed updates through ethernet but still I have this big problem…

have you configuration files in /etc/NetworkManager/system-connections/?
if, i would move thy elsewhere and try again as example
sudo mv /etc/NetworkManager/system-connections/* ~/`

1 Like

Cannot enter the folder, don’t know why. Tried to reinstall network manager but no effect…

it’s a permission thing, you must use sudo

sudo ls /etc/NetworkManager/system-connections/
sudo nano /etc/NetworkManager/system-connections/<yourCofigFile>


thank you a lot!! I moved the original configuration file and now the connection works again!!

1 Like

please mark this thread as solved


I’m sorry but i can’t make it… How to?

This is explained in the category description, please read it: