Browsing android phone from Dolphin fails


(kepszlok) #1

Since some time i can’t open my (or any other) android phone from KDE’s removable devices notification because of this KIO slave error:


It’s not a clear error message, but seems like kio can’t find the mounted phone, it misses the device file.

Meanwhile, i’m able to browse my phone using android file transfer (mtp) program, so it’s not a cable or android related issue. Also, mounting phones from Dolphin worked fine in the past. Strangely, after installing the android file transfer program, i was again able to browse my phone from Dolphin, for a couple of days, then it died again.

Any ideas?


Current status of the testing repository [2019-02-07 - 2019-02-14]
(Neofytos Kolokotronis) #2

Can you access the phone using this application?


(kepszlok) #3

Yes. AFT for Linux works, i can download files from the phone with it.
mtp-detect also sees my phone.


(Fred Talmadge) #4

Same as here https://code.chakralinux.org/chakra/packages/core/issues/73


(Jeff Huang) #5

Do you have kio-extras installed? If no, please install it and try again.


(kepszlok) #6

Yes, i have kio-extras installed.


(totte) #8

@kepszlok, is the linked issue report the same as the issue you describe? Which versions of linux, systemd, and libmtp do you have installed? This should be resolved as of commit 2a87e083.


(kepszlok) #9

I can’t decide it, that bugreport is well, not a simple thing.

For packages, i’m using the latest packages form testing, as always.
kernel: 4.19.12-1
systemd: 239.303-2
libmtp: 1.1.15-1


(totte) #10

libmtp-1.1.16-1 is available in [testing], please upgrade. Note the upstream difference in /usr/lib/udev/rules.d/69-libmtp.rules, line 4, for version 1.1.15:

ACTION!="add", GOTO="libmtp_rules_end"

…and for version 1.1.16:

ACTION!="add", ACTION!="bind", GOTO="libmtp_rules_end"

(kepszlok) #11

Oh, the good old udev rules! Updateing libmtp solved this!


(system) closed #12

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.