Bomi won't run on Intel 945GM chipset (GMA 950 graphics core), returns the error "OpenGL version is too low. bomi requires OpenGL 2.1 or higher."

Hello, I had a problem with bomi. When I try to open it this message comes up:

Error: OpenGL version is too low. bomi requires OpenGL 2.1 or higher.

Failed to check OpenGL support.
It may help to update driver of graphic card.

I ended up installing vlc but before that I updated the system by using pacman -Syu. The problem still remain. I have a Core 2 Duo laptop with intel 945GM Chipset.

show us the output please

pacman -Q libglvnd
pacman -Qs opengl

Also, what do you have as Rendering backend under System Settings -> Display and Monitor -> Compositor?

libglvnd 0.2.999+g4ba53457-3

and

local/freeglut 2.8.1-2
    Provides functionality for small OpenGL programs
local/glu 9.0.0-3
    Mesa OpenGL Utility library
local/lib32-glu 9.0.0-2
    Mesa OpenGL utility library (32 bits)
local/lib32-mesa 17.3.3-2
    an open-source implementation of the OpenGL specification (32-bit)
local/libepoxy 1.4.1-1
    A library for handling OpenGL function pointer management for you
local/mesa 17.3.3-2
    an open-source implementation of the OpenGL specification

I think it says OpenGL 2.0. This is in portuguese so not sure if this is the corresponding term to “Rendering backend”.

What is the output of glxinfo | grep "OpenGL version" ?

Can you try switching to OpenGL 3.1 as Rendering Backend?

I can. Should I restart the pc afterwards?

The output is: OpenGL version string: 1.4 Mesa 17.3.3

P.S. - Sorry guys for all this mess and thank you for your interest.

Edit: I changed to OpenGL 3.1 but still no bomi.

Here is your problem. In my case, the output is OpenGL version string: 3.0 Mesa 17.3.3.

Did you restart afterall? Please switch to OpenGL 3.1, restart and then try running the above glxinfo command and bomi again.

Can you also share the output of pacman -Qs intel and pacman -Qs xf86?

I did restart the system and nothing new. I’ll try again.

$ pacman -Qs intel
local/iasl 20150717-1
    Intel ACPI Source Language compiler
local/intel-ucode 20180108-1
    Microcode update files for Intel CPUs
local/lib32-mesa 17.3.3-2
    an open-source implementation of the OpenGL specification (32-bit)
local/mesa 17.3.3-2
    an open-source implementation of the OpenGL specification
local/xf86-video-intel 1:2.99.917+804+g708255cb-1 (xorg-drivers xorg)
    X.org Intel i810/i830/i915/945G/G965+ video drivers

$ pacman -Qs xf86
local/lib32-libxxf86vm 1.1.3-1
    X11 XFree86 video mode extension library (32-bit)
local/libxxf86dga 1.1.4-1
    X11 Direct Graphics Access extension library
local/libxxf86vm 1.1.3-1
    X11 XFree86 video mode extension library
local/xf86-input-keyboard 1.9.0-1 (xorg-input-drivers)
    X.Org keyboard input driver
local/xf86-input-libinput 0.26.0-1 (xorg-drivers xorg)
    Generic input driver for the X.Org server based on libinput
local/xf86-input-synaptics 1.9.0-1 (xorg-drivers xorg)
    Synaptics driver for notebook touchpads
local/xf86-video-intel 1:2.99.917+804+g708255cb-1 (xorg-drivers xorg)
    X.org Intel i810/i830/i915/945G/G965+ video drivers
local/xf86-video-vesa 2.3.4-2 (xorg-drivers xorg)
    X.org vesa video driver
local/xf86dgaproto 2.1-3
    X11 Direct Graphics Access extension wire protocol
local/xf86vidmodeproto 2.3.1-1
    X11 Video Mode extension wire protocol

I installed Kodi, Dragon and VLC. Could it have anything to do with it? Also Steam (that stopped working but we’ll leave for another occasion). I uninstalled these applications and I’ll restart the computer.

If I uninstall Kodi, glxinfo stops working. I could always reinstall Chakra. Do you think it’s useful to pursue a solution for this problem?

I think the problem are not the drivers, but you don’t have enabled opengl on your system.
What is the output of glxinfo | grep OpenGL ?

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) 945GM 
OpenGL version string: 1.4 Mesa 17.3.3
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 2.0 Mesa 17.3.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16
OpenGL ES profile extensions:

After installing kodi because before that it would be “command not found”.

which intel driver are you using?
xf86-video-intel or kernel?

If the package is installed try to uninstall it and use kernel based video driver. Otherwise install it and check. Reboot to enable new drivers.

I have a Haswell and use kernel drivers, OpenGL version is 3.0

Luca, do you mean he has to enable in the plasma settings?

system settings->display->compositor->rendering engine = OpenGL3.1

I just made a clean install of Chakra and tried to open bomi before performing “pacman -Syu”. It showed up the same error message. After updating the system it’s the same: no bomi.

@dinolib

Really I don’t know. I didn’t do anything about the drivers. I activated OpenGL 3.1 in the compositing part of the preferences and still bomi doesn’t run.

Try to change the drivers as from my first message…
sudo pacman -Rnns xf86-video-intel
then reboot

Give a try to this:
https://wiki.archlinux.org/index.php/Intel_graphics#OpenGL_2.1_with_i915_driver
I’m not sure the same issue, but very similar

Ehm… according to https://en.wikipedia.org/wiki/Intel_GMA#GMA_950 your card support up to OpenGL1.4.
Can’t you add some option to Bomi?

1 Like

So it’s not a fault it’s just default… :smiley:

Thank you all for your help.

This seems solved since it’s a limitation of the hardware that only supports OpenGL 1.4.

1 Like

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.