After disabling the testing repository, downgrading fails on files owned by `p11-kit`

Hardware information
$ inxi -Fzc 0
System:    Host: kinderspeelgoed Kernel: 5.2.11-3-CHAKRA x86_64 bits: 64 Desktop: KDE Plasma 5.17.3
           Distro: Chakra
Machine:   Type: Laptop System: Hewlett-Packard product: Compaq Presario CQ71 Notebook PC v: Rev 1
           serial: <filter>
           Mobo: Hewlett-Packard model: 306B v: 21.14 serial: <filter> BIOS: Hewlett-Packard v: F.20
           date: 10/13/2009
Battery:   ID-1: BAT0 charge: N/A condition: N/A/48.8 Wh
CPU:       Topology: Dual Core model: Celeron T3100 bits: 64 type: MCP L2 cache: 1024 KiB
           Speed: 1895 MHz min/max: N/A Core speeds (MHz): 1: 1895 2: 1895
Graphics:  Card-1: Intel Mobile 4 Series Integrated Graphics driver: i915 v: kernel
           Display: x11 server: X.Org 1.20.3 driver: intel unloaded: modesetting,vesa resolution: 1600x900~60Hz
           OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express v: 2.1 Mesa 19.1.8
Audio:     Card-1: Intel 82801I HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.2.11-3-CHAKRA
Network:   Card-1: Qualcomm Atheros AR9285 Wireless Network Adapter driver: ath9k
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 111.79 GiB used: 8.60 GiB (7.7%)
           ID-1: /dev/sda vendor: Kingston model: SV300S37A120G size: 111.79 GiB
Partition: ID-1: / size: 105.59 GiB used: 8.60 GiB (8.1%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda1
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 137 Uptime: 30m Memory: 2.86 GiB used: 905.3 MiB (30.9%) Shell: bash inxi: 3.0.10

mirrorlist.conf (754 Bytes)
pacman.conf (2.8 KB)

$ up <- that's just an alias to pacman -Syyuu
:: Synchronising package databases...
 lib32                                                                                                       105.3 KiB  84.9 KiB/s 00:01 [------------------------------------------------------------------------------------] 100%
 core                                                                                                       1691.9 KiB  1446 KiB/s 00:01 [------------------------------------------------------------------------------------] 100%
 desktop                                                                                                    1101.5 KiB  3.16 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 gtk                                                                                                         154.2 KiB  3.01 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
:: Starting full system upgrade...
warning: ca-certificates-mozilla: downgrading from version 3.52-2 to version 3.50-1
warning: curl: downgrading from version 7.71.0-1 to version 7.68.0-1
warning: dbus: downgrading from version 1.12.18-2 to version 1.12.12-2
warning: firefox: downgrading from version 76.0.1-1 to version 74.0.1-1
warning: git: downgrading from version 2.26.2-1 to version 2.25.0-1
warning: gnutls: downgrading from version 3.5.19-2 to version 3.5.19-1
warning: jack: downgrading from version 0.125.0-5 to version 0.125.0-3
warning: kdiagram: downgrading from version 2.7.0-1 to version 2.6.1-1
warning: libpulse: downgrading from version 11.1-3 to version 11.1-1
warning: libpurple: downgrading from version 2.13.0-2 to version 2.13.0-1
warning: libreoffice-base: downgrading from version 6.4.1-1 to version 6.4.0-1
warning: libreoffice-calc: downgrading from version 6.4.1-1 to version 6.4.0-1
warning: libreoffice-common: downgrading from version 6.4.1-1 to version 6.4.0-1
warning: libreoffice-draw: downgrading from version 6.4.1-1 to version 6.4.0-1
warning: libreoffice-en-GB: downgrading from version 6.4.1-1 to version 6.4.0-1
warning: libreoffice-gtk3: downgrading from version 6.4.1-1 to version 6.4.0-1
warning: libreoffice-impress: downgrading from version 6.4.1-1 to version 6.4.0-1
warning: libreoffice-kde5: downgrading from version 6.4.1-1 to version 6.4.0-1
warning: libreoffice-math: downgrading from version 6.4.1-1 to version 6.4.0-1
warning: libreoffice-postgresql-connector: downgrading from version 6.4.1-1 to version 6.4.0-1
warning: libreoffice-sdk: downgrading from version 6.4.1-1 to version 6.4.0-1
warning: libreoffice-sdk-doc: downgrading from version 6.4.1-1 to version 6.4.0-1
warning: libreoffice-writer: downgrading from version 6.4.1-1 to version 6.4.0-1
warning: libspnav: downgrading from version 0.2.3-1 to version 0.2.2-4
warning: libtasn1: downgrading from version 4.16.0-1 to version 4.9-1
warning: libvisio: downgrading from version 0.1.7-1 to version 0.1.6-1
warning: libvorbis: downgrading from version 1.3.7-1 to version 1.3.6-1
warning: nss: downgrading from version 3.52-2 to version 3.50-1
warning: openresolv: downgrading from version 3.10.0-1 to version 3.9.0-1
warning: p11-kit: downgrading from version 0.23.20-2 to version 0.23.8-1
warning: postgresql-libs: downgrading from version 12.2-1 to version 10.6-4
warning: pulseaudio: downgrading from version 11.1-3 to version 11.1-1
warning: python2-setuptools: downgrading from version 46.0.0-1 to version 36.6.0-1
warning: python3-setuptools: downgrading from version 46.0.0-1 to version 36.6.0-1
warning: python3-sip-pyqt5: downgrading from version 4.19.23-1 to version 4.19.19-2
warning: ruby: downgrading from version 2.4.10-1 to version 2.4.9-1
warning: sdl2: downgrading from version 2.0.12-1 to version 2.0.10-1
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: libreoffice-en-GB will be installed before its libreoffice-common dependency

Packages (37) ca-certificates-mozilla-3.50-1  curl-7.68.0-1  dbus-1.12.12-2  firefox-74.0.1-1  git-2.25.0-1  gnutls-3.5.19-1  jack-0.125.0-3  kdiagram-2.6.1-1  libpulse-11.1-1  libpurple-2.13.0-1  libreoffice-base-6.4.0-1
              libreoffice-calc-6.4.0-1  libreoffice-common-6.4.0-1  libreoffice-draw-6.4.0-1  libreoffice-en-GB-6.4.0-1  libreoffice-gtk3-6.4.0-1  libreoffice-impress-6.4.0-1  libreoffice-kde5-6.4.0-1  libreoffice-math-6.4.0-1
              libreoffice-postgresql-connector-6.4.0-1  libreoffice-sdk-6.4.0-1  libreoffice-sdk-doc-6.4.0-1  libreoffice-writer-6.4.0-1  libspnav-0.2.2-4  libtasn1-4.9-1  libvisio-0.1.6-1  libvorbis-1.3.6-1  nss-3.50-1
              openresolv-3.9.0-1  p11-kit-0.23.8-1  postgresql-libs-10.6-4  pulseaudio-11.1-1  python2-setuptools-36.6.0-1  python3-setuptools-36.6.0-1  python3-sip-pyqt5-4.19.19-2  ruby-2.4.9-1  sdl2-2.0.10-1

Total Download Size:    225.32 MiB
Total Installed Size:  1445.80 MiB
Net Upgrade Size:        -1.10 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...

 libtasn1-4.9-1-x86_64                                                                                       105.9 KiB   706 KiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 p11-kit-0.23.8-1-x86_64                                                                                     399.9 KiB  2.60 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 ca-certificates-mozilla-3.50-1-x86_64                                                                       328.2 KiB  4.01 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 curl-7.68.0-1-x86_64                                                                                       1018.2 KiB  3.68 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 dbus-1.12.12-2-x86_64                                                                                       292.2 KiB  4.76 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 nss-3.50-1-x86_64                                                                                          1453.7 KiB  4.73 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 libvorbis-1.3.6-1-x86_64                                                                                    291.9 KiB  4.75 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 libpulse-11.1-1-x86_64                                                                                      358.8 KiB  5.01 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 gnutls-3.5.19-1-x86_64                                                                                        2.3 MiB  5.05 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 sdl2-2.0.10-1-x86_64                                                                                        610.3 KiB  5.42 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 pulseaudio-11.1-1-x86_64                                                                                   1104.3 KiB  5.39 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 git-2.25.0-1-x86_64                                                                                           6.5 MiB  2.81 MiB/s 00:02 [------------------------------------------------------------------------------------] 100%
 jack-0.125.0-3-x86_64                                                                                       346.3 KiB  1385 KiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 libpurple-2.13.0-1-x86_64                                                                                     7.6 MiB  2.18 MiB/s 00:03 [------------------------------------------------------------------------------------] 100%
 postgresql-libs-10.6-4-x86_64                                                                              1251.1 KiB  5.31 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 libspnav-0.2.2-4-x86_64                                                                                       9.7 KiB  0.00   B/s 00:00 [------------------------------------------------------------------------------------] 100%
 openresolv-3.9.0-1-any                                                                                       21.6 KiB  0.00   B/s 00:00 [------------------------------------------------------------------------------------] 100%
 python2-setuptools-36.6.0-1-any                                                                             257.2 KiB  6.28 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 python3-setuptools-36.6.0-1-any                                                                             271.2 KiB  5.30 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 python3-sip-pyqt5-4.19.19-2-x86_64                                                                           54.1 KiB  1352 KiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 ruby-2.4.9-1-x86_64                                                                                           3.7 MiB  4.93 MiB/s 00:01 [------------------------------------------------------------------------------------] 100%
 kdiagram-2.6.1-1-x86_64                                                                                     649.9 KiB  4.88 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 libvisio-0.1.6-1-x86_64                                                                                     626.3 KiB  5.10 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 libreoffice-en-GB-6.4.0-1-x86_64                                                                              2.1 MiB  4.97 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 libreoffice-common-6.4.0-1-x86_64                                                                           109.6 MiB  3.81 MiB/s 00:29 [------------------------------------------------------------------------------------] 100%
 libreoffice-base-6.4.0-1-x86_64                                                                               4.1 MiB  5.01 MiB/s 00:01 [------------------------------------------------------------------------------------] 100%
 libreoffice-calc-6.4.0-1-x86_64                                                                               6.9 MiB  5.11 MiB/s 00:01 [------------------------------------------------------------------------------------] 100%
 libreoffice-draw-6.4.0-1-x86_64                                                                             202.1 KiB  4.93 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 libreoffice-gtk3-6.4.0-1-x86_64                                                                             415.9 KiB  4.51 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 libreoffice-impress-6.4.0-1-x86_64                                                                          568.1 KiB  5.04 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 libreoffice-kde5-6.4.0-1-x86_64                                                                             192.0 KiB  6.25 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 libreoffice-math-6.4.0-1-x86_64                                                                             378.1 KiB  5.27 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 libreoffice-postgresql-connector-6.4.0-1-x86_64                                                             224.5 KiB  5.48 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 libreoffice-sdk-6.4.0-1-x86_64                                                                             1929.7 KiB  5.38 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 libreoffice-sdk-doc-6.4.0-1-x86_64                                                                           17.6 MiB  4.75 MiB/s 00:04 [------------------------------------------------------------------------------------] 100%
 libreoffice-writer-6.4.0-1-x86_64                                                                             3.3 MiB  1789 KiB/s 00:02 [------------------------------------------------------------------------------------] 100%
 firefox-74.0.1-1-x86_64                                                                                      48.6 MiB  4.33 MiB/s 00:11 [------------------------------------------------------------------------------------] 100%
(37/37) checking keys in keyring                                                                                                         [------------------------------------------------------------------------------------] 100%
(37/37) checking package integrity                                                                                                       [------------------------------------------------------------------------------------] 100%
(37/37) loading package files                                                                                                            [------------------------------------------------------------------------------------] 100%
(37/37) checking for file conflicts                                                                                                      [------------------------------------------------------------------------------------] 100%
error: failed to commit transaction (conflicting files)
p11-kit: /usr/include/p11-kit-1/p11-kit/deprecated.h exists in filesystem (owned by libp11-kit)
p11-kit: /usr/include/p11-kit-1/p11-kit/iter.h exists in filesystem (owned by libp11-kit)
p11-kit: /usr/include/p11-kit-1/p11-kit/p11-kit.h exists in filesystem (owned by libp11-kit)
p11-kit: /usr/include/p11-kit-1/p11-kit/pin.h exists in filesystem (owned by libp11-kit)
p11-kit: /usr/include/p11-kit-1/p11-kit/pkcs11.h exists in filesystem (owned by libp11-kit)
p11-kit: /usr/include/p11-kit-1/p11-kit/pkcs11x.h exists in filesystem (owned by libp11-kit)
p11-kit: /usr/include/p11-kit-1/p11-kit/remote.h exists in filesystem (owned by libp11-kit)
p11-kit: /usr/include/p11-kit-1/p11-kit/uri.h exists in filesystem (owned by libp11-kit)
p11-kit: /usr/lib/libp11-kit.so exists in filesystem (owned by libp11-kit)
p11-kit: /usr/lib/libp11-kit.so.0 exists in filesystem (owned by libp11-kit)
p11-kit: /usr/lib/libp11-kit.so.0.3.0 exists in filesystem (owned by libp11-kit)
p11-kit: /usr/lib/p11-kit-proxy.so exists in filesystem (owned by libp11-kit)
p11-kit: /usr/lib/pkcs11/p11-kit-client.so exists in filesystem (owned by libp11-kit)
p11-kit: /usr/lib/pkcs11/p11-kit-trust.so exists in filesystem (owned by libp11-kit)
p11-kit: /usr/lib/pkgconfig/p11-kit-1.pc exists in filesystem (owned by libp11-kit)
p11-kit: /usr/share/p11-kit/modules/p11-kit-trust.module exists in filesystem (owned by libp11-kit)
Errors occurred, no packages were upgraded.

This tells me to report it as the files are owned, but they are owned by a package that is actually supposed to be downgraded, and other packages meant to be downgraded depend on it so I can’t just uninstall it.

What’s the right course of action for me now?

I’m wary of recommending this, but in your case you may need to use --overwrite in order to proceed.

I’m struggling with the syntax (well aware I haven’t included all folders/files yet, but this illustrates the problem well enough):

sudo pacman -Syyuu --overwrite /usr/include/p11-kit-1/p11-kit/*
[sudo] password for reemz:
:: Synchronising package databases...
 lib32                                                                                                       105.3 KiB   658 KiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 core                                                                                                       1691.9 KiB  3.67 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 desktop                                                                                                    1101.5 KiB  4.30 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
 gtk                                                                                                         154.2 KiB  5.02 MiB/s 00:00 [------------------------------------------------------------------------------------] 100%
error: target not found: /usr/include/p11-kit-1/p11-kit/iter.h
warning: '/usr/include/p11-kit-1/p11-kit/iter.h' is a file, did you mean -U/--upgrade instead of -S/--sync?
error: target not found: /usr/include/p11-kit-1/p11-kit/p11-kit.h
warning: '/usr/include/p11-kit-1/p11-kit/p11-kit.h' is a file, did you mean -U/--upgrade instead of -S/--sync?
error: target not found: /usr/include/p11-kit-1/p11-kit/pin.h
warning: '/usr/include/p11-kit-1/p11-kit/pin.h' is a file, did you mean -U/--upgrade instead of -S/--sync?
error: target not found: /usr/include/p11-kit-1/p11-kit/pkcs11.h
warning: '/usr/include/p11-kit-1/p11-kit/pkcs11.h' is a file, did you mean -U/--upgrade instead of -S/--sync?
error: target not found: /usr/include/p11-kit-1/p11-kit/pkcs11x.h
warning: '/usr/include/p11-kit-1/p11-kit/pkcs11x.h' is a file, did you mean -U/--upgrade instead of -S/--sync?
error: target not found: /usr/include/p11-kit-1/p11-kit/remote.h
warning: '/usr/include/p11-kit-1/p11-kit/remote.h' is a file, did you mean -U/--upgrade instead of -S/--sync?
error: target not found: /usr/include/p11-kit-1/p11-kit/uri.h
warning: '/usr/include/p11-kit-1/p11-kit/uri.h' is a file, did you mean -U/--upgrade instead of -S/--sync?

I’m fairly certain I’m just getting the syntax wrong here…

Right. Syntax was slightly off, and indeed one needs to be very specific and list the whole lot:

$ sudo pacman -S p11-kit --overwrite /usr/include/p11-kit-1/p11-kit/*.h,/usr/lib/libp11-kit.so*,/usr/lib/p11-kit-proxy.so,/usr/lib/pkcs11/p11-kit-*.so,/usr/lib/pkgconfig/p11-kit-1.pc,/usr/share/p11-kit/modules/p11-kit-trust.module

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.