After change of graphic output, Im not able to boot


(Jerome) #1

Hi everyone,

My graphic board had left me. So I chose to use the internal graphic of my mother board. Since that, Im not able to boot. I have these messages:

ACPI BIOS Error (bug): Failure looking up [\_SB.ALIB], AE_NOT_FOUND (20180105/psargs-364)
ACPI Error: Method parse/execution failed \_SB.PCI0.VGA.ATC0, AE_NOT_FOUND (20180105/psparse-550)
ACPI Error: Method parse/execution failed \_SB.PCI0.VGA.ATCS, AE_NOT_FOUND (20180105/psparse-550)

Can you help me to solve that problem ?

I have a A68HM GAMING mother board and using a DVI cable.
The mother board use Radeon HD 8470D for graphics.

Jerome


(brli) #2

Use a live system and try to chroot into your installed broken system.

Check that you have MODULES=(... radeon) in /etc/mkinitcpio.conf

If not, add it and recreate initramfs via # mkinitcpio -p linux inside the chroot

Reboot and test if it solves any problem.

Else, if the above is not the case, please let us know here.


(Jerome) #3

Hi brli,

Thank you for your help.
But nothing change ! I am still not able to boot.


(tom) #4

is xf86-video-amdgpu installed on your system?


(Jerome) #5

Hi Tom,

I don’t know. I though about this this morning after some researches on internet.
I remember tape a command in recovery mode where i have radeon driver for graphics something and nvidia for display server something.
How can I verify if I have xf86-video-amdgpu in recovery mode ?
And how can i install these driver in recovery mode ? I have internet only by WiFi with my cellular.


(tom) #6

to check if is installed is wasted time, if not install, then install it and if is installed, pacman will notify you

if not installed, connect to internet:

sudo pacman -S xf86-video-amdgpu

(Jerome) #7

In recovery mode I tape
sudo pacman -S xf86-video-amdgpu
But I need an internet connexion.
I don’t know how to enable my WiFi USB key in recovery mode with command lines.


(brli) #8

nmtui is a handy tool that mimic the graphical UI of NetworkManager


(tom) #9

https://community.chakralinux.org/t/how-to-start-a-simple-systemd-nspawn-container-for-system-rescue/7081/8

or start networkmanager perhaps works


(Jerome) #10

Under a liveUSB I used systemd-nspaw with a WiFi connexion. I’ve installed the driver and reboot. I still have the same problem. I can’t boot.
I think i’ll reinstall completely Chakra.


(brli) #11

I suggest you try xf86-video-ati first


(tom) #12

a good idea…but the installer first install all xf86-video* and then after setup will be the unneeded drivers removed…?


(brli) #13

iirc we’ve implemented the check removal list post the calamares installation, but maybe I’m wrong here.


(Jerome) #14

With a liveUSB and systemd-nspaw, I typed:

journalctl -p err^C

and get that result

sept. 21 01:38:08 jerome-pc systemd-coredump[498]: Process 493 (sddm) of user 0 dumped core.
                                                   
                                                   Stack trace of thread 493:
                                                   #0  0x00007f9bd33246b0 raise (libc.so.6)
                                                   #1  0x00007f9bd3325d07 abort (libc.so.6)
                                                   #2  0x00007f9bd3cca65b _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5)
                                                   #3  0x0000557774c8f8c8 _ZN4SDDM7Display5startEv (sddm)
                                                   #4  0x0000557774ca8a3a _ZN4SDDM4Seat13createDisplayEi (sddm)
                                                   #5  0x0000557774ca8ca0 _ZN4SDDM4SeatC1ERK7QStringP7QObject (sddm)
                                                   #6  0x0000557774caacbf _ZN4SDDM11SeatManager10createSeatERK7QString (sddm)
                                                   #7  0x0000557774cabb90 n/a (sddm)
                                                   #8  0x00007f9bd3ef4f7f _ZN11QMetaObject8activateEP7QObjectiiPPv (libQt5Core.so.5)
                                                   #9  0x0000557774ca9c0f _ZN4SDDM10LogindSeat19canGraphicalChangedEb (sddm)
                                                   #10 0x0000557774ca9d8e n/a (sddm)
                                                   #11 0x00007f9bd3ef4f7f _ZN11QMetaObject8activateEP7QObjectiiPPv (libQt5Core.so.5)
                                                   #12 0x00007f9bd4fd733f _ZN23QDBusPendingCallWatcher8finishedEPS_ (libQt5DBus.so.5)
                                                   #13 0x00007f9bd3ef59d2 _ZN7QObject5eventEP6QEvent (libQt5Core.so.5)
                                                   #14 0x00007f9bd3ec5ab1 _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5)
                                                   #15 0x00007f9bd3ec860d _ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData (libQt5Core.so.5)
                                                   #16 0x00007f9bd3f207d3 n/a (libQt5Core.so.5)
                                                   #17 0x00007f9bcea0ad47 g_main_context_dispatch (libglib-2.0.so.0)
                                                   #18 0x00007f9bcea0af80 n/a (libglib-2.0.so.0)
                                                   #19 0x00007f9bcea0b00c g_main_context_iteration (libglib-2.0.so.0)
                                                   #20 0x00007f9bd3f1fdff _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                                                   #21 0x00007f9bd3ec429a _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                                                   #22 0x00007f9bd3ecd1e0 _ZN16QCoreApplication4execEv (libQt5Core.so.5)
                                                   #23 0x0000557774c6f917 main (sddm)
                                                   #24 0x00007f9bd3310f2a __libc_start_main (libc.so.6)
                                                   #25 0x0000557774c6fbfa _start (sddm)
                                                   
                                                   Stack trace of thread 494:
                                                   #0  0x00007f9bd33dadeb __poll (libc.so.6)
                                                   #1  0x00007f9bcea0aef9 n/a (libglib-2.0.so.0)
                                                   #2  0x00007f9bcea0b00c g_main_context_iteration (libglib-2.0.so.0)
                                                   #3  0x00007f9bd3f1fdff _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
                                                   #4  0x00007f9bd3ec429a _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
                                                   #5  0x00007f9bd3cef01a _ZN7QThread4execEv (libQt5Core.so.5)
                                                   #6  0x00007f9bd4f7d555 n/a (libQt5DBus.so.5)
                                                   #7  0x00007f9bd3cf9dab n/a (libQt5Core.so.5)
                                                   #8  0x00007f9bd30d755a start_thread (libpthread.so.0)
                                                   #9  0x00007f9bd33e524f __clone (libc.so.6)
sept. 21 01:38:08 jerome-pc systemd[1]: Failed to start Simple Desktop Display Manager.

I’ll try to install xf86-video-ati


(Jerome) #15

I decided reinstall Chakra !
Thanks for everyone who tried to solve my problem !


(system) #16

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.